Router doesn't like torrents?
November 19, 2011 2:56 PM   Subscribe

Synology NAS can't torrent with new D-link router

I have a Synology DS110j NAS which could download torrents via its "download station 2" app, until my wireless router died. ISP sent us a replacement, a D-Link DSL-2680. Everything still gets on the internet ok, except my NAS can't download torrents any more. A torrent is added, it waits for a while, then eventually reports "Broken link". The same torrents on u-torrent for a PC connected to the router will download ok. Everything on the network sees the NAS's shares ok, eg streaming DLNA. If I swap in a borrowed router, the NAS can download torrents again. So I'm guessing there's some setting on the D-Link router which doesn't allow the torrents? I don't expose the NAS to the internet in any other way that torrenting. What should I be checking?
(The router is the only change I've made since the problem started, except I have put in a Netgear switch since getting the D-link router, as the router only has 2 ethernet ports,. But bypassing the switch does not fix the problem).
posted by wilko to Computers & Internet (3 answers total)
And FWIW: if I start a torrent on the NAS using a "good" router, then switch in my D-Link, the torrent's % progress will no longer increase.
posted by wilko at 4:13 PM on November 19, 2011

Can your NAS access the internet in any other way?

My NAS isn't the same as yours; it runs Windows Home Server. But what's important is that my Windows clients don't use TCP/IP to access my NAS. They use a different protocol.

So what I'm wondering is whether your problem is a symptom of a basic TCP/IP connect issue. For instance, maybe it can't get an IP from the D-Link's dynamic IP assignment. Or maybe it has a permanent IP and it's not on the same subnet.
posted by Chocolate Pickle at 4:34 PM on November 19, 2011

Problem solved, embarrassingly easily. As my two previous routers had been ok, I'd thought it couldn't be the NAS, so must be the cheap router I was using now. But going into the NAS settings and telling it to reset the network configuration has worked. Perhaps I fiddled with some setting there in the past. Anyway Chocolate Pickle's suggestion put me in the right place :)
posted by wilko at 5:46 PM on November 19, 2011

« Older Help me become a spreadsheet power user   |   Good Fantasy Critiques Newer »
This thread is closed to new comments.