Alive...dead...alive...dead
June 14, 2005 12:29 PM   Subscribe

My Internet connection develops narcolepsy whenever I use Azureus... strange symptoms inside

Here's the full scoop: when I start up Azureus (2.3.0.2, although I was having the same problems with earlier versions) with an active Internet connection (very fast cable broadband), it works really well for a little while-- this varies from a few seconds to an hour or so-- and I can sometimes even exceed 200 kb/sec down. So that's great. No complaints there.

The problem is that this NEVER lasts. At some point in the session, the connection goes completely dead. Literally nothing that uses the Internet from the same computer works (WWW, e-mail, IM, etc.). Other computers on the same router seem unaffected by this problem though. Then, to add to the strangeness, the connection will start up again once in a while and go at a good clip. Then of course, the cycle repeats itself.

I've got port 6881 forwarding on the router to my local IP, and sometimes I've gone so far as to even put my machine in the DMZ to see if this fixes the problem, which it never does. This doesn't sound to me like my ISP throttling my connection, since it's so sporadic.

Oh, one other piece of information, when I disconnect and reconnect to the router, that often helps, although it never solves the problem. I just get a brief respite.
posted by yellowcandy to Computers & Internet (16 answers total)
 
[Oh, and I booted up Azureus while writing this post to make sure I had the version number correct, and guess what just happened again? Help!]
posted by yellowcandy at 12:36 PM on June 14, 2005


I had the same problem with Bittorrent.

If you have a Netgear router, go into the security section of the router configuration and turn off SPI. See if that takes care of it.
posted by bondcliff at 12:38 PM on June 14, 2005


I've run into similar problems with various bittorent programs when my upload bandwidth gets maxed out (although in my case, all machines on my LAN are affected). Try setting your max upload speed in Azureus to something around 5 or 10 KB/s below the max allowed by your ISP. That leaves enough 'room' for other outgoing requests to squeeze through.
posted by nixxon at 12:39 PM on June 14, 2005


Turn off the distributed db stuff.
posted by stx23 at 12:39 PM on June 14, 2005


I have the same problem with my BitTorrent client of choice. I never had problems until last month. I like to blame my ISP (Adelphia) just because I don't like them, but I don't know what is really causing it. Like you, things will work fine for a while before my whole internet connection suddenly dies. For me, reseting the cable modem will bring back the connection immediately, but the same thing will happen again later. Lately, I've noticed that it seems to be ok as long as my computer doesn't go idle while I'm downloading.
posted by geeky at 12:50 PM on June 14, 2005


Try uninstalling both Azureus and whatever JRE you have, then installing the newest JRE and the newest Azureus. Make sure the distributed db is off. I had the exact same problem and this fixed it.
posted by Optimus Chyme at 12:51 PM on June 14, 2005


I had to switch to ABC, Yet Another BitTorrent Client. Evrything works fine now.
posted by jsavimbi at 12:57 PM on June 14, 2005


I get the same thing with Azureus 2.3. SMC router, DSL line. AFAIK it is all configured correctly. I use a not-6881 port in an attempt to deke out any ISP limits.

I'll be turning off distributed db to see if that helps.
posted by five fresh fish at 3:24 PM on June 14, 2005


My DSL gateway (Qwest) is a real piece of crap, and suffers from the same problem. Thankfully, it only happens every 12 hours or so, so it's managable. I've replaced it with a temporary, QUALITY gateway and all worked well. If you can't afford a decent gateway, try upgrading your firmware. Also, try to throttle back your DL & UL speeds to well below your bandwidth and slowly raise them every hour or so until you find a comfortable level. As as side note, I would also reccomend changing the BT port you are using to ANYTHING other than 6881, as most ISPs are aware that it is the default BT port and throttle it back ALOT. Choose something up in the 5 digit port numbers, just something random like 54883. You should immediately notice a good jump in BT bandwidth, provided your ISP doesn't scan at the packet level for BT traffic.
posted by rabble at 3:39 PM on June 14, 2005


Make sure you have Azureus' Auto Speed Plugin installed. For some reason it's not installed by default but it's easy enough to add. Assigning some random port is also a good idea, although a time is coming -- very soon -- when this won't help much.

I regularly get 500K/s download speeds, but only if I don't saturate my upstream channel.

I occasionally had hanging problems with my SMC Barricade, but disabling the cheesy built-in denial of service protection (and SPI in general) reduced those to nearly nonexistence. Now the only connection problems I have are when the Barricade overheats, which it does tend to do.
posted by majick at 4:42 PM on June 14, 2005


If you have a Netgear router, go into the security section of the router configuration and turn off SPI.

Ugh. I was wondering why I had to reboot my router every few days to get it to stop acting retarded. Thanks.
posted by kindall at 5:58 PM on June 14, 2005


Azureus did similar for me. I blamed the java engine, possibly wrongly. Now using BitComet without problems.

Note that ISPs are getting cleverer at throttling ... bittorrent streams are easy to identify. This will only get worse, so gather ye roses whilst ye may.

As rabble and majick said, don't saturate your connection. BitComet makes it easy to control bandwidth use per torrent, which wasn't possible when I was using Azureus tho it may be now.
posted by anadem at 6:31 PM on June 14, 2005


The SPI fix did nothing on my Netgear router. I switched to a Linksys and am having zero problems. Like you, Bittorrent downloads would cause the router to reboot every 10 minutes. It was horrible.
posted by exhilaration at 3:10 PM on June 15, 2005


Update here: I turned off Distributed DB, with little effect. I don't have a Netgear router, so the SPI solution wasn't relevant. I did download and install the Auto Speed Plugin, which works, but I am still having the dead connection issues.

Changing ports doesn't seem to make much difference either. I'm really baffled here. Really and truly.
posted by yellowcandy at 4:41 PM on June 15, 2005


Under some operating systems (Windows in particular, but there are others), Azureus can be a bit more aggressive with connections than the underlying network stack can support. Reduce the number of sockets that Azureus tries to maintain. In the settings, under Connection set "Max simultaneous outbound connections" to some especially small number, like 32.

Under Transfer, set "Maximum number of connections globally" to something small like 32 as well.

If the problem goes away, raise these figures until it breaks again. Now you know the magic number.

Doesn't help? Try installing a reasonably recent JRE, such as Sun Java 1.4.2 or Java 1.5.
posted by majick at 7:04 PM on June 15, 2005


Disabling the DB seems to have done the trick on my system! Hallelujuah!
posted by five fresh fish at 11:46 AM on June 17, 2005


« Older Blogging 101   |   Adorno quote Newer »
This thread is closed to new comments.