Join 3,366 readers in helping fund MetaFilter (Hide)


How can I get my Macbook to stop disconnecting from the Internet?
August 25, 2007 9:52 AM   Subscribe

Why does my Macbook keep losing it's wifi connection?

I have a Macbook that I've been using for months and just recently started having this problem where the Airport suddenly says it's losing signal and the internet stops working. I have to turn the airport off and on to get it to come back, but even then it will often stop again within a few minutes. It seems to work perfectly on other connections, but just has problems with my router (which it had always worked with before). My roommate's computers still work just fine (tried both mac and PC), so I'm having trouble figuring it out. I have a Zyxel X-550 Xtrememimo router and have tried resetting it to default settings, rebooting it, and disabling encryption, but nothing seems to work. Any ideas?
posted by fishmasta to Computers & Internet (13 answers total) 4 users marked this as a favorite
 
I had the same problem with my macbook pro. It was caused by one of the OS updates (10.4.9 maybe?), but another software update (either 10.4.10 or maybe a special wireless update) fixed it for me.

Try checking for updates (in the Software Update panel of System Preferences) and install whatever's there... hopefully that will fix it for you.
posted by stilly at 9:57 AM on August 25, 2007


I'm up to date with all the updates (10.4.10), so that's not it.
posted by fishmasta at 10:02 AM on August 25, 2007


I just looked more closely in my computer, to figure out what I meant in my previous post and get the actual information. For me it was actually 10.4.10 that broke wireless, and then a separate update called AirPort Extreme Update 2007-004 (installed on 7/31/07) that fixed it. To see if you have already installed it, go to Software Update and click on the "Installed Updates" tab. If you haven't installed it yet, that could be your fix. Otherwise, I don't know what to say....
posted by stilly at 10:33 AM on August 25, 2007


Make sure you have "use interference robustness" checked in your wifi menu.

also try repositioning the antennae of your wireless router
posted by softlord at 10:34 AM on August 25, 2007


I have the AirPort Extreme update installed, and interference robustness was on. I've tried moving the router antennae, but it doesn't seem to be the problem. It happens even if I'm in the same room looking right at it.
posted by fishmasta at 10:38 AM on August 25, 2007


Go into: Apple Menu > System Preferences > Network

Click on the "Airport" tab.

Where it says "By default", if you have "Automatic" selected, change this to "Preferred networks" and add your network.
posted by Blazecock Pileon at 11:10 AM on August 25, 2007


Two things that might help: If you're seeing a lot of other access points, you might be getting channel interference. Try changing the channel on yours (by at least 3 channels).

If you have a b/g access point, and you don't have older, b-only equipment that uses it, see if you can use the access point's admin interface to turn off the b radio.
posted by dws at 11:54 AM on August 25, 2007


VMWare Fusion has a bug with Bridged networking (Where your VM gets it's own DHCP address from the main DHCP server on your network). The fix is to use "NAT" networking.

You didn't mention if you had VMWare or not, but it's not something you'd obviously see a correlation between unless you really start paying attention.
posted by jeversol at 12:50 PM on August 25, 2007


I asked a similar question and was never able to resolve it.
posted by proj at 1:07 PM on August 25, 2007


My Mom had this problem with her iBook. It turned out to be that the connection between the wireless card and the computer was loose. The guy at the Apple Store inserted the wire to the card more firmly and it works fine now.
posted by MarvinTheCat at 1:14 PM on August 25, 2007


I had this problem about six weeks ago. For me, it was the 10.4.10 update. The nice guy at Applecare said he was getting tons of phone calls and that a fix would be out soon.

I don't know if the fix has come out, although I've noticed another update (same as Stilly), or because I'm on a different wireless access point now.

In the meantime, two things to help work around -
1) run off the power cord.
2) As soon as you notice the wireless drop, shut the lid and reopen it. Sometimes if I'm fast, I can get airport to reset before my terminal ssh connection times out.

If running off the powercord ends the problem, then it will help you determine if it's the update issue or another issue.
posted by arabelladragon at 1:52 PM on August 25, 2007


I had the same problem, using WPA2 personal - I switched from TKIP to AES, and enabled SSID broadcast, and the issue went away.
posted by aberrant at 3:12 PM on August 25, 2007


Well, I don't know which setting change did it, but trying all this stuff somehow seemed to fix it. Thanks everyone.
posted by fishmasta at 6:40 PM on August 25, 2007


« Older Looking for guidelines, princi...   |  What is a good, web 2.0, alter... Newer »
This thread is closed to new comments.