Skip

All sorts of WiFi connectivity issues. I think it's my router.
February 9, 2010 8:45 PM   Subscribe

After 4 months of smooth sailing, my WiFi has started acting up and (first temperamental page loading; then lock icon disappears when connecting to my secure network; now work computer won't connect at all). Is it my ISP, router, computer, or something else?

I bought a new router when I moved into my apartment last August. It's a Belkin Wireless G; Time Warner Cable supplies my service; and my computer is a MacBook running 10.5.8. Setting everything up back then was a breeze, and I never had any WiFi troubles. Things started going awry on January 1st, and I've been in various circles of Hell ever since.

For the first two or three weeks in January, I started having a problem almost exactly like the one described in this post. Some sites would load with no problem, every time I tried (typically big ones, like all Google and Gawker Media sites). Others would simply refuse to load. The sites that would not load seemed very random, and were different every time I restarted my computer; turned my airport off and on; reset my router; or unplugged and re-plugged my router. For example, sometimes MetaFilter would load, and other times it would not. The problem sites would always fail immediately (displaying a "Problem Loading Page" message), rather than trying to load first and then giving up. The problem was the same across browsers (Firefox, Safari, Chrome), and computers (my best friend's MacBook, my work MacBook). The comments to the post I linked to were very helpful, but nothing cured my situation.

Finally, I called Belkin out of frustration. They were very nice and walked me through re-setting up my network, step by step, using an ethernet cable, renaming the network, setting a new password (WEP), etc. My WiFi was working again!

The only strange thing: I started noticing something like the issue described in this MacRumors post: Whenever I turn my computer on or wake it from sleep, it defaults to an open network that isn't mine. When clicking on the AirPort icon, my network is displayed – among the others – with a lock icon next to it. When I select my network, my computer connects (the password is stored in my keychain). But: when I'm connected to my network, the lock is gone when I click on the AirPort icon and view my network in the list. Since switching to Mac in 2006, I have never been connected to a secure network and seen the lock disappear. The most I can glean from that forum thread is: "Yes, it appears that this is happening to you. Huh. Interesting." No other explanation.

I might have been able to live with this entire strangeness. Except: Tonight when I tried connecting to my network using my work computer (a MacBook running 10.6.2), I wasn't able to connect. I typed in the correct password, but my network's status under System Preferences says that my computer has a self-assigned IP and cannot connect to the Internet. The AirPort icon is greyed-out, with an exclamation point in it (I can take screenshots of any of this if it will help). Before January 1st, I was always able to connect to my home network from this same work computer. No settings have been changed on it (and unfortunately I can't get in there to fiddle around anyway because I don't have admin access).

I called Belkin in a panic again. The gentleman I spoke with didn't seem to understand the Mystery Of The Disappearing Lock, nor could he help me with my connectivity issues from my work computer – he kept adamantly saying that it was a problem with my computer, and that I should contact Apple for help. This may be true, but scheduling a call with an Apple expert could be problematic since my work schedule is very unpredictable and I most probably would have to be in my home, ready to tinker, in order to walk through anything with a representative.

Now, I haven't been able to find a single thing online or a single person to help me with this. Sir Belkin also adamantly told me that no it is not my service provider that is the problem (and he's probably right – hardwired, everything works perfectly). Does anybody know what could possibly be causing this? Let me know if I can provide any more information, or, as I said, screenshots of any of these recent happenings.

Anybody who can shed some light on this issue: thank you so much in advance; my sanity will thank you as well.
posted by aquanet to Computers & Internet (3 answers total)
 
To get your home Mac to automatically connect to your network rather than your neighbor's open network, go into Network Preferences (from the Airport icon) and select "advanced" where you should see the list of preferred network. Either delete that open network from the list or make sure your named network is toward the top of the list (you can drag the network names up and down in order) so the Mac will know your network is the preferred.

The look missing from the network name is a head scratcher. If you hold down the option key while you click on the airport icon, does it list the security that it is connected with?

As far as why your grayed out Airport icon on your work computer, I saw that once and I nuked the airport prefs, rebooted my system and when it came back the network was there.

in /Macintosh HD/Library/Preferences/SystemConfiguration/ look for com.apple.airport.preferences.plist and put it in the trash. When you reboot you may need to select your network name from the list.

[Also, you really should use WPA2 security rather than WEP...more secure and at least for me less problems with connections]
posted by birdherder at 9:24 PM on February 9, 2010


I had intermittent, ill-defined problems with a home network setup once and like you, focused on the software/ISP side of the equation looking for solutions. Nothing changed until I took a close look at the house phone wiring and found a loose connection.
posted by telstar at 1:21 AM on February 10, 2010


@birdherder : I was able to take a screenshot of the security information in my AirPort drop-down: click here to view.

I can't change any AirPort preferences on my work computer because I don't have admin access, but I will bring this up with someone who does have access and see what we can do with that. Thanks so much for your help.

I also read somewhere else that I should change my security to WPA2, and I did. Thanks for that as well.

@telstar : Unfortunately, I rent in a big apartment building; I might try catching my neighbors in the hallways to see if they've been experiencing anything strange with their connections as well. I can contact the landlord if yes. Thanks!
posted by aquanet at 12:26 PM on February 10, 2010


« Older Weather permitting, I am going...   |  Looking for graffiti in Melbou... Newer »
This thread is closed to new comments.


Post