Why oh why won't my Macbook Pro connect to the wireless Internet after sleep?
November 3, 2008 11:59 AM   Subscribe

Why oh why won't my Macbook Pro connect to the wireless Internet after sleep?

First and foremost, this is definitely an issue with the Macbook. We have 2 PCs (desktops), 3 game systems and 2 Tivo's using the router (wired and wireless) without issue. We've also used a Windows laptop on the router, and aside from the occasional dropped connection, it worked fine as well.

We had a Netgear G router for 4 or 5 years that the Macbook worked just fine with, even after I dropped the Macbook hard enough to dent it once (oops). But recently the Netgear router died, so we bought a replacement: a DLink DIR-655 Wireless N Router. I went through the usual setup pains trying to get the router configuration just right so that all of our various machines could get on the Internet. Now we're at the point where everything works fine, except for the Macbook.

The Macbook will connect to the router, get an IP, and work as expected after a fresh boot. I'll close the lid to put the Macbook to sleep, but when I open the lid later, where the Macbook would automatically get a working connection before, there's now anywhere from a 40% to 70% chance that I'll actually get a working connection, even when manually connecting or trying any of the things listed below under "Things that sometimes work" and "Things that always work". The airport card is working. It picks up the SSID from the router, connects to the router, indicates it is "getting status", gets a self-assigned IP address, and then eventually drops the connection. It never gets a valid IP address from the router. Except sometimes when it does. Even though I'm not changing any settings on the router or Macbook. Once I do eventually get a valid IP and working connection, it's rock solid. See how frustrating this is?

Here are the facts and specs:

Router:
DLink DIR-655 Wireless N Router
G only
manual channel
broadcasting SSID
WPA - Personal / WPA - TKIP

Macbook Pro 3,1:
OS X 10.4.11
2.4GHz Intel Core 2 Duo
Airport Extreme 1.4.4

Attempted Fixes:
Setting router to one manual channel
Running permissions repair
Setting manual IP on Macbook and reserving IP on the router
Installing updates and patches on Macbook
Updating firmware on router
Deleting com.apple.internet*.plist files
Deleting all preferred networks
Deleting all keychain entries
Set "By default, join:" to Automatic or Preferred Networks
Turned off IPv6

Things that always work:
Rebooting Macbook
Rebooting router

Things that sometimes work:
Turn off/on airport card
Running Diagnostics

I've been a PC girl most of my life, so I freely admit I'm not a Mac expert. Is there something I'm missing here? Please help me get my Macbook's wireless connection back to normal before I throw it into a wall! I've extensively searched the internet for solutions and spent an inordinate amount of time attempting to fix the problem, but so far no dice. I'm hoping there's a Mac genius lurking on MeFi that can come to my rescue. Is there anything else I can try to fix this problem, or should I just resort to buying a new router?
posted by geeky to Computers & Internet (11 answers total) 3 users marked this as a favorite
 
um i feel your pain. i have similar issues to yours i think, something that i do wirelessly suddenly kills the network and my computer has a "self assigned" IP. The only thing that ever fixes it for me without calling for tech support is pluggin the computer via ethernet cord directly into the router and using it that way for a little while. then it seems to reset itself and i can usually get onto wireless after that. sorry for the nontechnical answer but i'm a nontechnical kind of girl.
posted by Soulbee at 12:05 PM on November 3, 2008


Your settings all look fine, and one of those attempted fixes should be necessary.

I'm going to go out on a limb and blame the DLink router, despite lack of any data at all. Instead, I give you the Power of Anecdote: Every single Mac-on-wireless-network issue I've ever had has been with DLink products. In a couple cases, I even swapped in a Linksys on the spot and poof! problem vanished. I don't think those DLink folks test with Macs much.

As a coping strategy from now until you believe me, try using the menu bar thingie to flip the Airport "Off" and then back "On". That's faster than disable/enable in the Preferences, and might help you get through it.
posted by rokusan at 12:17 PM on November 3, 2008


I had a very similar problem and fixed it by deleting all the .plist files having to do with the airport or networking stuff.

See: http://forums.macnn.com/92/networking/363970/leopard-will-no-longer-remember-wireless/last-post/ and http://forums.macrumors.com/showthread.php?t=125311
posted by paanta at 12:18 PM on November 3, 2008


I agree with the idea that it might be the D-Link router that's the problem here. When I troubleshoot a problem, the first question I ask is, "What has recently changed?" knowing that often the answer I'm given will point me to the whatever is causing the problem. Despite what many people think, computers and operating systems don't just decide to stop working one day. If it was working fine yesterday, and is not working today, then there's a change made somewhere that needs to be investigated.

As you imply that the problem didn't start occurring until you replaced routers, I'm going to point to the router as the problem. There are several ways you can test this:

1) Take you MacBook to another location with wireless and see if the problem persists. Make note of the wireless network and equipment.
2) Buy another wireless router. Best Buy has a generous no-questions-asked return policy. I once went through 7 routers (five brands) at a client's house trying to find the optimal wireless solution for his unusual layout and circumstances. There's no reason you can't go buy a different router, try it out, and then return it if it doesn't work.
posted by mrbarrett.com at 1:06 PM on November 3, 2008


Switch your WPA encryption to AES/WPA2. I've had better luck with that setting. It's also possible that you need the "N Enabler" patch apple was selling for 5 bucks (I would only suggest that as a last resort since I think selling it is cheesy).
posted by chairface at 1:20 PM on November 3, 2008


I feel your pain a million times over.
We have a MacBook with a similar problem.

We found that running iStumbler all the time keeps the connection open for some reason.

It is the only thing we found that fixes it (after doing all the other magic people have suggested except the plist edit, we'll have to try that one also)

It's an Apple problem that's been around for months, I hope they fix it soon.
posted by bottlebrushtree at 1:26 PM on November 3, 2008


rokusan I'm tempted to agree. Thanks for the tip, but unfortunately most of the time even flipping the airport on/off doesn't bring the connection back.

mrbarrett.com You're correct, the problem did not start until we replaced the router. I'm thinking at this point that the Macbook just doesn't get along with the DLink router, but unfortunately I'm past my 30 day return window, which means I'll have to shell out another $100 (+/-) for a new router which I really, really don't want to do.

chairface Hmmm, I think I might give that a try. The problem did seem to clear up initially when I removed all encryption, so maybe WPA is the problem here. However, I think my craptacular wireless card in my ancient desktop only does WPA. I'll look into it.

bottlebrushtree Well that gives me at least a little hope! Thanks, I'll give that a shot too.
posted by geeky at 2:07 PM on November 3, 2008


What I did to solve this problem was to hardwire another brand (microsoft) of router up to my DLink and then log on to that router. It was a $30 fix but it works.
posted by ptm at 6:35 AM on November 5, 2008


Well, I tried installing iStumbler but that didn't do much, if anything. In fact, I was never able to connect to the router through iStumbler at all, and just running it in the background didn't seem to help revive the connection after sleep.

I haven't had a chance to fool with the encryption yet, as that usually takes many hours to get everything working together. Hopefully in the next couple of days...

ptm Could you explain a bit more? Was the second router a wireless router? Was it between the modem and the Dlink, or the last router in the chain?
posted by geeky at 7:33 AM on November 5, 2008


Just coming back to say that I changed our wireless encryption to WEP and everything is working fine again. Problem solved (sorta).

Apparently something about the combination of Macbook Pro + DLink Router + WPA = FAIL.
posted by geeky at 10:37 AM on November 20, 2008 [1 favorite]


I was having this problem as well with my MBP. I went into the Library/Preferences/SystemConfiguration and deleted com.apple.airport.preferences.plist and everything's been aces since.

Thanks, AskMeFi!
posted by fenriq at 2:00 PM on March 16, 2009


« Older The old conundrum: How do you ...   |  Where to watch the returns in ... Newer »
This thread is closed to new comments.