Minor Safari inconsistency
June 7, 2006 9:38 AM   Subscribe

Why this minor Safari inconsistency between machines with exact same build of Safari?

I have two intel Macs, an iMac and a Macbook. They both are running Safari 2.0.3 and both are the same build--- 417.9.3. When trying to download the Universal Build of Fuzzy Clock (which isn't typed properly--- Safari sees it as a text file and adds a .txt extension on both machines), on the Macbook, I get a "Save linked file to inbox" option in the contextual menu, which does just that. The file doesn't show up in the download window. On the iMac, however, I get a "Download linked file" message, and it goes through the download window. (Also ends up in the "inbox" folder.) Why would the two machines be different? They have the same version of OS X, but different build numbers (the iMac is 8l1119 and the Macbook is 8l2025).

This is just a headscratcher for me. Maybe one of you wizards know the answer.
posted by yesno to Computers & Internet (10 answers total)
 
I just have "Download linked file".

Perhaps one machine has a contextual menu plugin installed which is changing the menu, and one doesn't? Or one of the Safari-altering programs like Pith Helmet or Saft?

You could also try making a new user on each machine (which would give you brand new preferences) and see what happens when running as that user.
posted by xil at 10:18 AM on June 7, 2006


There are no plugins, and the behavior is the same on my girlfriend's accounts on both machines (which have not had their preferences altered). I'm thinking now it must be OS specific, maybe something with WebCore.
posted by yesno at 10:22 AM on June 7, 2006


Also, since the Macbook is maybe a week old, you would not be likely to see the different behavior because you are likely on an older OS build, like my iMac is.
posted by yesno at 10:24 AM on June 7, 2006


What "inbox" does it save it to then?
posted by bonaldi at 10:37 AM on June 7, 2006


Both Safaris successfully get the file in question, just by different means, one as a download (iMac), and one the way you'd save a web page (Macbook). And both go to a folder I have called "inbox"--- a different one on each machine--- which is just where I plop downloads and random temp files, etc.
posted by yesno at 10:58 AM on June 7, 2006


bonaldi, I think yesno meant "desktop", not inbox. I get the same behavior, but I always thought I was confusing Firefox and Safari.
posted by ontic at 12:08 PM on June 7, 2006


On my Macbook, I get the "correct" behaviour -- as a download, in the downloads window, etc. I have the same OS X build as you.

I can't replicate your behaviour at all. It won't stay in the downloads window if you've got Private Browsing on, but that doesn't affect the contextual menu. It's not the Finder types either, because setting all .txts to open with Safari doesn't affect it. Sorry
posted by bonaldi at 5:36 PM on June 7, 2006


It means it's in Safari's web cache on the Macbook but not on the iMac. Go to the 'Safari' menu on the Macbook, choose 'Empty Cache...' and it'll say 'Download Linked File' again.
posted by boaz at 6:03 PM on June 7, 2006


Boaz: Thank you very much! It got in the cache in the first place because I clicked on it, and it tried to display as a text file, due to its bad typing or whaddayacallit. I never did that on the iMac. Clearing the cache on the MB gives the same behavior as the iMac. Mystery solved.

(ontic, I didn't mean Desktop--- I wrote "inbox" because I send all of my downloads to a folder named "inbox," not to the Desktop, which I don't like to clutter.)
posted by yesno at 6:31 PM on June 7, 2006


Ah, for me it was desktop. Thanks, boaz, for explaining this puzzle.
posted by ontic at 10:15 AM on June 8, 2006


« Older Sheltering personal assets and making personal...   |   Longer than these great walls of China? Newer »
This thread is closed to new comments.