Skip

Disable "Inline Search" in Safari 4 Beta for Mac
June 7, 2009 1:19 PM   Subscribe

Is possible to disable "find in page" on Safari 4 Beta?

Hi,

I hate that the "find in page" is activated by just typing anything in the page instead of Cmd+F and then search.

On some pages that requires some keystrokes to do some actions it's annoying.

Do you know if it can be disabled to use only the Cmd+F and search box instead?


(Also I'm worried if it's a plugin I've installed functionality, so please confirm me if you're experiencing the same thing or it's only me)
posted by Leech to Computers & Internet (14 answers total)
 
only you
posted by mpls2 at 1:21 PM on June 7, 2009


only you - mac mini, 10.5.7, latest safari 4 beta. That would really wind me up...
posted by derbs at 1:22 PM on June 7, 2009


All i can think it is, is something like quicksilver, or similar
posted by derbs at 1:24 PM on June 7, 2009


Look in /Library/InputManagers and $HOME/Library/InputManagers which is the 2 locations that such extensions typically reside in.
posted by flif at 1:49 PM on June 7, 2009


Just to be sure, this is what I'm talking about:
http://img194.imageshack.us/img194/702/safari.png
It appears when I've just started typing "dis" anywhere in the page.

I'll try disabling plugins and see what happens.
posted by Leech at 1:55 PM on June 7, 2009


From that screenshot, it looks like the grey find bar is dropped down (the one that only normally appears when you press CMD-F). Is it always dropped down, or does it drop down when you start typing? What happens when you click the "Done" button in the bar and then start typing?
posted by derbs at 2:13 PM on June 7, 2009


It drop down when I start typing anywhere except form fields.

As you can see it's really annoying.
posted by Leech at 2:17 PM on June 7, 2009


I get that, and the only funny thing I'm running is Glims (bugs me too, come to think of it). Are you running that, and can you find a preference to shut it off?
posted by roombythelake at 2:21 PM on June 7, 2009


Yeah, if it is Glims, go to Safari menu, go to Preferences, Glims tab, Misc section, and deselect "Auto select browser search banner (type ahead support)". That stops it for me.
posted by roombythelake at 2:25 PM on June 7, 2009


It's got to be fiwt - Safari find as you type, part of SIMBL

link
posted by derbs at 2:26 PM on June 7, 2009


Awesome, it was Glims.

Thanks everybody!
posted by Leech at 2:30 PM on June 7, 2009


Did you find a way of turning this off in Glims, or did you have to uninstall it all together?

I don't see a preference for the feature in the Glims settings.

-Michael
posted by mpmchugh at 5:39 PM on July 1, 2009


oops... found it. somehow missed the preference description above.

Thanks!

-mpm
posted by mpmchugh at 5:44 PM on July 1, 2009


I'm having the opposite problem. I came upon this thread because I want the find as you type function in Safari and I can't figure out how to enable it. I tried downloading SIMBLE and Gims but I'm still finding that I need to press apple+F to do a search. How did you get it to go the other way?
posted by baronessa at 12:56 PM on February 20, 2010


« Older Sudden facial and joint rash a...   |  Tao Te Ching in rhyming meter?... Newer »
This thread is closed to new comments.


Post