Join 3,524 readers in helping fund MetaFilter (Hide)


Why does Microsoft Word always come to the foreground on Mac?
May 6, 2014 7:55 PM   Subscribe

For some recent while, probably since updating the OS X Mavericks, Microsoft Word for OS X keeps coming to the foreground on its own when I'm doing other things, as long as a document is open in Word. If I click out to the Finder, Word makes itself the frontmost program. If I click into the browser, Word comes forward.

If no document is open, Microsoft Word stays in the background.

Can anyone tell me why and suggest what I may do about it? Running Microsoft Word 2011 14.4.1 (140326) and OS X 10.9.2.
posted by Mo Nickels to Computers & Internet (15 answers total) 2 users marked this as a favorite
 
Oh god, there is a version of this bug in Word 2008 for Mac as well. Look at your icons in the top bar of Word: when it comes to the foreground, are they still greyed out, like you can't click close, minimize, or maximize?

This is incredibly irritating, and I never found a fix. My solution was to command-H word until I needed it. Annoying, I know. Sorry!
posted by sevensnowflakes at 8:13 PM on May 6 [1 favorite]


Is it maybe because it is auto-saving the document every few minutes? If you disable auto-save, does the behavior continue? Just trying to think of what might be making Word take action unprompted.
posted by xedrik at 8:26 PM on May 6


Autosave is set to every 10 minutes; this happens consistently and constantly with no timetable.
posted by Mo Nickels at 8:28 PM on May 6


Do you use spaces? There's some discussion of a spaces problem with Office 2011 and Mavericks online.
posted by Mad_Carew at 8:32 PM on May 6


No, I don't use spaces or any other virtual desktop.
posted by Mo Nickels at 8:34 PM on May 6


X11/Quartz does this when I'm using R to make figures. My sol'n is to Apple-H to hide the application, while it is making figures.
posted by Blazecock Pileon at 8:51 PM on May 6


That's odd. I have the *exact* same versions as you: Microsoft Word 2011 14.4.1 (140326) and OS X 10.9.2. And I am not seeing a problem. I know that doesn't sound helpful but I'm willing to check for any differences on my end....
posted by vacapinta at 2:06 AM on May 7 [1 favorite]


Also to be more specific I have OSX 10.9.2 (13C1021) and I have been running it a while. I only upgraded Word from I think 14.3.6 to 14.4.1 recently.
posted by vacapinta at 2:22 AM on May 7


We're running that version of Word on various machines from 10.6.8 to 10.9.1 and nobody is reporting this behaviour. It might be happening for someone in the office, but not for me on 10.6.8 or 10.8.5 and I think I would have heard if it was doing it for anyone else.

Can you turn Auto Save off temporarily to see if it stops?
posted by mewsic at 3:28 AM on May 7


Exact same set-up as vacapinta and not seeing the problem. I have both the wretched ribbon and Customer Experience feedback thing turned off. Have you?
posted by TheRaven at 5:50 AM on May 7


I have this weird thing where I switch between programmes and the wrong programme comes to the front (ie not the last but one I was using) - so when I go to a programme, open it, do something and then close it it won't go back to whatever was at the front before I did that. It's really annoying. It did it for finder (opened a finder window whenever I shut a programme) for a while but seems to do it randomly now. Often finder, but also other programmes. I don't have or use Word.

Could it be the same thing, but you just notice it a lot more when it is Word? So the phenomenon is real but it actually being Word causing it is a touch of confirmation bias?
posted by Brockles at 8:18 AM on May 7


First step is to try running Word as a different user and see if you still have issues. If you don't, you know there's something wrong with your Home folder, with a couple places to possibly delete:
~/Library/Preferences/[look for .plist files with microsoft] --This is where I usually find error with weird issues like this.
~/Library/Application Support/Microsoft/
~/Library/Microsoft/

(~/Library may be hidden by default in later OS's. With finder open, use the command "Cmd+Shift+G" and go to folder "~/Library")
As always, beware of deleting files. I work with machines where I don't care if I blow them up, so I tend to delete indiscriminately.
posted by jmd82 at 8:18 AM on May 7


I am also running the latest versions of Mavericks and Office on an iMac, not seeing this behaviour. Have you looked to see if anything is being logged to the Console? Does this behaviour occur if you use the Finder to switch between programs rather than clicking on a window?

(Also, not that I have ever known it make a difference, ever - have you tried repairing disk permissions?)
posted by epo at 10:11 AM on May 7


I did check console and there was nothing of note there.
posted by Mo Nickels at 3:24 PM on May 7


How long have you had the computer? Upgraded from earlier versions of OS X or Office? Check your Library/Application Data/Microsoft folder, and if you did have older versions of Office, kill their respective folders. I had some weird issues that popped up because of old Office 08 preferences/settings. I mean, it shouldn't make any difference, right? Except Microsoft. For some reason. I just don't get it.

Ok, now also check all Word plug-ins. Any 3rd party add-ons running, like reference manager software or the like? Try disabling, if so, and see if that helps.

Check your Normal.dot - it's in your Library folder too, in the User Templates subfolder buried in the Microsoft directory mentioned above. Try saving a backup copy of this file somewhere else, then delete the original. Start Word. Issue still persist? If so, you found the culprit, but have fun adding your personal customizations back in to Word.

Last-ditch attempt? The accepted official Microsoft-approved fix for any of this unidentifiable behavior is kill all your preferences and your Normal.dot, which is great because I am sure you want to start from scratch and re-enter all of your preferences all over again.
posted by caution live frogs at 5:42 AM on May 8


« Older I've recently assumed a role t...   |  Posting for a friend: "... Newer »

You are not logged in, either login or create an account to post comments