Join 3,572 readers in helping fund MetaFilter (Hide)


Don't underline trailing spaces?
September 22, 2012 8:45 AM   Subscribe

Word/OpenOffice/LibreOffice/everything ...When I want to underline a single word in a word processing or email application I want just the letters of the word underlined not the spaces that follow it. All of the editing programs I use, when you double click on a word will highlight the word and the spaces that follow it (up to the start of the next word). So when I select underline the spaces get underlined also. I don't want that (who does?). It's ok behavior for bold and italics because you can't see if the space has gotten those attributes. But with underline you can see it and I think it's wrong and I don't want it. Why is it done this way and can I stop it?

Sure I can highlight the word manually rather than double clicking, but that takes significantly more time. I have to think it would be easy enough for the apps to be programed to cut back the underlining when they are the trailing spaces.

Is there some reason why these spaces get the underline?
Does anybody actually want those spaces underlined every time?
Do any of the wp progs have options to switch this behavior on and off? (is there special terminology for it?)


ps: I see that this website (metafilter) does thing right. When edit text here and double click to add an attribute, although it highlights the trailing space, it then cuts back on it when it places the tag. That is what I want. I want them all to be like this.


pps: I only use Windows, so I don't know if this happens on Macs.
posted by Xhris to Computers & Internet (14 answers total) 2 users marked this as a favorite
 
Libre Office with default settings only highlights to the end of the word I double-click (or double-click and drag to, which selects by word dragged) here (Xubuntu 12.04). Is there perhaps some setting you've done to make it select the trailing spaces?
posted by straw at 8:50 AM on September 22, 2012


I am using Windows and Word 2007, and when I double click on the word it does indeed include the space after, but when I apply underlining it only underlines the word and not the space. Check your settings. It's probably under "Advanced" and under editing options.
posted by clone boulevard at 8:52 AM on September 22, 2012 [1 favorite]


There's also a keyboard shortcut in word—instead of using CTL+U, use Ctrl+Shift+W. That accesses the "underline whole word" tool, rather than just "underline". You can finesse anything to do with font formatting using the Font dialog box. In the font dialog box, under "Underline style" , you'll see the option "Words only". That does what you want it to.

Sorry I can't seem to find where the default setting for this is. I never use underlining, myself (it's not within our company's style options, because underlining can make people visually think "hyperlink"), just bold or italic or bold italic; and in Word when I use these features I use styles to apply them, that I've created a keyboard shortcut for.
posted by clone boulevard at 9:10 AM on September 22, 2012 [1 favorite]


Here's the actual setting for it.
posted by roomwithaview at 9:15 AM on September 22, 2012


Also, for what it's worth, I'm guessing that the underline tag in your original question included the trailing space after the words underline (first time) and spaces. I'm viewing the site in Chrome on OS X and it definitely appears that the trailing spaces after those two words are underlined in addition to the word itself.
posted by roomwithaview at 9:17 AM on September 22, 2012


roomwithaview, that doesn't show the way to make it the default going forward, though, which is I think what the question is. There's got to be a global setting for that, somewhere.
posted by clone boulevard at 9:21 AM on September 22, 2012


In the Word Options (under something like Editor Options/Advanced) you will find a tickbox:

'When selecting, automatically select entire word'

Tick this option to select entire words when you select part of one word and then part of the next word. Ticking this option also selects a word and the space that follows it when you double-click a word.

If you change this setting in Word it will affect the whole MS Office suite.

Also on the web and in email, for most people underline = link, to avoid confusing anyone why not just choose some other formatting option: colour, italics, indenting etc.
posted by Lanark at 9:52 AM on September 22, 2012 [1 favorite]


I don't want that (who does?).

The reason that editors do this is because it simplifies copy and paste actions. Say you want to change the order of two sentences. Without the trailing space, there would be an extra space where you copied from, and two words run together where you pasted it.
posted by bitslayer at 9:55 AM on September 22, 2012 [2 favorites]


How words and lines highlight when you interact with them is a function of the operating system (or, at least, the windowing system), not the word processor. This has been a peeve of mine for years, and is one of a few final straws that inspired me to never use a Microsoft operating system for personal use again.

God. Sometimes even when you're trying to select a word letter by letter it still jumps to include the final space after you hit the last letter. ARGHHH. There's simply something missing in the corporate culture at Microsoft, because frustrating little details like this fill their products from the top to the very innards like a mark of Zorro. Never again.
posted by tapesonthefloor at 9:55 AM on September 22, 2012


I don't want that (who does?).

It's actually useful to have spaces in the same style as words when you're using styles in Word for italic, underline, and bold and the text you're writing is going to be imported into a layout program like InDesign. With the right settings, you can make text in each style become a specific corresponding font in InDesign. When you do that, though, you don't want another font style in between words, because in some cases, in InDesign, that can make the those words automatically change to that font as well. So that's one reason why someone might want that, FYI!
posted by limeonaire at 10:09 AM on September 22, 2012


I'm certain there's a way to do this in Word too - I've done it - but I'm on my Linux computer at the moment so I can only test the LibreOffice solution that google gave me. Go to Format -> Character -> Font Effects, and check "Individual words" under the underlining options. I just tested it, and even if I intentionally select the spaces around a word when I highlight it to add underlining (my version natively only highlights the word with no spaces if I double click, no idea why) the underlining does not appear under the spaces.
posted by solotoro at 10:15 AM on September 22, 2012


tapesonthefloor writes "How words and lines highlight when you interact with them is a function of the operating system (or, at least, the windowing system), not the word processor. "

This is not an OS level function, or at least it doesn't have to be. For example IE on Windows does the stupid "select part of the word and the whole word gets selected" thing whereas Firefox does not automatically extend the selection. Double clicking still grabs the trailing space though.
posted by Mitheral at 10:55 AM on September 22, 2012


It doesn't fix the underlying problem, but after you've got your highlight with that extra tailing space, you can press Shift + Left Arrow to subtract that last space from the highlight before you add the underline.
posted by yuwtze at 11:06 AM on September 22, 2012


It's a Windows thing. It's especially annoying when copying and pasting temporary passwords, 'cos it gets the space too and fubars the login.

Few programs do underlines properly; they're a hangover from typewriter days. A proper underline should break neatly around descenders instead of blundering through them. Or better still, not use them at all.
posted by scruss at 11:19 AM on September 22, 2012


« Older What is the story behind the p...   |  Safe, at home free weight prog... Newer »
This thread is closed to new comments.