Join 3,552 readers in helping fund MetaFilter (Hide)


macbook pro wifi issue
June 6, 2011 10:49 AM   Subscribe

Please please help me. Macbook pro wifi keeps going in and out at home. Used to be fine, now disconnects and says: "searching for network" WHILE the wifi bar says full bars and connected. I think it has to do with either network setting or the weird location thing. Here is a picture of my issue: Picture of wifi issue Somehow, the wifi is fine, but I am no longer connected to the internet. internet works fine at other peoples houses, just my house and certain cafes this problem of "searching" for the internet emerges while the wifi bars stay on full. Have tried rebooting computer, router etc. Thank you for any suggestions.
posted by cascando to Computers & Internet (7 answers total) 2 users marked this as a favorite
 
Have you tried creating a new network? I had that issue with my Macbook Pro- I ended up solving it by getting rid of the current network I had and creating a new one with my router.
posted by Zophi at 10:54 AM on June 6, 2011


What kind of router do you have? I have had better results with the 802.11 wireless N routers.
posted by JesseBikman at 11:26 AM on June 6, 2011


Try logging into your router and changing the channel it broadcasts over. I had this issue at my house, and that fixed it. Probably just a lot of interference on that channel.
posted by The Deej at 11:32 AM on June 6, 2011


This happens on a regular basis with the mac laptop that I keep in the living room. My solution is to delete the SystemConfiguration folder located here:

Macintosh HD/Library/Preferences/SystemConfiguration

Works every time. You have to log-into your WiFi and enter the password again and then "always allow" your keychain access.

I have no idea what the cause is, but the solution works.
posted by humboldt32 at 1:16 PM on June 6, 2011 [1 favorite]


Oh, and reboot after the delete, of course.
posted by humboldt32 at 1:17 PM on June 6, 2011


The wifi on my macbook occasionally does this when I'm in my office at the back of the house, three rooms away from the airport express. I have assumed it to be a distance-related issue; turning wifi off and turning it back on usually does the trick.
posted by me3dia at 2:59 PM on June 6, 2011


I have this problem, and it's definitely due to interference on the WiFi channel. This free program is great for working out which other wireless networks are on nearby channels. You want to get the wireless on a channel that is as far apart from all the others as possible. So, for example, if there are networks on 1 and 4, you'll want to change yours to something high, like 11. In our case there are so many networks in the vicinity (cramped East End terraces) that it's difficult to find a clear channel, but I've been able to improve things substantially.
posted by Acheman at 6:56 AM on June 7, 2011


« Older Did I handle this (possible se...   |  I'm trying to sort out the tan... Newer »
This thread is closed to new comments.