Join 3,494 readers in helping fund MetaFilter (Hide)


This time no one can say "Buy a Mac" because we DID.
June 10, 2010 3:57 AM   Subscribe

My new roommate's Macbook can't connect to my cable signal. What should we do to fix this?

She just moved in. Every time she tries to connect my existing signal, her computer times out and can't. And yes, we've checked that she's using the proper password and connecting to the proper signal.

She has an Apple MacBook, I have Time Warner Cable's "Roadrunner" service and a Belkin router. I can connect just fine.

An initial Google turned up one person who had similar troubles but did something with the "DNS numbers"; might that be it? What other things should we try?
posted by EmpressCallipygos to Computers & Internet (10 answers total) 3 users marked this as a favorite
 
More details are needed... What are we talking here? Are you using a wireless connection or a wired connection? That's going to be the bare minimum. I'm guessing you're talking about using wireless, because you said "my existing signal."

Try resetting the router to the factory settings then re-enabling all your security. That should fix the problems you're having. I've had nothing but problems with my Belkin Vision N1 and I just retired it in favor of a more stable Linksys.
posted by ganzhimself at 4:20 AM on June 10, 2010


Have you tried connecting her directly to the cable modem?
If it works there, it's a problem with the router. Can she connect to other places?
Have you tried restarting the router?

In networking, you basically want to identify where the problem lies - if she can connect directly via the modem, there's something wrong with the wireless connection. If she can connect to other wireless base stations, then it's something specific to your setup (and not her machine.)

When you run Safari, it has the ability to automatically launch an app called "network diagnostics".

Open her system preferences>Network. It should show what sort (if any) connection she has...and what IP address. Likely your belkin is a 192.168.0.x number (or 192.168.1.x). If it's coming up with a 169 it's a self referencing address - it timed out before the router gave it an ip address.

The DNS - Domain Name Servers often are left blank - they're fetched from the router or cable modem; this is only an issue if she's filled something else in.

Last, It might also be worth checking that you have the latest belkin firmware
posted by filmgeek at 4:20 AM on June 10, 2010


I suppose you try to connect via WiFi, and it doesn't work.

One of the reasons for this could be that the router does filtering based on the MAC address.
What this means is that, as an additional layer of security the router has a whitelist of which machines can connect to your network. Each network port on every machine has a unique ID, called the MAC address (so this has no relationship with Mac as in "Apple Mac(intosh) computers"). The router can have a table with which MAC addresses can connect.

To verify this, you'll need to login to the web interface of the router. This can be done from the pc that can connect. For this you'll need the IP address of the router, and enter it in the address bar of the browser. In 99% of the cases it will be one of the following:

http://192.168.2.1 (this is usually the default address on a Belkin router)
http://192.168.1.1
http://192.168.0.1
http://192.168.1.254
http://192.168.0.254

You should arrive at a login screen where a password is asked. On a Belkin router, by default you can leave the password field empty. Else you should try 'admin', 'password', or something like that.

Go to Firewall, and then "MAC address filtering". If it is enabled there, we've found the problem. Enter the MAC address of your roommate's Macbook and click Apply.

To find the MAC address of the Macbook, click the Apple logo in the menu bar (top left), click System Preferences, then Network, then Airport, then Advanced, then Ethernet. It should give you the "Ethernet ID". This is the MAC address of the wireless adapter of your roommate's MacBook. Enter this exactly as you see it in the web interface of the router and you should be good to go. (If this was indeed the problem.)

Let us know how that works.

Good luck!
posted by lodev at 4:55 AM on June 10, 2010


Try going to the router administration page that lodev is suggesting and disabling the wifi password. If that gets her online, then try reenabling it and changing the type of security (WPA, WPA2, WEP, &c).
posted by thejoshu at 6:02 AM on June 10, 2010


Do you have a wireless phone that is physically closer, or between the wireless router and the non-working computer? That's something that could be happening: Interference from Cordless Phones
posted by artlung at 6:34 AM on June 10, 2010


If the Belkin device is supplied by and managed by the cable company, then a call to their tech support would be appropriate - they can probably sort it out in a few minutes.
posted by TravellingDen at 7:51 AM on June 10, 2010


I am aware that this sounds totally ridiculous, but try having her put a $ directly in front of the password and/or changing the password so that it has a $ in front of it. I have no idea why this is the case, but I've had to do that with my last two wireless connections. After working with tech support for hours to try to fix the problem, that's what did it.
posted by nosila at 10:07 AM on June 10, 2010


Sorry for the delayed response - we haven't been home at the same time.

It is a wireless connection. She DID try connecting to the moden with a cable, and that worked (well, except it started asking her to load the Road Runner software, and she was uncomfortable doing that so she stopped).

Lately, though, she's getting the error message that she's using an incorrect password. However, she's using the same password that I'm using to connect right now, and I haven't had any problems.

I told her about the $ in front of the password and she'll try that.
posted by EmpressCallipygos at 11:15 AM on June 12, 2010


Okay. An update.

* She cannot connect either through the ethernet OR wirelessly.

* She is DEFINITELY using the right password. We confirmed that with our router (belkin).

* Her specific problem is: when she types in the proper password, that password box is cleared and she gets the error message that she "needs a WPA password."

* When she connects via the Ethernet cable, it says she "needs an ISP address."

* She called Apple and they said to call my ISP. My ISP said to call Belkin (the folks who made the router). That's who we're on the phone with now. They have advised her to try to connect via another ethernet cable (I think the fact that she was using only the one ethernet cable flummoxed them).

Help?
posted by EmpressCallipygos at 6:27 PM on June 14, 2010


Actually, we finally found someone at Belkin who was helpful.

I had to just switch to another kind of security on my router, and everything worked. My roommate had said that someone at Apple DID say that Apples sometimes had problems with a specific kind of security, but "there's ways to work around that." Alas, none of those ways worked, so we had to reconfigure my router with the new security and passcode, and now everything works fine.

Marking this resolved.
posted by EmpressCallipygos at 8:01 PM on June 14, 2010


« Older Help me find this online resou...   |  Last year or so, I listened to... Newer »
This thread is closed to new comments.