Join 3,514 readers in helping fund MetaFilter (Hide)


Make my laptop and router get along!
April 30, 2012 6:19 AM   Subscribe

My laptop (and only my laptop) intermittently fails to see my wi-fi network. Please help me solve the problem.

I have an Asus laptop running Windows 7 (64-bit) and a Netgear wireless router (branded Virginmedia). Until a couple of weeks ago, I'd never had a problem connecting to the internet, but since then my computer randomly fails to see my network.

If I click on the wireless icon next to the clock, I can see several of my neighbours' network, but not my own. Other computers in my house can connect without a problem, so it seems to be an issue with my computer rather than the router.

Things I've tried:

- Turning the router off, waiting a minute, then turning it back on again.
- Disabling the wireless adapter, then enabling.
- Updating the drivers for my wireless adapter (it was up to date already).

I'm not sure what else to do. Google leads me around in circles. Please help!
posted by afx237vi to Computers & Internet (5 answers total) 2 users marked this as a favorite
 
We had this problem with our Acer laptop. We couldn't find any resolution for it, but when I got a different wireless router and put Tomato firmware on it, the problem disappeared.
posted by AzraelBrown at 6:35 AM on April 30, 2012


For reasons I don't understand, sometimes congestion on one channel causes some wifi drivers on some laptops to sometimes fail. I apologize for not having a less-superstitious-sounding answer than that.

Try switching the channel on your wireless router to 1 or 11, see if that helps.
posted by mhoye at 7:21 AM on April 30, 2012


Yes, change the channel. The clue is "until a couple weeks ago". Probably one of your neighbors has a new router or a new cordless phone or wireless security system or baby monitor or something which is causing some interference, and it doesn't even have to be on the same channel that you are now using. You may have to change to and test every channel.
posted by caclwmr4 at 8:04 AM on April 30, 2012


Router channel is a good idea.

Sometimes there can also be issues with the authentication, if you run a variety of different OS's on your network. A few weeks ago I brought home my Win7 work laptop for the first time in a few weeks, and something got tied up in the router - it started getting hung up and wireless not working for either the Mac or the Vista computers that also used the network.

I thought the tech support guys were crazy for saying it might be the authentication, since that hadn't changed at all, but after they tweaked my authentication system (from numbers only to 5 letters and 5 numbers, WEP) suddenly all the computers started working. I still have to disconnect and re-connect my Win7 computer occasionally but it isn't cutting out mid-session any more.

And apologies for another "semi-superstitious-sounding" answer...
posted by Lady Li at 9:23 AM on April 30, 2012


Thanks everyone. The channel setting was on "auto", so I changed it to 10 and my computer picked up the network almost immediately.
posted by afx237vi at 2:15 PM on April 30, 2012


« Older Is this a redbud?...   |  So our teenage daughter slept ... Newer »
This thread is closed to new comments.