Skip

How to bypass my provider's annoying "site not found" screen?
January 28, 2009 11:09 AM   Subscribe

How to bypass my provider's annoying "site not found" screen?

I used to be able to just type in a domain name in the address bar, like "metafilter", hit return, and the browser would automatically load "metafilter.com". But lately, Optimum Online is interfering with that handy shortcut by displaying a search result screen (to show me ads, I'm sure) saying "the site cannot be found" and a screen full of search results, usually with metafilter.com listed right at the very top. How do they do this? More to the point, how do I get the old behavior back?
posted by monospace to Computers & Internet (14 answers total) 6 users marked this as a favorite
 
There was a provider in Germany doing that, after enough people complained they put an opt out in customer center. But using different DNS servers (like OpenDNS might also do the trick.
posted by starzero at 11:13 AM on January 28, 2009 [1 favorite]


Copied from another forum: I'd say your ISP is redirecting you to their search page when their DNS servers can't find an entry for what you typed in. Have you tried typing the name and then pressing Control+Enter? This will force the browser to add .com at the end of the entry.

Shift+Enter adds www.*.net, and Shift+Control+Enter adds www.*.org
posted by filthy light thief at 11:17 AM on January 28, 2009 [2 favorites]


It's AdSense for Errors.
posted by GuyZero at 11:25 AM on January 28, 2009


And if I had read the whole thread, I would have found this link to opt in (or out?) of the new Page Not Found results. If you're not on their network, the link appears to re-direct you, so I can't verify that it still works as intended.
posted by filthy light thief at 11:27 AM on January 28, 2009 [1 favorite]


Call the ISP and ask the support person. Maybe if enough people bother them, they will stop doing stupid crap. ("Gee, we have some new ad revenue, but it's more than offset by the two new support people we had to hire...") My cable company did similar stupid crap and there was a checkbutton somewhere I unchecked to get sane behavior back.
posted by fritley at 11:27 AM on January 28, 2009


Use different DNS servers. I'd suggest OpenDNS, but they do the same thing OOL apparently now does. (OOL didn't do this back when I was a Jerseyite. Still miss their speed . . . )
posted by CommonSense at 11:35 AM on January 28, 2009


Use Verizon's DNS servers, which don't break standards by redirecting when they aren't supposed to:

4.2.2.1
4.2.2.2
posted by odinsdream at 11:42 AM on January 28, 2009 [1 favorite]


Just a note to say that Filthy Light Thief's link to Optimum's opt-out page seems to have worked in my case... that bloody search page was driving me crazy too. Thanks for asking this question, Monospace...
posted by departure lounge at 11:48 AM on January 28, 2009 [1 favorite]


OpenDNS
posted by gomess at 11:51 AM on January 28, 2009


My solution (having just now learned about the opt-out) was to use the 4.2.2.x servers. OpenDNS didn't work because it does the same thing as OOL and I didn't see any way to disable that.
posted by Godbert at 12:56 PM on January 28, 2009


I actually had exactly the same problem with my ISP (Grande Communications, fwiw). I spoke to their technicians (people who actually seemed to know what they were talking about, in fact) and they were completely mystified.

I put up with it for a while, and eventually someone hepped me to different domain-name servers at my ISP. I switched to those and the problem went away.
posted by adamrice at 1:00 PM on January 28, 2009


My ISP (HughesNet) does this too; it's unbelievably irritating, and changing the DNS server doesn't seem to help.

Their "opt out" link doesn't actually stop the redirecting, it just shows you a different page designed to look sort of vaguely like the IE6 standard error page (which would be more convincing if I were running Windows or using IE6). Bitching to the tech support call center had the predictable effect (none).

I ultimately ended up just blocking the server they redirect to (found-not-help.com) in my hosts file.
posted by ook at 1:02 PM on January 28, 2009


Use Verizon's DNS servers, which don't break standards by redirecting when they aren't supposed to:

4.2.2.1
4.2.2.2
posted by odinsdream at 11:42 AM on January 28


God, thank you. I was horrified when i found OpenDNS doing that.
posted by Optimus Chyme at 1:16 PM on January 28, 2009


Yeah don't use OpenDNS. They do the same thing.
posted by juv3nal at 4:29 PM on January 28, 2009


« Older I'm going to be in downtown To...   |  My cat has taken to licking th... Newer »
This thread is closed to new comments.


Post