Safari never forgets!
January 22, 2009 5:31 AM   Subscribe

When using Safari, since the weekend, I have noticed that whenever I do a Google search with the search field in the browser, it looks as if my girlfriend is still logged on on Google via my computer. I tried reseting the browser, restarting it, logging in to Google as myself and logging out, even clearing the cooking, cache and history manually, and still eventually it looks like she is still logged in. What gives?

Has anyone seen similar behavior on Safari? This is 10.5.whatever (latest), with the latest Safari too. I don't notice any similar ptoblems with other sites.
posted by TheyCallItPeace to Computers & Internet (15 answers total)
 
What do you mean by "looks as if"?
posted by devbrain at 6:45 AM on January 22, 2009


I get the same thing with Safari on my mom's Mac (i.e. even though the previous Google account has been logged out, it appears that it is still signed in on the Search homepage). Has been this way since she bought her computer more than two years ago (OS hasn't been upgraded since).
posted by halogen at 7:15 AM on January 22, 2009


Do you have "private browsing" turned on in the Safari menu, sometimes that messes things up -- not letting you log out, etc.
posted by chunking express at 7:22 AM on January 22, 2009


devbrain: "looks as if" means "her log in appears on the top right corner when I do Google searches".

chunking express: nah, private browsing is off (it seems to shut itself off whenever I close Safari)
posted by TheyCallItPeace at 7:38 AM on January 22, 2009


To avoid this in the future, just create a separate user account for your girlfriend or turn on the guest account.
posted by nathan_teske at 7:43 AM on January 22, 2009


Yeah, seems like separate accounts with fast user switching would be the easiest solution.
posted by 6550 at 7:50 AM on January 22, 2009


nathan_teske: my problem is security in general. If Safari can't clear all the stuff even after I do all this, and this is _normal_ behavior, then what else is accessible when it should not be? If this is not normal behavior, then I was hoping on figuring out what I am doing incorrectly.
posted by TheyCallItPeace at 7:51 AM on January 22, 2009


This may or may not help. In gmail, at the very bottom of the page (third line from the bottom) it lists the "Latest Account Activity" and has a link to "details." If you click on that it will show her a list of IP addresses from which she still has an open gmail session. She can choose to log out of them all at once.

I assume that this could help your problem since gmail and igoogle use the same log-in. I hope it's helpful anyway.
posted by oddman at 8:01 AM on January 22, 2009


Are you sure you deleted all the cookies? There may be one from google.com and another from gmail.com and another from igoogle.com.
posted by damn dirty ape at 8:06 AM on January 22, 2009


damn dirty ape: I delete all cookies by using "remove all", so there is nothing left.
posted by TheyCallItPeace at 8:17 AM on January 22, 2009


Or even the annoying thing of not being able to selectively clear an item from the history. I hate having to clear the whole history because I typo'ed 'google' or 'review' or some other common term and it shows up first.
posted by mce at 8:22 AM on January 22, 2009


Try pressing option+refresh or shift+refresh. I think one of those tells the browser and upstream proxy to deliver a fresh copy of the site and to ignore any caches along the way.
posted by damn dirty ape at 9:00 AM on January 22, 2009


you know my safari just started doing the same thing, (my gf is also logged in on mine)

I killed all cookies, emptied the cache

still she was there,

so logged in myself and stayed logged in for two days
and the problem seems to have gone away
but i have no idea why it happened in the first place
posted by compound eye at 12:26 PM on January 22, 2009


I've also been having problems with Safari not deleting cookies. This is when I delete them from the 'Reset Safari...' menu. But if i go to preferences -> security, then show cookies, then remove all from there, it works.

Not sure if that's the same problem you're having though.
posted by sero_venientibus_ossa at 3:45 PM on January 22, 2009


Well, it seems to have gone away. I am not sure what finally worked, between the resets and the manual cookie deletion/history clearing.

Either way, after seeing that similar things have happened to other people, I will do my best to stick to Firefox -- at least it hasn't flaked out like this yet.
posted by TheyCallItPeace at 10:33 PM on January 24, 2009


« Older Looking for a good writing board   |   Una Americanca si un Roman din Washington DC Newer »
This thread is closed to new comments.