July 18, 2008 10:25 AM   Subscribe

Outlook AutoComplete filter: Deleted AutoComplete entries keep coming back. How do I get rid of them for good?

I rely pretty heavily on Outlook's (2007) AutoComplete feature. Due to recent change of company ownership, we all have new email addresses (new format and domain). So, when I start an email to Jack Smith, I am getting AutoComplete suggestions for and Per Microsoft's instructions, when the drop-down list showing the suggestions pops up, I should highlight and press delete. This works for the current login session. The next day/login, shows up in the AutoComplete list again. I understand that the NK2 file gets populated based upon emails I send, but I am not sending new emails to these old addresses, so I don't see how they are being added back in. Any ideas?
posted by tdischino to Computers & Internet (4 answers total)
I've always used Shift + Delete to get rid of autocomplete entries. Now I could just be doing it wrong, but it may be worth a try. Other than that, the only thing I can suggest is deleting the .NK2 file. It's really odd that they are coming back...
posted by PhillC at 10:33 AM on July 18, 2008

Shift-delete makes sense, as in Windows that is the "permanent delete" function and not the "recycle bin" delete function that is just the delete key on it's own...
posted by Grither at 10:38 AM on July 18, 2008

You can delete the nickname file. Look at this knowledgebase article.
posted by Dan Brilliant at 11:26 AM on July 18, 2008

Response by poster: Deleting the NK2 file isn't an option, as it contains hundreds of valid external email entries (clients and partners).

Since posting my question, a cohort of mine has suggested a 3rd party NK2 file editor, which would probably nix this pretty quickly. I assumed NK2 was some sort of binary proprietary format to begin with, I didn't even think this was just a text file.

Thanks for the replies. I'll try the shift + delete option in the future.
posted by tdischino at 11:40 AM on July 18, 2008

« Older Time travel with an iPhone   |   Canadian Repatriation Newer »
This thread is closed to new comments.