Why won't my RH linux play my shoutcast music stream?
June 18, 2004 8:41 AM   Subscribe

At work we use Red Hat linux and I've used Shoutcast to stream music. Today, I tried it on a different computer than normal and got an error reading something along the lines of "digital rights conflict with mpeg1/mpeg2/mpeg3 and Red Hat will now allow you to stream music." Thinking it would still stream (silly me), I clicked the "Do not show me this again" box and now I can't stream anything off any website and can't see that error message to give better details. I also use xmms. Anyone heard of this or know what's up? Also, my normal computer is in use so can't test that one out.
posted by jmd82 to Computers & Internet (10 answers total)

Maybe it's related to the fact that recent Red Hat releases do not include mp3 support. If that's the problem, you should be able to add an mp3 decoder plugin to XMMS (check xmms.org for instructions)--maybe someone already did this on your usual computer.

Check Options->Preferences->Audio I/O Plugins in the XMMS menu to see whether you have an MPEG Layer 1/2/3 Player.
posted by Galvatron at 9:15 AM on June 18, 2004

Redhat 9 and all subsequent Fedora releases don't support mp3s. A pain for users, I guess, but a decent decision from a business perspective since there are real patent issues with mp3s that are as of yet unresolved.

I usually get the xmms-mp3 package from freshrpms.net. You can download it directly from there, but I usually just use their apt repository to get that sort of thing automatically.
posted by mragreeable at 9:20 AM on June 18, 2004

Response by poster: Ah yes, that defintely explains it! I think it works on the other computer because it's the Sound Blaster version of xmms so they must have included the mp3 support.
Another question: the mp3 support package requires root, which I don't have. Is there anyway else to install mp3 support, possibly in the fashion Firefox is installed on linux? (If you couldn't tell, this is my first time using linux and trying to figure it out, such as the different ways to install stuff)
posted by jmd82 at 9:37 AM on June 18, 2004

If you don't have root access, then I think what you want to do is find the source for the XMMS mpg123 plugin, compile it, and install it into .xmms/Plugins/ in your home directory.

Finding the source doesn't seem to be trivial. I'm not sure it's distributed separately from XMMS itself...
posted by Galvatron at 9:56 AM on June 18, 2004

posted by the fire you left me at 10:21 AM on June 18, 2004

Building xmms plugins requires xmms development packages, the installation of which would require root access. Your best bet may be to compile xmms from source.

You could try ths xmms-mad plugin. Which will require libmad. You'll have to have this stuff build to somewhere in your home dir, and set your path and (likely) LD_LIBRARY_PATH settings to point to it. And, actually, possibly PKG_CONFIG_PATH as well.

It's doable. Though a lot easier with root access. You could download the relevant rpms and reboot the computer in sigle user mode and install them that way, I guess.
posted by mragreeable at 10:35 AM on June 18, 2004

LAME is nice and all, but I'm pretty sure it's not a streaming mp3 player.

Trying to build xmms from source may also fail due to lack of gtk development packages, among other things. Can you bribe one of the IT guys? That would really be the easiest thing...
posted by Galvatron at 10:45 AM on June 18, 2004

Response by poster: Thanks for the tips. I going to try working on this when I have more free time.
Yea, I could easily ask the IT guy, but I also want to learn how to do this stuff on my own so someone can bribe me the next time help is needed.
posted by jmd82 at 10:48 AM on June 18, 2004

The RPM that mragreeable links to only contains one file, the shared object libmpg123.so, which wants to be installed in /usr/lib/xmms/Input. I think there's a good chance that you can just put that file in some directory of your own and get xmms to use it. You'll have to check what directories xmms scans by default, but IMHO there's a good chance that one of them is ~/.xmms/Something/. And you'll have to figure out what flag to pass to rpm to get it to cough up that file without trying to install it in the recommended place.
posted by hattifattener at 2:01 PM on June 18, 2004

« Older Where does She-Ra get her power from?   |   Crystal Ball software for the Mac? Newer »
This thread is closed to new comments.