The little LCD that couldn't . .
November 8, 2007 8:07 PM   Subscribe

Flat Panel's DVI interface works during POST, windows startup graphic, nothing else :(.

I've got a few-year-old Dell 2405FPW that works using it's D-Sub interface, but I'm having trouble getting it to work via DVI. If I attempt to use the DVI interface, the BIOS/POST screens display, the windows startup graphic works (the moving bar), but as soon as I get into windows the display blanks out.

The monitor does detect that it's connected to something, as unplugging the cable on either end resets the monitor to it's 'no input' screen. Same goes for the PC, as unplugging the DVI cable on either end elicits the windows hardware insert/removal sound. The DVI cable is brand-spanking new and <6' long.

Attempting to configure the LCD via it's buttons while it's connected to the PC via DVI reveals that the LCD thinks the PC is in power-save mode. I can VNC into the computer while it's in this state. The video card (a BFG GeForce 8600GT) detects that an analog display is connected (as opposed to a digital). All attempts to reset resolution (even at 800x600) or refresh rate (even at 60hz) fail. Forebodingly, I cannot get the display to fire up on my laptop's DVI interface either :(.

One side of me is saying 'give up, it's hosed', but the other says 'but it works during POST!' What the hell is going on here?
posted by datacenter refugee to Technology (11 answers total)
Have u tried a different DVI cable?
posted by mphuie at 8:30 PM on November 8, 2007

It's probably being treated as a secondary display by Windows. The VGA and DVI ports on your graphics card are driven separately (you can run two different monitors showing different pictures, one off each) and you will probably have to:

1. Connect via VGA

2. Use Display Properties to enable the second display on your graphics card, and tell Windows to make it the primary monitor

3. Connect via DVI.
posted by flabdablet at 8:32 PM on November 8, 2007

Doing Step 2 on its own via VNC would probably work, too.
posted by flabdablet at 8:41 PM on November 8, 2007

Some graphics cards support a lower resolution on the DVI output than the VGA. For example, I have the Dell 24" (1920x1200) panels on my desk at work which would work at native resolution only on VGA before I had the video card upgraded.

So have a look at the specs of your card, you might be exceeding the maximum supported DVI frequency. A quick google tells me that that card can do 2560x though, so it *should* work.

Plug it in with the analog connector and see if it works; the quality will likely be quite alright if you don't have a crap cable and/or DAC.
posted by polyglot at 8:44 PM on November 8, 2007

If you have both cables connected at the same time, that's your problem. Shut down, remove the VGA cable, and start up with only the DVI cable.
posted by pmbuko at 8:48 PM on November 8, 2007

Response by poster: Thanks for all of the suggestions -

- Yes I've tried multiple cables. This one just came out of the bag

- The dual-screen enable thing doesn't work because I dont even SEE a secondary display in either the windows generic display dialog or the nvidia control panel

- I have been making sure that both of the cables were never plugged in at the same time - good call though.

After some more experimentation I've found that completely uninstalling all NVidia drivers allows me to bring the thing up in 640x480 on standard windows drivers. Im beginning to think that this card (or the drivers) are just crap. I'll keep screwing around and if I find anything that may be of any help I'll post it here.
posted by datacenter refugee at 10:25 PM on November 8, 2007

You probably need a dual link capable video card and DVI cable:
The dual link DVI pins effectively double the power of transmission and provide an increase of speed and signal quality; i.e. a DVI single link 60-Hz LCD can display a resolution of 1920 x 1080, while a DVI dual link can display a resolution of 2048 x 1536.
I expect that when the driver senses the monitor's native resolution, but the card doesn't support that resolution, the symptom you are experiencing occurs.
posted by Chuckles at 12:06 AM on November 9, 2007

Your video card is dual link capable for sure.. Did the cable come with the monitor?
posted by Chuckles at 12:08 AM on November 9, 2007

Response by poster: Your video card is dual link capable for sure.. Did the cable come with the monitor?

No, it's off-brand. One other possible source of problems: The DVI connector on the video card is DVI-I dual-link, the DVI connector on the monitor is DVI-D only. I'm connecting them with a cable that's DVI-D on both sides.
posted by datacenter refugee at 6:35 AM on November 9, 2007

I think it's Windows. It's trying to talk in a way that the monitor doesn't understand. As the computer is starting to load Windows -- immediately after POST -- press F8 a few times and boot into safe mode. That should fall back to a resolution/refresh rate/dot clock that is well-understood (though ugly).

Then, fix it from there.
posted by cmiller at 10:09 AM on November 9, 2007

The previous answers about Dual-Link and the cable are total red herrings, I know exactly what your problem is -- see an old self-answered question of mine from when I ran into it myself.

The problem is that your video card driver in windows expects to be able to talk to the monitor over DDC to find out what resolutions it supports, and the monitor's controller board doesn't support that. That's why it works in the BIOS -- the video card is being driven in standard VESA mode. It'll work in windows with the driver uninstalled (in VESA mode), but at terrible refresh rates, as you appear to have discovered.

The problem is that you got unlucky with your monitor and got one from a batch that used a non-DDC supporting chip. When I ran into this problem the first time with a batch of 60 Gateway desktops, Gateway was willing to treat the monitors as 'defective' (though we opted to buy 60 replacement video cards below cost instead).
posted by blasdelf at 10:49 AM on February 13, 2008

« Older I want my dry cleaner to starch my shirts, not...   |   ストロベリー・フィールズ・フォーエバー Newer »
This thread is closed to new comments.