Excel Hotlinking
May 28, 2004 12:15 AM   Subscribe

Yo, skryche! How do I keep Excel from hotlinking URLs as I paste them into cells? I use spreadsheets to store, sort, and transform lots of URLs. But Excel seems to think that anything beginning with "http://" is something I want blue and underlined and hotlinked for easy clicking. It doesn't happen right away, only once I leave the cell does it become a hot link. I'd like Excel to just leave my text strings alone. I don't want to launch a browser window every time I click in a cell that contains a URL. And I'm tired of doing the right-click-remove-hyperlink thing every single time. Formatting the column as plain text before dropping in the URL *doesn't* work. As soon as you paste a URL into a cell, Excel wakes up, decides to "preserve the formatting" of your pasted text, and voila! A nice blue hot link. Is there a preference I can un-check for this?

Sorry if this is a stupid one. I can't find anything in the help documentation or via Google that solves my stupid problem.
posted by scarabic to Computers & Internet (8 answers total)
 
Tools-Options-Spelling-Options-Autoformat-Replace-Network Paths and Internet Links
I'm translating from catalan so those words may not be exact but you'll find it (that's excel 2003, I'm sure the others are similar).
posted by Zootoon at 12:46 AM on May 28, 2004


I searched for "Remove hyperlinks" and there's some weird funky way that Excel help tells you how to do it. You put the number 1 in a cell, copy, and then paste special to all the cells. Duh!
posted by gramcracker at 1:10 AM on May 28, 2004


Zootoon! Grathias!
posted by scarabic at 1:14 AM on May 28, 2004


An alternative to turning the feature off is to press Ctrl-Z (undo) immediately after Excel puts in the hyperlink.
posted by blue mustard at 3:23 AM on May 28, 2004


Another way: type a single quote ' as the first character in the cell. The ' operator forces Excel to display exactly what you type instead of evaluating it and displaying its value. The ' appears in the formula bar, but not in the cell. This works for everything: type 000.0 in one cell and '000.0 in the one beneath it, and you'll see that the first cell displays "0" and the second cell displays "000.0".
posted by crunchburger at 3:47 AM on May 28, 2004


Subquestion: Why do Microsoft Office's "Helps" suck so bad.
posted by jpoulos at 7:10 AM on May 28, 2004


Subquestion 2: Why do Microsoft menus suck so bad? I mean, really, who the hell wants to search through seven levels of menus to find an option? I think there shoudl be an understood programming rule that no menu should ever go more than 3, maybe 4 levels deep. Seriously, Microsoft hides some stuff so deep that you can never remember where the damn option is. It's just bad design.
posted by Jonasio at 7:55 AM on May 28, 2004


For the record, I recommend:
Tools > AutoCorrect Options > AutoFormat As You Type

...and then untick the box next to "Internet and network paths with hyperlinks"
posted by skryche at 10:50 AM on May 28, 2004


« Older Passport Help   |   Tired Rat Newer »
This thread is closed to new comments.