Can someone explain to me how to use Mozilla Thunderbird's junk mail controls in 30 words or less?
May 8, 2004 2:22 PM   Subscribe

Can someone explain to me how to use Mozilla Thunderbird's junk mail controls in 30 words or less? [mi]

I have the adaptive junk filters enabled and I've been dutifully marking spam as "junk" since I've installed Thunderbird three weeks ago. However, Thunderbird never marks suspected junk mail as "junk," and when I run the Junk Mail Controls on the inbox, nothing happens.

The documentation for Thunderbirds points to this DevEdge document:

I've read it several times and I don't see what I'm doing wrong. I've poked through the training.dat file and it appears to be getting updated although the Junk Mail log is always blank.

posted by scottandrew to Computers & Internet (11 answers total)
You probably have already, but, just in case, in Tools > Junk Mail Controls... Settings tab, are you set to your e-mail account's domain (not Local Folders)?
posted by normy at 3:12 PM on May 8, 2004

Response by poster: Yep, it's set to my account, not the Local Folders.
posted by scottandrew at 3:18 PM on May 8, 2004

OK, and under Tools -> Junk Mail -> Settings, under the "Handling" category, do you have "move incoming messages determined to be junk mail to" checked? The "Junk Mail Log" at the bottom of the panel can be helpful, too.
posted by Zonker at 4:41 PM on May 8, 2004

Hmm... how about this (even longer shot)?

Junk mail filters can be configured to not mark as junk anything in the 'collected addresses' list. If all incoming mail has the 'from' added to the collected addresses list, then it won't mark it as junk. It's not immediately obvious to me, nor can I find in the help, how the collected addresses list get's populated.

Anyhow, in Junk Mail Controls > Settings, have you got "White Lists: Do not mark messages as junk mail if the sender is in my address book: Personal Address Book", rather than "...Collected Addresses".
posted by normy at 4:43 PM on May 8, 2004

If all else fails, Thunderbird 0.6 was just released a week or so ago, if you're not already on the latest....
posted by normy at 4:49 PM on May 8, 2004

I had a similar problem when I first started using Mozilla's junk-mail filter. Turned out I had to mark some stuff as "not junk" before it would start doing anything.
posted by hashashin at 8:14 PM on May 8, 2004

Try telling it to download all messages to the local machine. I had the same problem, and that cleared it up.
posted by apathy0o0 at 9:26 PM on May 8, 2004

Response by poster: Thanks for the help everyone, but none of those seem to work. Ugh.

Zonker: yes, I have specified that all junk messages be moved to the Junk folder on my account, but nothing is ever moved there. As I said earlier, the Junk Mail Log is always blank.

Normy: AFAICT Thunderbird only collects outgoing addresses, and I have those collected in a separate address book that I use as a whitelist. So no, incoming addresses are not being added to the whitelist by accident.

hashashin: how do you mark something as "not junk?" Do you mark it "junk" and then un-mark it again? That doesn't make any sense.

apathy: I'm already downloading messages to my local machine.

It could be that Thunderbird hates me and I just suck.
posted by scottandrew at 12:38 AM on May 9, 2004

To mark a message as "not junk", right-click on its subject in the inbox view. The context menu will include a "mark" submenu, and one of the choices is "as not junk". Give that a shot. If it doesn't work, try having your junk messages moved to the Trash folder, and then try it again.
posted by Zonker at 8:45 AM on May 9, 2004

I think you have to build a certain sized corpus before it works. One day it started working on its own. Sorry I don't have a better anwer than that.
posted by yerfatma at 10:11 AM on May 9, 2004

Maybe it wasn't actually the need to mark things as not junk, but the fact that when I did, I marked a great number of saved non-junk emails as not junk (the way Zonker describes), and that gave me a big enough set for the filter to start working.
posted by hashashin at 1:33 PM on May 10, 2004

« Older Where can I download a proper DVD player for my PC...   |   Why do Canadian Mounties wear goofy pants? Newer »
This thread is closed to new comments.