Am I blue?
October 30, 2006 7:33 AM   Subscribe

My PS2 is not working as a DVD player. Never has. I get audio, but the image alternates from a few seconds of program to a few seconds of brilliant blue screen. Games work perfectly. FWIW, the PS2 is hooked up to a VHS machine (my TV is elderly) which then feeds into the Co-ax on my TV. VHS works perfectly also.
posted by sourwookie to Technology (12 answers total)
Best answer: This is the macrovision in the PS2 working.

DVD players have copy-protection built in. What it does is changes the contrast frequently, TVs ignore this, but as you can see it messes VCRs up. I used to see this when I had my PS2 plugged into a TV/VCR combi.

You could look into getting an RF lead for your PS2 (a playstation 1 lead will work fine too), and a Co-ax switch so you can have both plugged in.
posted by chrispy108 at 7:36 AM on October 30, 2006

Best answer: Sounds like a macrovision issue. It's trying to keep you from taping DVDs onto VHS tapes.

You'll need a box to remove macrovision protection or get a RF modulator to hook the PS2 directly into your TV.
posted by GuyZero at 7:37 AM on October 30, 2006

Response by poster: So the solution is eliminate the VHS?

I'm cool with that, as the VHS player it there only as an Ad Hoc RF adapter. It never sees any tape.
posted by sourwookie at 7:40 AM on October 30, 2006

Best answer: it's macrovision, which is a crap technology intended to keep content from being copied. It causes waves of interference when you play a macrovision-treated film through a recording device like a VCR. If you get an RF Modulator you'll be able to hook your PS2 up to your TV without going through your VCR.

on preview, what they said.
posted by ulotrichous at 7:40 AM on October 30, 2006

Response by poster: Cool. Now that that's solved (so easy for so much time spent searching, natch) we can use this thread for animated GIFS!
posted by sourwookie at 7:46 AM on October 30, 2006

FWIW, only a percentage of DVDs have Macrovision: some studios choose to use it, others don't - particularly smaller ones.

A typical conversation with a client goes,
"would you like Macrovision on your disc?"
"what's that?"
"it's a form of copy protection."
"does it cost money?"
posted by forallmankind at 7:57 AM on October 30, 2006

It's the DVD player that generates Macrovision on the output. It's not on the disc itself (AFAIK).
posted by GuyZero at 8:14 AM on October 30, 2006

There's a flag on the disc.
posted by Ethereal Bligh at 8:21 AM on October 30, 2006

On the subject line, is there a way to stop my PS2 stretching out a widescreen DVD to fill the whole 4:3? The menu option is always greyed out?
posted by tomw at 8:33 AM on October 30, 2006

Tomw: Have you looked in the setup of the PS2?

Start the PS2 without a disc in and have a look there, I think you have to tell it you've got a 4:3 tv, and then the option appears within the player?
posted by chrispy108 at 8:36 AM on October 30, 2006

Okay I'll try that. I know if you do it once a dvd is onscreen, you can see the option but you can't change it.
posted by tomw at 8:54 AM on October 30, 2006

Another thought, (haven't got a PS2 infront of me), but have you tried it with the disc stopped? (Think you have to press circle twice).
posted by chrispy108 at 9:07 AM on October 30, 2006

« Older digital cameras for kids?   |   What to do in Vietnam and Hong Kong Newer »
This thread is closed to new comments.