Hope me make my mac forget an unwanted network!
April 8, 2016 9:25 AM   Subscribe

My macbook (air, Yosemite 10.10.3) keeps trying to connect to a BT wifi network, prioritizing it over my normal home network. How can I make it stop?

My macbook, for some reason, has suddenly started attempting to connect to a BT public wifi network. When I turn it on or wake it up, it tries first to connect to the offending network, 'connects' successfully, and then up pops a BT login window in Safari. I then have to turn my wifi off, immediately turn it back on, then select my normal home wifi network.

It is terribly frustrating, and I've tried all I know to stop it; I've gone into my network settings, clicked the 'advanced' tab, and tried to remove the BT network from the list, but it does not appear in the list!

What can I do to make my computer forget this bastard network ever existed?
posted by still bill to Computers & Internet (8 answers total) 2 users marked this as a favorite
 
if you open Network Preferences, select wifi and hit the advanced button you'll get a new window
In this window the first tab has a list of known networks. These can be dragged into your preferred order and individual networks can be deleted/forgotten entirely.
posted by mce at 9:34 AM on April 8, 2016


'I've gone into my network settings, clicked the 'advanced' tab, and tried to remove the BT network from the list, but it does not appear in the list'

Sorry, mce, but that doesn't work; the offending network does not appear in the list in wifi preferences.
posted by still bill at 9:59 AM on April 8, 2016


When you go into your list of networks to remove the hated network, are you currently "connected" to the hated network? I recall having to temporarily disable wifi on my macbook in order to get off of my idiot neighbor's "guest" network.
posted by xyzzy at 10:10 AM on April 8, 2016


osxdaily suggests removing the Bluetooth PAN interface from your network interfaces.
posted by kalessin at 10:11 AM on April 8, 2016


Do you have an iPhone? If so, do you have iCloud keychain sharing active on both the phone and the computer?

I have my computer configured to only connect to known networks, but I've found that my phone and computer will sync previous networks - if I've already connected to wifi on my phone, my computer will connect as well.

I noticed this first when my computer auto-connected to an AT&T wifi point (AT&T is my phone service provider). My phone had At&T wifi pre-approved when I bought it. Maybe BT does something similar? If so, my fix was to tell both my phone and my computer to "forget" the AT&T wifi. They haven't connected since.
posted by owls at 10:11 AM on April 8, 2016


xyzzy: I've tried it both ways! No dice yet. It just won't show itself in the networks list.

kalessin: I gave that a shot (thanks for the idea!) but to no avail.

owls: nope, no iphone. I am also using my android phone, as normal, on the desired network, and it has no issues. It doesn't even show the BT network as an option in the available networks screen, in fact.

Any more ideas?
posted by still bill at 10:31 AM on April 8, 2016


OK, try this.

Go to System Prefs | Network | Airport. Place your preferred network in the highest priority. Delete any remembered network that you don't recognize. Uncheck "Remember networks this computer has joined."
posted by xyzzy at 10:59 AM on April 8, 2016 [1 favorite]


Open Network Preferences -> Select "Wi-Fi" -> Advanced -> Select "Wi-Fi" tab -> Select network -> Click "-" symbol to remove the network from list.
posted by GiveUpNed at 10:32 PM on April 9, 2016


« Older Literature about ugliness   |   Voice Recognition Software that can format papers... Newer »
This thread is closed to new comments.