ps2 networking help
November 27, 2005 3:02 PM   Subscribe

Help us get our PlayStation 2 online...

My boyfriend really really wants to play Battlefront 2 online, but we are having trouble getting it to work. We share internet with the upstairs neighbours via a wireless connection (the router is in their apartment).

Here is what we have at our disposal:
- Powerbook with wireless internet connection
- Windows XP desktop with wireless internet connection
- regular and crossover ethernet cables
- admin access to the router (Motorola WR850G), but no physical access to it

Things we have tried so far:

1. Internet sharing through the ethernet card on the powerbook, with manually assigned IP and DNS on the PS2. This worked for a day and then inexplicably stopped working. When we try it now, I can ping the PS2 frm the Powerbook and get a response, but the PS2 can't get online.

2. Internet sharing through the ethernet card on the Windows box, with manually assigned IP and DNS. This works for Battlefront 1 but not 2.

Setting the PS2 to automatically grab address info via DHCP hasn't worked at all, through either the Powerbook or WinXP.

Our current connection setup looks something like this:
PS2 ---> WinXP box ---> Motorola wireless router ---> DSL connection

My networking skills don't extend much beyond what we've tried so far. I imagine it is a blocked port problem but have no idea how to fix it. Do I need to unblock ports in WinXP, at the router level, or both?
posted by sanitycheck to Computers & Internet (6 answers total)
Have you considered the option of buying a one of these?

I know they're a bit pricy, but I suspect the problem lies in having your Mac/Windows machine acting as hub for your playstation. A gaming adapter (Linksys, USR and a few others make them as well), would allow a direct connection between your PS2 and router.
posted by phyrewerx at 4:31 PM on November 27, 2005

Why not buy a wireless adapter for the PS2? Seems like it would save quite a bit of heartache, plus your PCs wouldn't need to be on to play.
posted by jellicle at 4:32 PM on November 27, 2005

doublecheck your firewall settings. also, if you do Internet sharing with either the Mac or XP it'll act as a DHCP server on your Ethernet port anyway - make sure that the subnet and all that kinda stuff are valid and don't conflict with the LAN settings the router's set up to use. (i.e. if your IP is like and subnet is, Internet Sharing can't be using 192.168.anything, or if your IP is like and your subnet is you need to make sure your machine's not giving out 192.168.1.x addresses.. it can get kinda hairy).

to be honest, I'd echo phyrewerx's suggestion. wireless bridges don't have to be pricy. I in fact bought the linked-to Netgear ME101 for my Xbox and it works great; the only hitch with it was the power brick had an european plug on it and it didn't look like the adapter they sent worked (it did, but it's not like those things aren't easily replaceable anyway). it just joins my network and I don't have to screw with having a laptop on and all that. (as an aside and almost a derail, I'd avoid d-link wireless products. haven't seen one work right yet.)
posted by mrg at 5:14 PM on November 27, 2005

What you really want to do is a bridged network on the WinXP machine.

Go to Control Panel, Network connections. Highlight the Local Area Connection and the Wireless Network Connection, right click, and then choose Bridge Connection. This will allow you to use the Win XP machine to bridge the network between the OS2 and the router. Then, you'll need to connect a crossover cable between the PS2 and the WinXP machine.

Email me at the address in my profile if you need more help from there.
posted by stovenator at 12:36 AM on November 28, 2005

Thank you! Bridging the connections worked like a charm.
posted by sanitycheck at 1:25 AM on November 28, 2005

For anybody reading in the future, that should be PS2, not OS2. :-)

Glad to know it worked.
posted by stovenator at 8:09 AM on November 28, 2005

« Older What is apple fuzz?   |   Where to hoe-down? Newer »
This thread is closed to new comments.