Help me to not hate Lion
July 28, 2011 12:26 PM   Subscribe

Please help me not hate OSX Lion. Even though I have deselected "Restore windows when quitting and re-opening apps" every time I launch Pages, it opens several recent documents. This is driving me nuts.

I'm embarrassed to even be asking this, but I cannot seem to figure this out. This problem, combined with some stability and performance issues, is making me wish I had stuck with Snow Leopard.

Thanks, as always.
posted by 4ster to Computers & Internet (8 answers total) 7 users marked this as a favorite
 
FWIW, I hate it too and am trying to downgrade, though my 10.6 will no longer boot since Lion was installed. :p

This link helped me:

How to De-iOS-ify Max OS X Lion.
posted by procrastination at 12:37 PM on July 28, 2011 [4 favorites]


If you want to disable this feature for all applications, you can do so in system preferences-->General

If you want to disable this on an app-by-app basis only for Pages enter this console command in the terminal "defaults write com.apple.iWork.Pages NSQuitAlwaysKeepsWindows -bool false"
posted by Another Fine Product From The Nonsense Factory at 12:39 PM on July 28, 2011 [1 favorite]


p.s enter it without the quotation marks, obviously.
posted by Another Fine Product From The Nonsense Factory at 12:40 PM on July 28, 2011


Out of curiosity, if you open Pages, click the "Pages" menubar item, and then hold down the option key, what does it say next to the Quit entry? Does it say "quit and keep windows" or does it say "quit and discard windows?" That may help diagnose the underlying problem.
posted by jedicus at 12:45 PM on July 28, 2011


Another Fine: I tried that terminal command, but nothing changed.

Jedicus: When I press the Option key, it says "Quit and keep windows."
posted by 4ster at 12:50 PM on July 28, 2011


If these Pages docs were opened originally before you ticked that box, I think they'll keep opening when you start Pages until you go in and close them individually and then quit Pages. I just did a test and found when I did this, the older restored files are no longer being restored. Any new document I created would not be present one relaunch.

I noticed the older Pages docs that were getting restored were "locked" when I opened Pages after ticking the box in Settings to stop restoring. This actually may be a good behavior since if gives you a chance to save the version you might want somewhere then close the doc. If you inadvertently ticked the box in Settings, and opened Pages and didn't see files you expected to see opened, you might be surprised.
posted by birdherder at 12:53 PM on July 28, 2011


I would also be interested to hear if there is a Lion fix to disable the Spaces switching animation, as it is now back on again.
posted by lundman at 10:53 PM on July 28, 2011


FWIW, I hate it too and am trying to downgrade

the worst thing about doing that (yay backups!) is having to re-learn how to scroll, AGAIN.

How to De-iOS-ify Max OS X Lion.

sweet!
posted by russm at 6:47 AM on July 29, 2011


« Older Is "too hungover" a valid excuse?   |   The bathroom is supposed to be my happy place, not... Newer »
This thread is closed to new comments.