I want mexican food but english instructions
November 23, 2010 9:35 AM   Subscribe

why am I being redirected to the mexican version of allrecipes.com?

I type allrecipes.com into the address bars of both firefox and chrome. I get sent to allrecipes.com.mx. This happens on two different computers on the same network. On one computer I'm fine.

I know this could be malware. I'm running full malwarebytes scans on both of those computers as we speak.

But is there a quick workaround? I'm trying to make lunch.
posted by tylerfulltilt to Computers & Internet (11 answers total)
 
Not sure why it's happening to you. However, if you search for "Allrecipes" in google, you get a handy search box under the result, which you can use to look for what you want for lunch. It's a workaround.
posted by stoneweaver at 9:37 AM on November 23, 2010


From looking at the site, there should be a bar at the bottom where you can choose your version. Have you tried that?
posted by kmz at 9:38 AM on November 23, 2010


When I click the us/canada link at the bottom of the page i get sent right back to allrecipes.com.mx

trying the google search workaround right now
posted by tylerfulltilt at 9:40 AM on November 23, 2010


i tried the google search and found the direct link to the recipe i want. But clicking it redirected me as well. But there was a cached version I clicked and that brought up the recipe i wanted in english.

thank you guys for your help. I hope all the malware writers of the world slip in the shower and crack their heads.
posted by tylerfulltilt at 9:42 AM on November 23, 2010


I wonder if it would help if you cleared your cookies?
posted by aniola at 9:43 AM on November 23, 2010 [1 favorite]


Where are you located? And are you using a proxy? I wonder if the site is trying to do a sort of auto-localization thing based on your IP address?

Allrecipes.com comes up as 64.94.140.201. What happens if you enter that IP address into your browser? This, or perhaps doing a tracert to www.allrecipes.com may help uncover DNS weirdness that may be going on.
posted by xedrik at 9:49 AM on November 23, 2010


So it looks like their doing geolocation based on your IP.

According to their "About" site you should be able to select an alternative using the navigation at the bottom.

http://allrecipes.com/Help/questions/faq/Localization.aspx
posted by bitdamaged at 9:54 AM on November 23, 2010


(its the EEUU/Canada link on the bottom)
posted by bitdamaged at 9:55 AM on November 23, 2010


Sounds like it;s thinking your IP address is in Mexico, and auto-changing the URL based on that.
posted by deezil at 10:03 AM on November 23, 2010


could be your browser is running through a proxy based in mexico, when your malware scan is done, you should check your browsers for proxy settings
posted by yeahyeahyeahwhoo at 10:35 AM on November 23, 2010


Some sites try to be clever about languages. I have that problem with Blogger sites, for example: the things Blogger itself adds to the page are displayed in Japanese.

The reason is that I have my browser set to support both English and Japanese, and when my browser makes a request it indicates that both languages are supported here. Evidently there's no way to indicate which I prefer (obviously English) and Blogger decides that all dumb Americans are English-only, so if I'm also saying Japanese is fine, then that must be what I prefer.

Do you have your browser set up to support Spanish language? I bet that if you eliminate that, the site will display in English.
posted by Chocolate Pickle at 4:16 PM on November 23, 2010


« Older Adding lining to wool dress pants   |   Modem, Router, or Us? Newer »
This thread is closed to new comments.