Microsoft Word Adds Thousands of Pages?
March 2, 2005 1:16 AM   Subscribe

Anyone great with dealing with Microsoft Word problems? It's adding thousands of blank pages to my document! Please help...I'm in the middle of writing my thesis...

I'm writing my Master's thesis (chemistry) in Microsoft Word, on my Mac laptop (Ti Book running OS 10.3.5; updated to Word 2004 from Word X just now to try to solve this problem with no luck). My document is about 50 pages right now. Problem: every so often, Word goes nuts and starts adding thousands (yes, thousands) of blank pages into my document. I can make it stop only by closing the document without saving (which of course sucks if I haven't saved immediately before this happening). When I open the doc again, sometimes it still has the thousands of pages, sometimes not. This seems to happen when either I am: (1) moving a figure or (2) typing in the middle of the doc (pushing other text and figs down). So it seems to be some sort of problem related to the moving of figs and/or text. Has anyone had this problem before? What can I do to make it not do this anymore? Please help...I'm desperate.
posted by rio to Computers & Internet (15 answers total)
Best answer: It was a while ago (around 1998, when I was writing my Master's thesis, so probably Word 6 or Word 97 on Windows), but I had a "dodgy" image which caused all sorts of poltergeist-like behaviour in one of my chapters. It took a lot of sorting out to track it down. One thing worth noting is that Word is crap at dealing with megalithic documents, and is much better at dealing with large documents split into chapters. This has the advantage of allowing you to work on it a chapter at a time, as each chapter is effectively a standalone document, and you link them with a "Master" document.

I'd advise splitting the document into chapters, and then at least you'll have some idea where within the document the problem is occurring, and it will only affect one chapter:
appears to be the M$ article describing the process. You can still get table of contents and consistent page numbering through the master document, so you don't lose any formatting.

Or, of course, switch to LaTeX. but that might be a bit much if you've already created 50 pages of microsofty stuff. One thing I decided was that I was never going to use a microsoft product to write a thesis again.
posted by handee at 1:25 AM on March 2, 2005 [1 favorite]

I couldn't find a mention of your specific problem, but the folks at the microsoft.public.word.application.errors [Google Groups] newsgroup are generally very helpful with these things. I'd consider asking there, too.
posted by ori at 1:31 AM on March 2, 2005

Response by poster: Thanks to both of you. I will try the Master Doc thing suggested by handee, and ori--that link was helpful; through it, I found out the name of this problem is "infinite pagination" and is related to figures/tables anchoring themselves to paragraphs. Here's what I discovered, and this too. If anyone else has any other clues or fixes please add them here!
Also, I'm wondering this: if this problem is associated with the figures anchoring themselves to paragraphs as the second link I posted claims, is there a way to turn off this anchoring globally? Or does that just take away the ability to move the figures around altogether?
I am certainly NOT going to use M$ Word for my Ph.D. dissertation when that time comes around. I'll have to look into this LaTeX of which you speak, handee!
posted by rio at 2:05 AM on March 2, 2005

Oh, LaTeX is brilliant for dissertations and theses. If only it could write my phd for me as easily as it is typesetting it.
posted by handee at 3:20 AM on March 2, 2005

In future, I would definetly reccomend Lyx Mac a nice easy to use LATEX frontend for mac. I've been using it for all my university work for a couple of years. Combining it with BibTEX, a cool citation aid program, makes it indespensible for me. Once you go to proper typesetting, you never go back ;)
posted by Thoth at 3:53 AM on March 2, 2005

On preview, you are doing this thesis in Chemistry?? I'd switch to lyx now just for the equation support..
posted by Thoth at 4:02 AM on March 2, 2005

Best answer: The explanation in rio's second link sounds possible:
It may have to do with the Keep Lines Together Property or it could be one paragraph is spanning multiple pages and the object is looking for a paragraph mark to anchor to, and cannot find it,because no paragraph either begins or ends on that page.
Try getting rid of paragraph formatting such as the "Keep with next" setting. You can use the search function to look for such formatting.

In the version of Word I have (yours is probably similar):
1. Edit > Find
2. Click More
3. Click Format and select Paragraph
4. Select the "Line and Page Breaks" tab
5. Select one (not all) of the suspect paragraph settings.

Search setting by setting (I see four of them) to see which one falls on the pages you have trouble with. If this paragraph formatting is defined in one of your styles, try modifying the style definition.

Also, can you paste the graphics inline (without using anchors)? If it's enough for your purposes to paste a graphic into a paragraph and center the paragraph, do that.
posted by pracowity at 4:14 AM on March 2, 2005 [1 favorite]

Best answer: For long complex scientific documents, you can't beat LaTeX. The math support is stellar, and wait until you start playing with BibTeX.

LyX is fine, as is Scientific Workplace, but in the long run you're better off sucking it up and learning to use LaTeX in emacs, WinEDT, or other popular TeX-aware editor. Start by converting an old paper to LaTeX and learn what you need to know as you go.

How to deal with your problem now:

(1) Master doc, by all means.
(2) Don't move graphics. That's layout, and layout can bloody well wait until you have all your content --done--. Keep a separate document or documents for figures and tables, and just leave a placeholder in the main document; one of those FIGURE ONE ABOUT HERE or TABLE 1 GOES AROUND HERE things that you probably see in preprints and working papers. While you're writing it, you want a thesis with no figures in the file. Once everything is written and the tables and figures set up, then it's time to merge everything together.
(3) That makes it easier to switch to LaTeX, as the file you're translating is just plaintext (maybe with equations).
(4) If you have equations, check and re-check them. Word sucks a dog's butt at them and has probably screwed up at least one.
posted by ROU_Xenophobe at 6:30 AM on March 2, 2005

I also agree with the LaTeX recommendation for scientific papers, but make sure you understand that it's likely not a matter of picking it up and using it immediately. It'll have a bit of a learning curve, so it may not be appropriate for this particular project if you're almost finished already.
posted by jnthnjng at 7:25 AM on March 2, 2005

<slightly off-topic>
I, too, recommend LaTeX for scientific (and many other) documents.

I use TeXShop on MaxOS X for texts about mathematics and physics. You might want to check it out if you decide to switch to LaTeX.

To help you get started, check out the TeX Users Group web site.
</slightly off-topic>
posted by amf at 9:38 AM on March 2, 2005

Best answer: and you link them with a "Master" document.

Warning: Microsoft Word master documents are fine as a bare-bones skeleton for linking chapters together. But doing editing within master document is reported to cause a lot of problems; make your changes within individual chapters.
posted by WestCoaster at 10:05 AM on March 2, 2005 [1 favorite]

Just want to double the recommendation for TexShop from amf. I've seen a bunch of WYSIWYG latex editors (eg Lyx), and it's just not worth it. TexShop is an absolute joy to use and doesn't give up any of the control you'll come to appreciate if you're typsetting something as long as a dissertation.

A word of warning, though. Texshop has the most arcane install process of any native OS X app. They can't distribute the tex core in the installer, so you have to use some bizarre package management system to get it or do it by hand.
posted by heresiarch at 10:21 AM on March 2, 2005

I KNOW THIS ONE!! Had this problem at work with large documents, and IT fixed it.

It's a font substitution problem. Really.

Tools > Options > Compatibility > toggle "Substitute fonts based on font size"

This ought to solve the problem. Alternatively, you can select all and change the font.
posted by mudpuppie at 12:53 PM on March 2, 2005

Response by poster: I know this sounds silly but I feel like crying with gratitude. Yeah, it's about that time in my thesis progress. :) Thanks to ALL of you for your suggestions. I will try out what I can for now (I'm nearly done with this so the LATEX stuff will have to wait until my Ph.D. or next article) and I will definitely return to this thread to mark the best answer(s) once I try everything out--and after my defense. :)
posted by rio at 5:06 PM on March 2, 2005

ROU_Xenophobe: If you have equations, check and re-check them. Word sucks a dog's butt at them and has probably screwed up at least one.

Also on the equation front, if you have access to Visio it is much easier to create the equations in Visio and then paste them into Word.
posted by Mitheral at 11:19 PM on March 2, 2005

« Older What is this song?   |   Nonlinar Music Newer »
This thread is closed to new comments.