Skip

How to use a 32" CRT as a computer monitor?
August 10, 2008 4:43 PM   Subscribe

I want to be able to use my 32" television as a secondary computer monitor for games/movies. There are many tutorials for doing this on the internet but I'm having a heck of a time actually getting this to work. What am I doing wrong?

Computer is relatively new, runs Windows XP SP2 and has an nVidia 7300 GS card with a VGA, DVI and 4-pin S-Video port. Newest video drivers (as of today) are installed.

Television is an unknown model Philips/Magnavox CRT monstrosity with several rows of composite ports and two (pretty sure, but not 100%) 4-pin S-Video ports. If I knew the model I could locate the manual or specifications but neither Philips nor Magnavox seem to have these CRT television sets listed on their sites anymore.

I went to the store and bought a 12' 4-pin S-Video cable. Hooked one end up to the video card, other end to the television. Messed around with the settings and configurators in the nVidia control panel.

I'm getting a signal on the TV, but unfortunately it is about as clear as watching scrambled porn. It's constantly fuzzy and doesn't display anything coherent. I know it's getting a signal from the computer since I can make out certain things depending on what's on my monitor ("hey, that looks like a nipple!") but it is absolutely unusable.

I am assuming that something, either the resolution, bit depth, or frequency is incorrect but the nVidia control panel does not make it easy to change any of these things. I'm pretty sure at one point I did find somewhere I could change the resolution but the lowest it would go is 800x600 and didn't seem to have any effect on the display.

If it matters, the control panel keeps referring to my TV as being an HDTV. It is not an HDTV.

Any suggestions? All the computer hardware I find seems to facilitate watching TV on your computer monitor, not the other way around. Furthermore I could not find any useful adapters or anything at Fry's; I couldn't even find a VGA-to-composite converter (yes, I was getting that desperate).

If you need any more information about the setup then please ask; I'd really like to be able to accomplish this task.

Thanks
posted by Ziggy Zaga to Technology (10 answers total) 3 users marked this as a favorite
 
So I think the problem is that your Video card is outputting the wrong signal because that card supports analog TV output (which is the one you are using with S-Video).

I think your control panel referring to your TV as an HDTV is a red-flag. Check around the control panel to see if you can change the output somewhere.
posted by the_dude at 4:54 PM on August 10, 2008


NTSC resolution is 648 by 486, close to std VGA (640x480). In my experience, it will always look fuzzy. The way I worked this is to never use the TV display for anything but movies (and games, for you), it's just not a high enough resolution to represent even 800x600.
posted by rhizome at 5:02 PM on August 10, 2008


what do you mean by fuzzy? is it like scrambled cable or a badly-tuned TV station, or is it just not clear? are you cloning your desktop, or are you using the TV as a second display? (cloning might be screwing it up, especially if your regular monitor doesn't really understand 800x600 or 60Hz.) is your normal monitor using the VGA or the DVI connectors? if it's VGA, can you use the DVI instead? (some video cards might get confused if you're using two analog outputs, or the SVideo and the VGA might actually be tied together.) how many regular monitors do you have? does the S-Video cable work? (try it on your DVD player.)

ideally you should use the TV in "Extend" mode, rather than cloning (so you have different stuff on each screen). googling for "extend desktop nvidia" would probably be helpful - for the most part, it doesn't matter that the second monitor is a TV. since it's a normal TV, you should probably not go any higher than 800x600 at 60Hz. you should be able to set this in the Monitors pane in the Display Properties thing - there's a List All Modes button. (this is something that's part of Windows, not any sort of video driver thing.) be prepared for the display to suck unless you've got a video game or a movie going on it - TVs make craptastic monitors. (I recently bought a 37" LCD specifically to be able to read my iTunes library list, which I couldn't do on my old CRT TV.)
posted by mrg at 5:04 PM on August 10, 2008


So I think the problem is that your Video card is outputting the wrong signal because that card supports analog TV output (which is the one you are using with S-Video).

I think your control panel referring to your TV as an HDTV is a red-flag. Check around the control panel to see if you can change the output somewhere.
posted by the_dude at 7:54 PM on August 10 [mark as best answer] [+] [!]


A reboot seems to have fixed the HDTV thing. It is now reporting to be a regular TV.

NTSC resolution is 648 by 486, close to std VGA (640x480). In my experience, it will always look fuzzy. The way I worked this is to never use the TV display for anything but movies (and games, for you), it's just not a high enough resolution to represent even 800x600.
posted by rhizome at 8:02 PM on August 10 [mark as best answer] [+] [!]


Perhaps I didn't explain it well enough; the picture is not just "fuzzy," it is like watching scrambled porn-- there is no consistently coherent picture, it is much like a badly-tuned television station. It's constantly zig-zagging and scrolling up and down.

I did manage to find a way to force Windows to display at a lower resolution than the lowest option it was allowing me (Display properties > Settings > Advanced > Adapter > List All Modes). Setting it to 640x480, 8 bit color cleared up a lot of the picture (but it's still not watchable...it's off-center, still scrolling and waving, and black and white). It's also not consistently this clear.

what do you mean by fuzzy? is it like scrambled cable or a badly-tuned TV station, or is it just not clear? are you cloning your desktop, or are you using the TV as a second display? (cloning might be screwing it up, especially if your regular monitor doesn't really understand 800x600 or 60Hz.) is your normal monitor using the VGA or the DVI connectors? if it's VGA, can you use the DVI instead? (some video cards might get confused if you're using two analog outputs, or the SVideo and the VGA might actually be tied together.) how many regular monitors do you have? does the S-Video cable work? (try it on your DVD player.)

ideally you should use the TV in "Extend" mode, rather than cloning (so you have different stuff on each screen). googling for "extend desktop nvidia" would probably be helpful - for the most part, it doesn't matter that the second monitor is a TV. since it's a normal TV, you should probably not go any higher than 800x600 at 60Hz. you should be able to set this in the Monitors pane in the Display Properties thing - there's a List All Modes button. (this is something that's part of Windows, not any sort of video driver thing.) be prepared for the display to suck unless you've got a video game or a movie going on it - TVs make craptastic monitors. (I recently bought a 37" LCD specifically to be able to read my iTunes library list, which I couldn't do on my old CRT TV.)


Badly-tuned television. I was initially using clone mode but at your suggestion changed it to extended/spanning. No difference.

Monitor is currently using VGA, but I'll see if I can dig up a DVI-VGA converter and try that. Good idea.

S-Video cable works crystal clear on the DVD player.

Will try the DVI thing; still soliciting ideas in the meantime :)

Thanks!
posted by Ziggy Zaga at 5:32 PM on August 10, 2008


Tried the DVI thing using the adapter that came with the video card.

Anytime something happens on the monitor the TV screen flickers briefly, but otherwise there is no picture on the TV at all.

The TV is detected by the nVidia control center but now I cannot set up any kind of dual-monitor arrangement...I can only configure one or the other to be the primary monitor and that's it.

So it looks like the DVI and S-Video are the ones tied together. I didn't run into this issue while using VGA.
posted by Ziggy Zaga at 5:54 PM on August 10, 2008


By some miracle of luck, after yet another reboot the TV does seem to work.

However, the only display mode in which it does work is Clone mode...all other modes still do that scrambled picture thing.

Now if only I could figure out why the TV won't play any videos other than Flash videos...
posted by Ziggy Zaga at 7:55 PM on August 10, 2008


As far as videos showing up - I had to set my TV as the primary display device before DVD software and the like would display on it. PowerDVD and the like only show video in the primary monitor, even in 'clone' setups, the secondary monitor usually just gets the software 'frame' with a blank display inside.
posted by pupdog at 11:29 PM on August 10, 2008


That's what I've read as well, but as I mentioned the TV *only* works in Cloned display mode. If I try to set the TV as the primary display I completely lose the picture on the monitor and the TV exhibits the same symptoms it did initially.

This is so frustrating. I can't wait until I can afford a decent-sized LCD/HDTV with DVI inputs.
posted by Ziggy Zaga at 6:49 AM on August 11, 2008


I'm a little late to the party, but in my experience an HDTV doesn't make configuration any easier. I've had huge headaches getting my HDTV to properly work with Windows XP (and never got it to work with Ubuntu), and I'm a "computer guy". I got mine to work acceptably the same way you did - the miracle of reboot.
posted by antonymous at 9:09 AM on August 11, 2008


Sheesh. Well thanks for dashing my long-term goal :P

Anyway the problem I was having was that on the external display (the TV), it would only show a black box where the video should be.

I tried disabling hardware acceleration but that didn't work.

I poked around in the settings for VLC and in the Video tab I disabled "Overlay Video Output." The video now plays fine on the external monitor.

The end result really is not bad at all. Text is completely unreadable but when watching video, aside from some harsh coloration it looks really good.

Thanks for the tips and guidance!
posted by Ziggy Zaga at 9:23 PM on August 12, 2008


« Older Recommend to me event listing ...   |  Suggestions for antiviral SW f... Newer »
This thread is closed to new comments.


Post