Join 3,572 readers in helping fund MetaFilter (Hide)


Firefox at Work
August 13, 2004 7:16 AM   Subscribe

I really love using Firefox instead of IE as my browser, but I'm having problems with Firefox at work. About half the time I try to use it at work, it won't load anything. It tells me that the page timed out. Whenever this happens, I have to browse with IE instead until Firefox starts working again, several minutes later. I have no problems with Firefox at home. I've heard this is a firewall-related issue, but I don't really understand. Is there a way to fix this?
posted by Tin Man to Computers & Internet (11 answers total)
 
Heh, I asked this same question and didn't really get a response other than it was a Windows/Firefox issue. I still get this problem every now and then, not as much since firefox was updated, but I do get it every now and then.
posted by thebwit at 7:21 AM on August 13, 2004


Hmm, I did a site-specific Google search before posting this question and didn't see your post. Thanks thebwit. Oh well. Looks like there's no clear solution.

(Funny that we both began by saying that we love Firefox.)
posted by Tin Man at 7:41 AM on August 13, 2004


I'm a Mac person, and loaded Firefox on the PC here at this law office, expecting it to be an update of Mozilla. In a few words, can someone explain to me me how it differs/why it's better than Mozilla?
posted by ParisParamus at 7:47 AM on August 13, 2004


Ditto - happens to me at home. Usually, a url copy/paste or a 2nd attempt after a cuppa tea works. Weird one.

PP: it's quick and easy, automagically blocks pop-ups, implements tabbed browsing beautifully and has features which simplify life - like Download Manager, right-click Google search, etc. It's also open source and free, with ongoing development (unlike IE).
posted by dash_slot- at 7:52 AM on August 13, 2004


You can get Firefox to display an error page rather than a dialog box. This has the advantage that you can easily try the page again (like IE's error pages). This often works if it's just a timeout problem. It's not a solution, but it does help a bit.

From the Firefox tips page:
Use error pages instead of dialog messages

By default, Firefox displays annoying error messages if a connection fails, instead of quitely displaying the error information in the browser window as Internet Explorer does. To turn off the error messages and use pages instead, add the following code to your user.js file:

// Instead of annoying error dialog messages, display pages:
user_pref("browser.xul.error_pages.enabled", true);

Note that this feature is still a bit buggy as it removes the last visited page from the Back button history.
posted by bonehead at 7:55 AM on August 13, 2004


dash_slot- at 7:52 AM:

My question was, what's the difference between Firefox and the latest version of Mozilla? (PC Platforme)
posted by ParisParamus at 8:02 AM on August 13, 2004


PP, not much. It's just the browser part of the Mozilla suite - no mail/news, composer, or IRC. It's been dressed up a bit so it looks a little nicer than Mozilla. The Options dialog has been cleaned up a lot. There's a separate Google search bar now, instead of having the search built into the main address bar. The context menu (right-click) Google search opens in a new tab now instead of a new window. It no longer has Quicklaunch, which I like a lot on the old, slow PC I have to use at work. Without Quicklaunch it starts right up on any newish computer, though.

(These are off the top of my head, I'm sure there are a lot more differences....)
posted by zsazsa at 8:11 AM on August 13, 2004


Sorry, PP.
Thanks, zsazsa.
posted by dash_slot- at 8:23 AM on August 13, 2004


Thanks--that was my impression (although I can't find quick launch in the newest Mozilla either)
posted by ParisParamus at 8:27 AM on August 13, 2004


do you connect through a proxy at work? check your IE connecton settings to see if you have a proxy configured, and if so, copy the settings to firefox maually.
posted by Hackworth at 8:42 AM on August 13, 2004


Hackworth's suggestion is the way I got around the problem with the firewall at the last place I worked.

Specifically, in IE you can find this information under tools, internet options, connections tab, LAN settings button.

Under Firefox go to tools, options, general, connection settings button, select manual proxy configuration and then enter the corresponding information in the http proxy field.

Fingers crossed that that'll help. The good news is that, if you're using the same computer at home and at work, firefox makes it easy to choose between direct and proxy connections without having to enter the data each time.
posted by nthdegx at 8:58 AM on August 13, 2004


« Older Is there an open-source web ap...   |  Programming languages: I'd lik... Newer »
This thread is closed to new comments.