Join 3,418 readers in helping fund MetaFilter (Hide)


Basic Audio Recording with Audacity: Need help removing the microphone from the input mix
December 9, 2007 5:51 PM   Subscribe

I'm using Audacity to record audio from various software on my laptop, but it's grabbing info from my microphone instead of my speakers. How do I fix this?!

I am newish to using Audacity. The first time I used it was on my old laptop, and I was able to use it perfectly the first time. Now I have a new laptop (a Dell running Vista), and whenever I try to record, it defaults to the input coming from the microphone. I can't figure out how to make it where the input is just what's playing through the speakers (browser, audio software, etc).

Any ideas?
posted by abbyladybug to Computers & Internet (31 answers total) 2 users marked this as a favorite
 
I don't know about Vista but in 2000 it was usually a matter of bringing up the Volume Control panel from the task tray, going to Options, Properties, Adjust Levels for > Recording and setting the levels of which input you want to get audio from. I'm sure others will be able to clarify this better.
posted by chips ahoy at 5:57 PM on December 9, 2007


Do you mean the Windows task tray?
posted by abbyladybug at 6:01 PM on December 9, 2007


On the menu bar is a drop box. Yours probably says "microphone". Select the one that get input from the sound card (on mine it's "Stereo Mix".
posted by OlderThanTOS at 6:04 PM on December 9, 2007


Did you try the control panel?

Start>Control Panel>Hardware & Sound>Manage Audio Devices
posted by MiaWallace at 6:05 PM on December 9, 2007


Just for reference, I took a screen shot of what I'm seeing in Audacity/
posted by abbyladybug at 6:11 PM on December 9, 2007


These instructions might help. To summarize:
1. Select sound from the control panel.
2. Select the recording tab.
3. Right click on the background of the tab and choose "show disabled devices."
4. Right click on Wave Out Mix and click enable.
5. Now it should work the same way as Wave Out Mix in Windows XP, allowing you to record any sound your computer makes.
Apparently it depends on your soundcard, I'm not having any luck on my own new Vista laptop (thankfully I didn't buy it for audio).
posted by malocchio at 6:16 PM on December 9, 2007


I am able to go into Start > Control Panel > Sound

Then I see three tabs: Playback, Recording, and Sounds

When I select, Recording, I am able to disable the "Microphone Array", but when I do that and then try to use Audacity, I get an error message: Error while opening sound device. Please check the input device settings and the project sample rate.
posted by abbyladybug at 6:17 PM on December 9, 2007


Sorry, the responses are so fast that I can't try things as fast as people are posting suggestions (I LOVE that!).

Anyway, Malocchio, I tried what you said, but when I do that, I don't see an option for "Wave Out Mix". I wonder if I'm missing some driver or something. The only recording devices I have are: (1) Microphone/Line In and (2) Microphone Array
posted by abbyladybug at 6:20 PM on December 9, 2007


It's been a while since I used Audacity for anything, but I'm pretty sure you don;t want it to use anything on the recording tab, but the playback tab. You want Audacity to grab playout from your computer, not stuff coming in.
posted by pupdog at 6:25 PM on December 9, 2007


I should clarify - You're trying to record the output from other programs, correct?
posted by pupdog at 6:27 PM on December 9, 2007


Oh! That makes sense, pupdog. Still, I don't see this famous "Wave Out Mix". Any ideas?
posted by abbyladybug at 6:30 PM on December 9, 2007


I used to be able to record the audio output when I was using a desktop, but my new laptop doesn't have a sound card that supports that. Your issue may be a hardware limitation.
posted by roomwithaview at 6:33 PM on December 9, 2007


I don't think that's what it's going to be called on most Vista machines, I've only got XP machines at hand, most of these have just 'Wave' as an option in output controls, along with Master, SW Synth, CD, etc. Part of what I hate about Vista is how they changed the naming/organizing conventions just enough to make it hard to use for folks that had been dealing with them for years...
posted by pupdog at 6:34 PM on December 9, 2007


I don't know... I sure did add a lot of bells and whistles on this machine when I ordered it. If someone can tell me exactly what hardware it is that I need to have installed for this to work, I'd be most grateful!
posted by abbyladybug at 6:37 PM on December 9, 2007


So, if you don't have any options in the blank drop down box (right edge of your screen dump), then your Audacity is not seeing your hardware properly. Maybe you need to update drivers?
posted by OlderThanTOS at 6:44 PM on December 9, 2007


Yeah, I'm stuck as well. I'm familiar with Audacity under XP, but Vista is a completely different beast. And I still think we need to select the recording source as being "wave out," but that just isn't an option on my Inspiron 1721 with a Soundblaster Audigy card running Vista (latest drivers, I checked.)

Most of the workarounds that I can find require running a cord from the line out into the microphone input. Which is stupid, but it should work.
posted by malocchio at 6:49 PM on December 9, 2007


So I am not sure if this is a Dell laptop with the Sigmatel sound card but if it is then the Mix out is (deliberately) disabled/ removed. I had a hell of a time getting it back (for Windows XP including customizing an installation ini. There is a couple of different resources if you google for it. First result is for Vista.
posted by clarkie666 at 6:52 PM on December 9, 2007


OK, I'm officially REALLY CONFUSED!
posted by abbyladybug at 6:58 PM on December 9, 2007


If you're using the most recent beta of Audacity, go to Edit / Preferences / Audio I/O. There you'll see a combined dialogue box for Playback and Recording. Under recording, if you see an option called "Stereo Mix", select it. (On mine it's called Windows DirectSound: Stereo Mix.)
posted by evilcolonel at 6:59 PM on December 9, 2007


OK here's what I think is happening. Your sound card/ machine is physically able to record the Mix out or Stereo mix, i.e. everything that goes through the sound card, however the manufacturer has disabled this feature, the option to switch it on has been removed. When this option has been removed from Vista - it will not appear either in Audacity.

Therefore instructions to go and switch this on in Vista will not work, no addition of hardware will solve this problem. You can re-install the drivers which make the sound card function with the Mix switched on, however you will need a custom installer which enables this function since the standard installer which came with your machine will just keep disabling it

Unfortunately there is a lot of different instructions on this since there are a lot of different laptops and hardware, as I mentioned all the instructions I found (for the Latitude D630) did not work and I had to put together a combination of a couple of different instructions.

Do you want to let us know the laptop and the sound card and I can go look this up for you.
posted by clarkie666 at 7:10 PM on December 9, 2007


Yes! Because I went and got the suggested download from CNet, and it didn't work. Said it was not the correct audio driver for my system. OK, so I have an Inspiron 1420. When I go into my Device Manager, it's saying Sigma Tel High Definition Audio CODEC. Is that the correct information?

(Sorry, I understand the internet and software, but the hardware part isn't my forte!)
posted by abbyladybug at 8:01 PM on December 9, 2007


That's the same on-board audio that I see. Did you upgrade the audio to the Audigy Integrated? I thought it was a hardware upgrade, but apparently it just forces the integrated audio to emulate the Audigy.
posted by malocchio at 8:32 PM on December 9, 2007


I think that I did not do that. Is that a problem?
posted by abbyladybug at 9:54 PM on December 9, 2007


Ok malocchio seems to be on a different track, this may be faster - and if it works then good luck to ya!

If not give me your ID I can try to change the installer to enable this. Can you open the Sigma Tel High Definition Audio CODEC Properties from the device manager and click on details. Then give me the Device Instance ID. I can then try to look into a modified installer.
posted by clarkie666 at 11:30 PM on December 9, 2007


Your problem is the DRM in Vista. Microsoft has decreed that you are not allowed to record your own output, because you might be a music pirate.

You thief. How dare you use your computer in a way Microsoft doesn't like? You don't own that hardware anymore... you rent it from Microsoft and Hollywood.

Either get XP, or read this prior AskMe thread.
posted by Malor at 1:39 AM on December 10, 2007


Actually, I'm stumped at this point (and I don't think the Audigy upgrade makes any difference here - it seems pretty worthless to me). clarkie666, it sounds like your powers are far greater than mine - tweaking installers is out of my league.

(Malor is entirely correct, Microsoft doesn't want to allow this little piece of functionality, and they've intentionally crippled Vista. I've had a lot of growing pains when upgrading OS over the years, but this is the first time I've seen functionality actually decrease.)
posted by malocchio at 6:57 AM on December 10, 2007


hmmm - I was always under the impression that it was a manufacturer (either computer or sound card) cripple rather than a Vista disable. My machine came pre-installed with Windows XP and this was also intentionally disabled for my system when I got it. The installer for the sound card for XP or Vista (it is compatible with either) contains a list of settings which enable or disable features depending on the sound card (e.g. Dolby, EQ, etc.) These settings are contained in the WDM folder of the installer. Earlier versions contain the setting to switch on Stereo Mix, newer versions do not have this setting / or the setting is set to '0', i.e. off.

Anyways abby - I have send you a PM about the Device ID (which tells me which INI file to modify in the installer), lets try to fix this and report back to the hive. If it works then it is not a Vista thing, if not well.....
posted by clarkie666 at 10:44 AM on December 10, 2007


OK, got the PM, and I think I've sent you what you need. Look forward to seeing if this is fixable.
posted by abbyladybug at 11:11 AM on December 10, 2007


I'm assuming, from the lack of followup, that this indeed a Vista misfeature.
posted by Malor at 1:00 PM on December 12, 2007


I'm assuming, from the lack of followup, that this indeed a Vista misfeature.

I'm running Vista and I have no such problem.
posted by evilcolonel at 2:02 PM on December 12, 2007


OK, the PM-ing has stopped for now. I still don't have a solution. So you don't have this problem? What's wrong with me?!!
posted by abbyladybug at 4:27 PM on December 12, 2007


« Older Attention swimmers- please hel...   |  I need gag vids. The kind tha... Newer »
This thread is closed to new comments.