Join 3,512 readers in helping fund MetaFilter (Hide)


My laptops internal wifi card keeps disconnecting
August 24, 2007 7:26 AM   Subscribe

How do I stop my laptops internal Wifi card from disconnecting?

I have a Dell Latitude D620 laptop.

It worked fine for around 3 months, then all of a sudden I started loosing my Internet connection.

Windows says you are still connected, however if you run a Ipconfig in dos you get this:

Windows IP Configuration

Ethernet adapter Wireless Network Connection 2:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.1.134
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected

Ive tried everything but can't stop it from doing this, it seems to do it at totaly random unprovoked intervals. If you disconnect and reconnect it will be okay for maybe another 5 minutes or maybe 50 if your lucky.. but it will just happen again.

I have tried installing a PCMCIA wifi card and the same thing will happen to that.

Im fairly certain its some kind of internal windows config error.

Windows XP sp2
Spybot Clear
AVG clear
posted by complience to Computers & Internet (7 answers total)
 
Perhaps I'm missing something, but the ipconfig output looks correct.

the part:
Ethernet adapter Local Area Connection:

Media State . . . . . . . : Media disconnected
means that your LAN (wired) connection is disconnected, which I assume is true.

Your wireless connection seems to have a valid IP address and gateway:
IP Address. . . . . . . . . .: 192.168.1.134
Subnet Mask . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . : 192.168.1.1
posted by nightwood at 8:10 AM on August 24, 2007


yikes. Sorry about the formatting. I don't know what happened there.
posted by nightwood at 8:10 AM on August 24, 2007


I had a Thinkpad that did this because of power management. It had some dumb software that would shut down the Wifi card it wasn't used for a couple of minutes. I don't think Windows default has a setting like that (but could be wrong). But maybe Dell does?
posted by Nelson at 8:11 AM on August 24, 2007


could be power management there is a setting to save battery power.. but i definately have it turned right off and am plugged into mains power anyway.
posted by complience at 8:33 AM on August 24, 2007


this comes up a lot here. One thing you don't seem to be considering is that your access point could be flakey, or are you having this problem at a variety of dissimilar access points.
posted by Good Brain at 9:08 AM on August 24, 2007


Yeah, does this happen just with one access point, or anywhere you go? Could be a channel conflict with another nearby AP.
posted by Brian James at 1:28 PM on August 24, 2007


For what it's worth, My Dell (Inspiron 6400) does this as well. I have to open the wireless connections dialog and Disconnect/Reconnect the wireless connection for it to start working again.

Haven't been annoyed yet to look for a solution, but you're not alone with this problem.
posted by davey_darling at 4:48 PM on August 24, 2007


« Older In relation to printing/publis...   |  iPod dreams and hacks. I'm in ... Newer »
This thread is closed to new comments.