Join 3,520 readers in helping fund MetaFilter (Hide)


Firefox to Internet
March 18, 2007 6:41 PM   Subscribe

Why won't my laptop connect to my wi-fi? :-(

I have a Dell laptop and a wireless network in my apartment. When I start up my laptop, browsing the internet works just fine. If I close it, though, when I reopen, Firefox won't let me browse! Apparently I'm still connected to the internet--Trillian connects just fine--but Firefox won't connect.

What gives? :-(
posted by jefficator to Computers & Internet (21 answers total) 3 users marked this as a favorite
 
Sounds fishy. Firefox and Trillian are similar, in terms of how they operate.

What does "close it" and "reopen" mean?

Suppose you try other tools? Give us more data points about tools that work and don't work.
posted by cmiller at 7:00 PM on March 18, 2007


What does IE do? (Yes, I know, but just try it.)
posted by Steven C. Den Beste at 7:10 PM on March 18, 2007


Another thing to try: when Firefox won't work, can you ping Google?

From a command prompt, type "ping google.com". If that works, it not only means that the network connection is open; it also means you have access to a DNS. If that doesn't work because of a name lookup failure, try "ping 72.14.207.99". (That's Google's IP.)
posted by Steven C. Den Beste at 7:13 PM on March 18, 2007


I think you are referring to closing the lid of the laptop, correct?

If so, I have a Dell laptop as well and something similar would happen to me (on a wired Ethernet network though). Something similar would happen sometimes when I used "Stand By" in windows.

For me, at least, the closing the laptop lid thing was cured going to Power in ctrl panel ---> Advanced and change "when I close the laptop lid" to "do nothing".

Hope it helps.
posted by jourman2 at 7:14 PM on March 18, 2007


Yet another thought: are you trying to use a copy of Firefox you had running when you put the system to sleep? Try killing it off and starting a new instance, and see what that does.
posted by Steven C. Den Beste at 7:14 PM on March 18, 2007


I'm sorry...I worded that incorrectly.

If I close my laptop, when I reopen the laptop, this problem occurs. Every indication is given that I am connected to the internet via my wi-fi. The bars are at full-strength on my wi-fi meter, and Trillian connects both to yahoo and AIM. But Firefox won't connect to a website!! I have to restart every time.
posted by jefficator at 7:14 PM on March 18, 2007


Also you can try disabling the wireless connection then re- enabling it when the problem arose. I seem to recall that helped too.
posted by jourman2 at 7:14 PM on March 18, 2007


* arises
posted by jourman2 at 7:15 PM on March 18, 2007


I have disconnected from my WiFi server and reconnected, to no avail. I have reset the receiver. I have even tried using IE. Nothing works!
posted by jefficator at 7:18 PM on March 18, 2007


I was having really weird Wi-Fi problems with my laptop and my computer tech friend found out that my lappy came with two diffferent wireless device "managers" installed.

I'm not a computer person and I could ask him - but he said there was the default wireless software and some extra one as well fighting over the connection.... I'll email him and see if he can clarify that... but I had similiar issues.
posted by meta x zen at 7:50 PM on March 18, 2007


Two different things:

1) Try disabling and reenabling the wifi- not simply disconnecting.
Open Network Connection (Start --> Settings --> Control Panel --> Network Connections). Right click on the wireless connection and disable. Wait a minute and enable it (depending on what you meant, disconnecting can be the same thing or different than what I what I'm referring to). See if WiFi works now.

2) Go back to your Control Panel and open Power Options. I don't have a laptop on hand, but there's a section with an option for what to do when you close the lid. Most laptop defaults are set to "stanby." Change this to "do nothing" or "turn of monitor." I'm thinking that closing your laptop causes it to go on some kind of power-down mode turning off your WiFi and thus causing things to be screwy so we need to prevent the power-downing from happening.'
posted by jmd82 at 8:01 PM on March 18, 2007


If your Wifi is passworded (as it should be), go into the wifi properties window and re-enter the password. (On XP SP2, I click the network icon in the systray, hit Properties -> Wireless Network tab -> select the connection -> properties -> re-enter the password, then hit OK in the boxes you have open.

For some reason my laptop doesn't always hang onto the password when I put it to sleep.
posted by IndigoRain at 8:04 PM on March 18, 2007


You might also want to check the properties of your wireless adapter. They'll often have power saving properties of their own.

For example, I have a Wireless-G adapter on this laptop. Under the properties of the Wireless Network Connection, I click on Configure and select the Advanced tab. There I've got Power Save Mode set to Disabled. Some cards will have a Power Management tab with a checkbox to Allow the computer to turn off this device to save power.
posted by JaredSeth at 8:26 PM on March 18, 2007


Set the computer to hibernate, rather than sleep, when the lid is closed. The computer will take a little longer to start but it still won't be as long as a complete reboot. You'll also save a little electricity compared to entering standby mode.
posted by humblepigeon at 1:57 AM on March 19, 2007


Nothing works!

This is why I gave up tech support. Is that a sweeping incorrect generalization, or a contradiction that Trillian does indeed work?
posted by cmiller at 5:58 AM on March 19, 2007


You can try this batch file I made for myself:

ipconfig /release
ipconfig /renew


Use a text editor and save this in text format. Rename it to DNSclear.bat (or really any name followed by .bat) Clicking on it will clear your DNS cache which might help, or not. I have lots of trouble with my WiFi and this is one of the rituals I try.
posted by Joe in Australia at 8:21 PM on March 19, 2007


What OS... Vista?
posted by whatisish at 9:05 PM on March 19, 2007


From a command promt:

ipconfig /flushdns

???

Make a bat file if it works maybe.
posted by whatisish at 9:34 PM on March 19, 2007


The above suggestion is one of many stolen from this thread.

DNS issues seem to make sense given that Trillain works.

Keep us updated.
posted by whatisish at 9:37 PM on March 19, 2007


Oh, and does the "Fix Problem" button in Network Magic actually fix this problem? That might help diagnose it.
posted by whatisish at 9:41 PM on March 19, 2007


Another possible helpful thread.
posted by whatisish at 9:52 PM on March 19, 2007


« Older Can you recommend a new mattre...   |  If you experienced an extended... Newer »
This thread is closed to new comments.