Join 3,440 readers in helping fund MetaFilter (Hide)


Laptop can't see secure wireless network. Can you?
January 21, 2007 7:24 PM   Subscribe

PC laptop wireless issues: Can’t connect to my secure in-house wireless network. Any smart people able to help?

Hey Team Internet,

I’ve got a laptop, and I can’t make it connect to my wireless network.

The wireless connection requires users to be added manually by inputting their fixed and/or wireless MAC addresses. I have added those addresses, and they have certifiably been correctly inputted. The network is not password protected, but will only let pre-authorized computers connect.

My laptop is an Acer TravelMate 280 running Windows XP. The router is a Linksys. In the “Choose a wireless network” box, the network doesn’t even show up as an option. It’s not a matter of distance – the signal is being broadcast from within my house.

When in other locations, I can connect to other wireless networks without any trouble. I can connect fine via a direct plug-in via Ethernet cable. I have another PC laptop that connects fine to the same wireless network. There’s also a new Macbook Pro that can connect fine to the wireless.

Those are the clues to the puzzle! Any ideas how to make this work?
posted by Milkman Dan to Computers & Internet (13 answers total) 2 users marked this as a favorite
 
Is your wireless router broadcasting a wireless protocol that your laptop can't detect (ie. your router is 802.11 G and the wireless card in your laptop is 802.11 B) ?
posted by Burhanistan at 7:27 PM on January 21, 2007


My laptop's wireless card is 802.11 b/g, and my router's box says "Up to 22Mbps and 802.11b Compatible." Sooo...?
posted by Milkman Dan at 7:47 PM on January 21, 2007


Have you tried disabling security temporarily to ensure that the laptop can connect wirelessly AT ALL? If it can, then we can isolate the issue to the router configuration.
posted by Rock Steady at 7:54 PM on January 21, 2007


Is your router broadcasting the SSID? If not, the laptop may not show the network as available. Try turning on the SSID broadcast on your router, see if that works.
posted by shinynewnick at 8:00 PM on January 21, 2007


Make sure the wireless router is set to broadcast the network name (SSID).

Try temporarily disabling the MAC address filtering to see if your adapter can connect. (The router will remember the MAC address list even if you disable filtering so you won't have to reenter them.)
posted by tresbizzare at 8:06 PM on January 21, 2007


Once again I type too slowly..
posted by tresbizzare at 8:07 PM on January 21, 2007


I have a travelmate c110 and it uses the intel chipset. I just went to intel's website and downloaded their drivers. Those may work better if it's an intel chipset on your acer.

Also regarding the Linksys, chek to see if you can load it with firmware from http://www.dd-wrt.com
posted by chaska at 8:39 PM on January 21, 2007


Try adding the SSID manually in your "preferred wireless networks"?
posted by k8t at 8:55 PM on January 21, 2007


Did you put in the correct MAC address of the laptop? My mom's Sony Vaio has 2 MAC addresses. One for the built-in ethernet and one for the built-in 802.11g wireless. I have a similar setup and made the mistake of putting in the MAC address for ethernet.

Off the top of my head, I don't remember how you can check....
posted by Cog at 11:14 PM on January 21, 2007


"... Off the top of my head, I don't remember how you can check...."
posted by Cog at 11:14 PM PST on January 21

In a WinXP command prompt window, type ipconfig /all to have a list of all active interfaces on your machine, and their associated IP and mac addresses, and related information listed. Copy and paste the output of that command back to this thread using the pre tag, for additional diagnostic assistance.

I'll check this thread for the next 24 hours for updates.
posted by paulsc at 1:40 AM on January 22, 2007


Check the laptop's wireless radio switch. This is a hardware option separate from Windows settings. When disabled, it appears that the wireless is working in Windows but no networks are found.

It can usually be found as a switch on the side of the laptop or a Fn + F-key (Fn+F5 on my IBM) functionality. Look around the laptop for anything that could be a wireless icon and see if that helps. I work at a University library and 99% of wireless problems stem from this feature.

Good Luck.
posted by coolin86 at 7:39 AM on January 22, 2007


Problems solved. Here's what I did:

* Installed the 2007 driver updates for my Intel PROSet/Wireless card
* Restarted the computer
* Switched from letting Windows mange my connection, to letting Intel PROset manage it instead
* The signal was immediately detected, but without an SSID. I gave it the correct name, let it know that security was disabled. It is now connected with five bars.

Thanks guys. Priceless support.
posted by Milkman Dan at 8:40 AM on January 22, 2007


I just want to note one small thing: any wireless network that uses MAC addresses as authentication is not secure by any means. It is trivial to sniff the network for packets to determine the MAC address of existing machines on it and then change your MAC address to be the same. This is no security whatsoever. The same is true of SSID broadcast hiding -- it is still out there, and can be determined easily. Neither of these measures actually secure a network. Turn on WPA2 pre-shared-key (PSK) with a long, random passphrase if you want a network that is actually secure and cannot be used by random strangers.
posted by Rhomboid at 12:05 PM on January 22, 2007


« Older Bats in the belfry? No, birds ...   |  Today a friend adamantly claim... Newer »
This thread is closed to new comments.