Join 3,512 readers in helping fund MetaFilter (Hide)


MS Word approving nonsense words in spell check?
December 8, 2006 10:43 AM   Subscribe

Reasons Word tells me a document passed spell check when it has misspelled words in it?

For some reason, when I run spell check on my resume, Word tells me spell check is complete without actually finding the misspelled words. If I run it on any other document, it finds the same misspelled words for me. Any idea why this is? Note that it's not that I've added the words to my dictionary as I can type nonsese like asdlkfjlasdjf and it passes.

I'm on OSX Office X.
posted by You Should See the Other Guy to Computers & Internet (10 answers total)
 
Check your language settings. That document may have somehow gotten set to a language you don't have a dictionary for.
posted by BackwardsCity at 11:00 AM on December 8, 2006


You probably told Word to ignore a that misspelling. Go into the spell checking menu and hit the "recheck" button.
posted by caddis at 11:09 AM on December 8, 2006


Just in case my last comment was confusing, I mean that at one time while spell checking your resume you may have hit "ignore all" when that misspelling was highlighted. For that document only Word will continue to ignore that misspelling, that is until you tell it to recheck.
posted by caddis at 11:13 AM on December 8, 2006


You/another user may have also inadvertently added misspelled words to Word's dictionary.
posted by koahiatamadl at 12:52 PM on December 8, 2006


Note that the OP says he's typing nonsense on the fly and it's passing. It's not a case of misspelled words being added to the dictionary or ignored.

It must be the language thing. Open the document, go to Tools --> Set Language and make sure it's set for your native language. If you don't have the dictionary for a language installed, rather than come up with every word misspelled, it just doesn't do a spellcheck at all.
posted by BackwardsCity at 1:39 PM on December 8, 2006


Playing around with Word just now, I realize you need to select all before you reset the language, or the text you've already typed won't change. Hope this solves your problem.
posted by BackwardsCity at 1:44 PM on December 8, 2006


Press Command-A to select all the text, then Tools,language and untick "do not check spelling"
posted by Lanark at 2:37 PM on December 8, 2006


I have this same problem. Word is constantly missing misspelled word in my docs and I can't figure it out either. My language is set correctly and I've gone into the custom dictionary to see if the misspelled word is there and it isn't so no reason why Word shouldn't catch it. Wish I knew the answer.
posted by gfrobe at 3:13 PM on December 8, 2006


Lanark is probably right. Note that this can be complicated if the text is within tables - afair, each table has to be selected and marked for checking/not checking seperately.
posted by Busy Old Fool at 11:51 PM on December 8, 2006


You can also set exceptions for capital words, words with numbers, etc. The big problem is words which are spelled correctly, but used improperly, like there and their.
posted by Mr. Gunn at 7:28 AM on December 9, 2006


« Older Once I've made my sci-fi novel...   |  I am pretty computer savvy but... Newer »
This thread is closed to new comments.