Join 3,430 readers in helping fund MetaFilter (Hide)


What is the port on this hard drive?
June 23, 2006 11:06 PM   Subscribe

Attempting to plug my old hard drive into an enclosure, but I don't know what this port is or how it connects. Pictures inside.

I'm pretty hardware-useless, so hopefully someone can send me in the right direction. I bought this enclosure. My hard drive is a Seagate ST94Q11A that came with an HP 2100 series notebook.

[1] - The drive and the weird port.

[2] - Close-up of the port

[3] - The port on the enclosure.

[4] - The two ports are the same size, so one cannot plug into the other.

[5] - Probably the clearest picture.

I'm really sorry for the webcam pictures! I thought they would do; my camera is loaned out until next week.

Is there an adapter that I need? How do I get this darn thing connected? From the reviews on Newegg, it looks like it should just plug in easily, but the port on the hard drive is goofy and my geeky pals could not identify it, either.
posted by sian to Computers & Internet (5 answers total)
 
Are you absolutely sure that you can't pull the weird port off to reveal the drive's connector pins (which should then match the enclosure's port?).

I'm guessing that the weird port is an adapter for a non-standard connector inside the laptop, and can be removed. The drive's actual interface should look like this.
posted by I EAT TAPAS at 11:16 PM on June 23, 2006


My god, it works! I was reluctant to go pulling off plastic pieces. Thanks!
posted by sian at 11:22 PM on June 23, 2006


If that's an XTA connector adapter, you might hold on to it as it is pretty rare.
posted by Blazecock Pileon at 11:45 PM on June 23, 2006


related question on the enclosure...did it actually work with the drive? i got one of those from microcenter and tried 2 different drives in it, it would power on the drives but wouldn't actually mount them, and i could here the drives spinning up and down.

i eventually gave up and put one of the drives back in its original enclosure and called it a day.
posted by eatcake at 9:07 PM on June 24, 2006


I tried to use it but it wouldn't detect. I don't know if it's a driver issue or if my HD is hosed.
posted by sian at 4:51 PM on June 26, 2006


« Older Divx seems to make my computer...   |  I'm male, in my early twenties... Newer »
This thread is closed to new comments.