Join 3,438 readers in helping fund MetaFilter (Hide)


Audacity & iTunes Not Talking
February 4, 2006 3:31 PM   Subscribe

My WAV files that are exported from Audacity will not play (or even import) in iTunes! I've done this a thousand times before, why doesn't it work anymore?

I'm using Audacity 1.2.4 and iTunes 6.0.1.3. The files will not open or even show up in iTunes no matter how I try to get them in there.

If I export to MP3 from Audacity (using a LAME encoder) it still won't play in iTunes. So I have a few questons:

1 - Why did this work before, and if I need to get an earlier version of either or both programs, how do I do that? The websites only offer the latest versions.

2 - Is there other free software that I can use to take the Audacity WAV file and convert it into something (anything) that iTunes will read?

3 - Is there another way to get iTunes to read the WAV files without going through a third product?

I'm extremely confused. Thanks a lot.
posted by crapples to Technology (8 answers total)
 
Did your export settings change? Try non-vbr (shouldn't be a problem, but quicktime has some issues with it)? Can you convert the file using the lame command line tool and see if the problem is lame or audacity? This is very strange.
posted by null terminated at 6:38 PM on February 4, 2006


I have no answers, but I've recently had no problems doing this with audacity 1.3 and itunes of the same version as you, so I don't think it's the versions.

(by the way, the odds are you've tried this, but have you right clicked the wav files in the finder and selected open with... itunes? assuming this is os x of course)
posted by advil at 6:45 PM on February 4, 2006


What does non-vbr mean?

I have tried to open the files in every way possible, but they absolutely don't work. I'm using Windows XP, not Mac.

If anyone is still reading this question: How would I convert the file using the lame command line tool? I'm not sure what that means.

If anyone else has ideas - please help. I have tried exporting as AIFF, MP3, & WAV and iTunes will not respond to any of it.
posted by crapples at 7:23 PM on February 4, 2006


OK - I just figured out how to use the LAME command line. The resulting file DOES import and play in iTunes. So I still have no idea what the problem is with the original WAV export from Audacity, but at least I have a work-around. Thanks.
posted by crapples at 7:32 PM on February 4, 2006


VBR means Variable Bitrate. Instead of the filesize and compression being constant over time, it varies depending on how well a particular section can be compressed. Some playback software has trouble with VBR files, but not with CBR, or constant bitrate, files.

Audacity should have options for setting the bitrate when exporting to WAV. You can also fiddle with the sampling rate. I think 44.1 kHz is "normal."
posted by odinsdream at 8:47 PM on February 4, 2006


For the record, there is only sample rate when you're talking about WAV files. It's a lossless format, and thus has no bitrate to vary, as you would with an MP3 file. 44.1 is normal. VBR does apply to MP3s, and though some players have issues with VBRs (vs CBR -- constant), iTunes should not be one of them

I did some Googling -- it could be that your project rate is set incorrectly (not to 44.1). Instructions on examining and changing this setting are here. LAME config info for Audacity is here.

That doesn't explain why LAME command line can handle the MP3 export and Audacity can't... but it may help with your original goal. Along the same lines, AIFF files exported from LAME must be in 16-bit mode as well.
posted by VulcanMike at 10:24 PM on February 4, 2006


I'm an Audacity hacker.

The most common problem with iTunes is that it can't import 32-bit sound files. Make sure you have a 16-bit format selected in Audacity's "File Formats" preferences.
posted by mbrubeck at 8:05 PM on February 5, 2006


Correcting the last sentence of my post above...

(Along the same lines, AIFF files exported from Audacity must be in 16-bit mode as well.)
posted by VulcanMike at 4:41 PM on February 6, 2006


« Older Verizon FIOS vs DSL?...   |  Some of my screen fonts have c... Newer »
This thread is closed to new comments.