Join 3,553 readers in helping fund MetaFilter (Hide)


How can I convince my VoIP router (PAP2T) to connect?
April 26, 2014 6:14 AM   Subscribe

I'm trying to get my VoIP at home (through a PAP2T, working perfectly until now) working with a new router (Linksys DIR-825), and having no luck past a certain point. My provider's support service isn't very supportive.

My tech knowledge is middle-low: as you can see I'm not shy about getting into the interfaces for my router, but have no idea what the more complex settings mean. Lots of links to images below for clarity.

I got a new wireless router (D-Link DIR-825), and have been trying to get our VoIP phone to run through it.The old phone adapter (a Linksys PAP2T) was working fine until I got the new router in place.

I'm as far as having a dial tone, but can't call out (a long, long pause, followed by a fast busy signal), and calling in results in our phone ringing, but nothing but silence on pick-up and the phone that's calling in just hears our phone ringing forever.

Service with this company (Unlimitel, now owned by Primus) is frankly not great: my initial reply was "see our support page", and when I asked for more help than that, got an "open ticket" notification, this reply, and an immediate "closed ticket" notification:
Hello,

You'll need to adjust the firewall settings on your new router.
Please add our SIP server to your firewall's white list or allowed list.

We use port UDP 5060 for SIP signaling.
We use port UDP 10000-20000 for RTP voice packets.

Our server's host name is sip02.unlimitel.ca and the IP address is 209.217.98.194.

For further information on adjusting your routing please contact your manufacturer.

Thank you,
[name]
Primus Business
HPBX and VOIP support
1-888-222-8577


I've tried forwarding the ports, as here:

http://shep.ca/temp/dlink-dir-825-portforwarding-primus-26042014.png

I can't find any way to add a SIP server to the firewall allowed/white list; here are the router options:

http://shep.ca/temp/dlink-dir-825-firewall-options-26042014.png

Here's what the PAP2T system looks like. I've blurred out my name and my phone number. When the phone is on-hook:

http://shep.ca/temp/PAP2T-systeminfo-phone-on-hook-26042014.png

While dialling (1-800-222-2222 is the number being dialled):

http://shep.ca/temp/PAP2T-systeminfo-phone-dialling-26042014.png

While getting that busy signal:

http://shep.ca/temp/PAP2T-systeminfo-phone-busysignal-26042014.png

I don't seem to have any specific information about connecting to the service in the current PAP2 configuration:

http://shep.ca/temp/PAP2T-systeminfo-phone-connections.png

...but I haven't changed anything with the PAP2T adapter, only changed the main router, so I'm not sure if I _should_ be touching any of the PAP2T settings.

I can also see that in my Line 1 settings on the PAP2T adapter, the URL and port match up with what the support ticket provided.

http://shep.ca/temp/PAP2T-systeminfo-phone-line1settings-26042014.png

As you can see, I'm at a bit of a loss as to what to do next.
posted by Shepherd to Computers & Internet (9 answers total)
 
...and searching around in the interim, it occurs to me that maybe I should just switch to voip.ms, which seems to offer lower prices and better support.
posted by Shepherd at 6:32 AM on April 26


Follow these directions.

That should work for any sip device.
posted by empath at 6:32 AM on April 26


I have a different VOIP system, but I encountered a similar problem a few years ago after I bought a new router (the old one had started to have problems with wireless connections). One surprising thing that might work for you is to take your old router, disable the wireless function on it, connect it to the new router, and then connect your VOIP adapter to the old router. I didn't think this arrangement would work, but it did. In my case, the old router functioned perfectly well with wired connections (even though wireless had become flaky), so I used the new configuration for a couple of years.
posted by akk2014 at 8:25 AM on April 26


Hi empath,

Unfortunately not -- I've already forwarded the ports.

I'm forwarding them to the IP address of the PAP2T phone adapter, as the DIR-825 won't allow me to open ports without a URL -- the screenshots you linked don't seem to work without a URL in the Computer area, despite there being no URL in those screenshots.


akk2014, the old router doesn't work at all -- powers down at random intervals -- so while that's a neat idea, I don't think it'll work out.
posted by Shepherd at 8:36 AM on April 26


Your port forwarding settings look fine, so the issue is most likely caused by a firewall that your new router has and your old router didn't.

Personally I detest in-router firewalls for home use and recommend finding those features and turning them off entirely. The only really useful firewall feature in a home router is blocking all connections from outside by default, and that's inherent in the fact that it's doing NAT anyway.
posted by flabdablet at 9:10 AM on April 26


Thanks, fladbablet. I've tried various flavours of options on the Firewall page, but there's no clear way to "deactivate" anything. I've turned SPI and anti-spoof checking off, set both TCP and UDP to "Endpoint Independent," which seems to be the least restrictive option.

The ALGs at the bottom seem to enable, not disable, stuff. I deactivated the SIP one just to see, and lost the line I had on the VoIP, so that's actually a step backwards.

I've updated my firewall screenshot to show the current state of it.

http://shep.ca/temp/dlink-dir-825-firewall-options-26042014.png

I've even tried putting the PAP2T in the DMZ, just to see if it would help. It didn't.

This is all very frustrating...
posted by Shepherd at 9:29 AM on April 26


Myself, I would probably go on eBay (or whatever) and buy the same model router as you used to own. It's not an elegant solution, and you won't really learn anything new, but you'll at least get your VOIP running again.
posted by alex1965 at 9:45 AM on April 26


I got a new wireless router (D-Link DIR-825), and have been trying to get our VoIP phone to run through it.

I gather you've replaced an old, broken wireless router. The PAP2T doesn't need wireless, so why exactly are you putting it downstream of the wireless router in the first place? Does your Internet modem not have its own router inbuilt?

I'm wondering whether you're now trying to run your PAP2T behind two layers of NAT. If so, that's doing things the hard way.
posted by flabdablet at 10:15 AM on April 26


(sigh)

Firmware update solved it. Should have been my first port of call, but I got stuck in problem-solving mode and didn't even think about the damned firmware. Thanks for all the help.
posted by Shepherd at 11:29 AM on April 26


« Older I am part of a large distribut...   |  I have lost ALOT of weight, an... Newer »

You are not logged in, either login or create an account to post comments