Join 3,552 readers in helping fund MetaFilter (Hide)


Having trouble setting up a client bridge with my routers
January 11, 2014 11:04 AM   Subscribe

I'm trying to set up a client bridge but cannot get seem to get internet access from the bridge. I assume it's a subnet problem but can't pin down what I'm doing wrong.

I"ll preface this by saying I'm a novice in all this and don't really understand subnets, etc. That said, I have a Belkin F7D8301 as my primary router and the default gateway is 192.168.2.1. I'm trying to use a Linksys e1000 with DD-WRT installed as a client bridge. The DD-WRT main log in is 192.168.1.1. The directions I'm working off are here:

http://dd-wrt.com/wiki/index.php/Client_Bridge

Could someone please tell me what I have to change in those directions considering my default gateway is 192.168.2.1 and not 1.1? Specifically,

- should the static IP I set up be 192.168.2.9 instead of 1.9?

- in the directions, where it says "go to setup, basic setup and enter a local IP address of 192.168.1.6, should that be changed to 192.168.2.6?

I'm assuming not as I've tried the above and not having luck. When I do that, I can access the DD-WRT GUI when the static IP is 192.168.2.9 but there is no internet connection. And when I set the computer back to auto IP, I can't even access 192.168.2.9 anymore.

I feel like I've tried all combinations of 1s and 2s here! Can someone offer some advice?

Thanks
posted by gfrobe to Computers & Internet (13 answers total) 2 users marked this as a favorite
 
Yes, you should change everything on the DD-WRT device to use a 192.168.2.xxx subnet. If things don't work after that, it's probably a problem with the wireless connection between the two devices.
posted by zsazsa at 11:21 AM on January 11


Thanks zsazsa. How about the static IP at the beginning? Should that also be a 2.xxx number?

As I've mentioned, I have tried all of this and not having much luck. Any idea how I can troubleshoot the connection problem between the two devices? SSIDs are the same, WPA2 security password is same, network (auto) and channel (auto) are also same.
posted by gfrobe at 11:30 AM on January 11


I also can't figure out why I'm able to not able to access the DD-WRT router at 192.168.2.9 unless I have a static IP in the 2.x range set up on the computer. When I set it back to auto IP as per the directions, I can't reach that IP address. Thanks!
posted by gfrobe at 11:38 AM on January 11


Well, to do the initial setup of the DD-WRT router, you'll have to set your computer to a static IP of 1.x. Once the setup is complete, it should changed to 2.x. As for why auto IP isn't working, it's because it's not getting an IP from your Belkin router because for some reason the connection is working. Another thing you need to do is disable the DHCP server on the DD-WRT router, because your Belkin provides that service.

I'm wondering if the problem is the channel. Instead of using auto, pick a channel and set it on both.
posted by zsazsa at 1:54 PM on January 11


I have a client bridge using DD-WRT running on my network right now.

The part that always took the most time for me was getting the client router to successfully connect to the main router. To do this, the connection settings in DD-WRT must be exactly the same as the main router (password, but also form of protocol and AES/TKIP). I found it easier to temporarily remove security from my main router, then once it was working add it back.

Can you see that the dd-wrt router is connected to the belkin from the belkin menu? Should list clients somewhere.

Also, the routers must be on the same subnet.
posted by zug at 3:49 PM on January 11


I also can't figure out why I'm able to not able to access the DD-WRT router at 192.168.2.9 unless I have a static IP in the 2.x range set up on the computer. When I set it back to auto IP as per the directions, I can't reach that IP address. Thanks!

They either aren't on the same subnet, or the routers aren't talking to each other. To check your auto IP address, open up a command prompt and type "ipconfig" when you're auto-connected. If you're wireless, check the wireless adapter IP, if you're wired check the ethernet adapter IP. It should be 192.168.2.x.

If not, it's a subnet issue. If it is, the client bridge router is not connecting to the main router.
posted by zug at 3:51 PM on January 11


Thanks for the replies. I removed the static IP and did the ipconfig thing this is what I get

Wireless Connection (to Belkin)
IPV4 192.168.2.5
Subnet Mask 255.255.255.0

The wired connection to the DD-WRT router says
IPV4 169.254.221.161
Subnet Mask 255.255.0.0

So it sounds like it's a subnet issue. Any idea how I would correct that?
posted by gfrobe at 5:21 PM on January 11


169.254 means the secondary router can't connect to anything. Remove all security from your main router and set it to connect to that. See if that fixes it.
posted by zug at 5:31 PM on January 11 [1 favorite]


If it means anything, when I have a static IP in the 2.x range, I can ping the DD-WRT router but not the Belkin. With auto IP, I cannot ping the DD-WRT router.
posted by gfrobe at 5:31 PM on January 11


169.254 means it can't connect to anything. Remove all security from your main router and set it to connect to that. See if that fixes it.

Will give that a shot. Thanks.
posted by gfrobe at 5:33 PM on January 11


Also make sure you're on the same channel.
posted by zsazsa at 5:34 PM on January 11


OK, I did a 30/30/30 reset and started everything over from scratch, turned off security and firewall on Belkin/computer and it's working. I guess I now just need to figure out how to get it to work with security on as I double checked that I had same passcode set on both.

Thanks go both of you. And if you have any suggestions on the security, please let me know. Thanks again.
posted by gfrobe at 6:23 PM on January 11


Congrats! Now that's it working you should be able to set up security again and it will keep working as long as the connection settings in dd-wrt are identical to whatever security you set up.

There are some caveats about which settings actually work, I am currently using WPA2 personal -AES and that works fine, but I have DD-WRT v24-sp2. So if WPA2 won't work, you can use WPA personal or WEP.
posted by zug at 7:36 PM on January 11


« Older I dearly loved my mustard-yell...   |  I have a mains-powered pump wh... Newer »

You are not logged in, either login or create an account to post comments