Skip

How to stop program from changing window state uncontrollably
January 15, 2013 9:49 AM   Subscribe

On a Windows 7 system open windows will sometimes rapidly cycle through windowed, maximized, and full screen states. I've run out of ideas and am looking for suggestions that might fix it.

This happens intermittently and happens with most programs that get used on that particular system--Firefox, Chrome, and VLC mainly. Regular explorer windows cycle slower. Utorrent is affected a different way, with the menu bar and left pane rapidly shifting back and forth.

Media Player Classic is unaffected.

So far I've tried:

--Windows Update
--full virus and malware scan
--unplugged the keyboard and mouse (thought it might be a stuck key or button)
--video driver update
--startup repair
--restarted with all background programs off
--restarted with both system services and background programs off

None of those worked. Sometimes this will happen four or five times in a day, sometimes not for a day or two. Usually I can close the program, or get Task Manager open and kill the problem program, sometimes I just restart. That fixes it but just for awhile.

I think something has gone wrong at the core of Windows and my next step is to reinstall, but does anyone have an idea before I do that?
posted by aerotive to Computers & Internet (11 answers total)
 
Does the cycling happen on its own or when you are using the keyboard/mouse? Check Control Panel -> Ease of Access Center to see if some weird gesture setting or something like that is causing this behavior. You might try disabling Aero shake as well.
posted by axiom at 11:10 AM on January 15, 2013


Happens more often when I use the mouse, have tried another one too but the same thing happens. Occasionally will happen on its own. This is a laptop with a touchpad so I suppose the built in kb or touchpad could be the problem.

I looked around Ease of Access and everything was turned off, and I went ahead and disabled aero shake.
posted by aerotive at 12:01 PM on January 15, 2013


It's possible that there could be a stuck key on the laptop itself. Does pressing the Windows key on the keyboard and the up arrow mimic the same behavior?
posted by samsara at 1:22 PM on January 15, 2013


(edit: or left or right arrow keys)
posted by samsara at 1:27 PM on January 15, 2013


samsara: "It's possible that there could be a stuck key on the laptop itself. Does pressing the Windows key on the keyboard and the up arrow mimic the same behavior?"

When then problem is happening pressing the Windows key momentarily stops it, but pressing the arrow keys does nothing. Then when the Win key is released the cycling starts again.

When the problem isn't happening, pressing the Windows key then an arrow key moves the foreground window to the left half of the screen, another press to the right half, and another press to the the whole screen (but not quite maximized or full).
posted by aerotive at 5:29 PM on January 15, 2013


I think it may be the left arrow key (and possibly one of the windows keys) in a stuck state on the laptop. You may want to try mashing all the keys several times while the laptop is off to see if that helps with loosening them up, otherwise it could be a short, or piece of debris that is causing keys in that area to register as being pressed.

It's a start! (no pun intended)

You may have luck finding a cheap keyboard replacement online for your particular laptop. Most are not too terribly difficult to replace. I would research the process beforehand to gauge whether you're up tot he task however. I think the touch-pad portion is "mostly" safe to rule out.

An inexpensive workaround would be detaching the on-board keyboard to primarily use the spare.
posted by samsara at 9:53 AM on January 16, 2013


Yes I've tried pressing down and shifting the keys around, with no success. Gonna try some compressed air next.

Replacing a laptop kb is beyond me.

BTW do you know what kb combo would cause the maximized-full screen-windowed progression? F11 just does back and forth between full screen and the previous state.

Thanks much for all the suggestions.
posted by aerotive at 5:55 PM on January 16, 2013


What is your make/model for the laptop? I could help dig up the maintenance handbook online for it (instructions on KB assembly).

The only other keyboard combination I know of off hand or full screen switching is ALT+Enter. It's possible you're witnessing conflicting combinations too however. (more than one combination fighting for dominance)

Maybe try a keyboard test program too to see if it shows up.
posted by samsara at 7:34 AM on January 17, 2013


Test program suggestion is excellent, had forgotten such things existed. I have it downloaded and installed, will see if it indicates anything when the issue happens again.
posted by aerotive at 3:02 PM on January 17, 2013


It's the built in kb, when the problem is happening that program registers the F11 key as being pressed a bit more than 30 times a second. Will try and work the button around a bit, still need to use compressed air. Failing that I will pop the key off and see if that helps. And if that fails, maybe there are utilities that can disable certain keys...

Thanks again.
posted by aerotive at 6:16 AM on January 18, 2013


Decided not to remove the key, instead downloaded a utitlity called KeyTweak, configured that to disable the F11 key in Windows. Problem hasn't happened in several days so I consider this resolved.
posted by aerotive at 7:47 AM on January 23, 2013


« Older After a torturously long stint...   |  I am seeking professional advi... Newer »
This thread is closed to new comments.


Post