Skip

Why does fullscreen make old programs look funny on my Windows 7 computer?
December 4, 2009 10:37 PM   Subscribe

When I run some programs in full screen under Windows 7, they either crash or have odd colour effects.

When I run Diablo 1 on Windows 7, some of the colours in the game are replaced by bright, flourescent oranges and greens and cyans and the like- and not in any apparent order, just big jumbles of them. The same thing happens when I play Alone in the Dark under DOSBox, though only at full screen- when I play at the default window size, the colors look fine. FCE Ultra, the NES emulator, simply crashes, which it didn't in XP. Messing about with compatibility settings doesn't seem to fix it. The really fucked thing is that when I take screen shots, everything looks proper and normal.

I'm on a Dell Inspiron 1545- 1366x768 screen, dual-core 2.0GHz processor, 3GB RAM.
posted by Pope Guilty to Computers & Internet (5 answers total)
 
Problems only in fullscreen and screenshots not being messed up sounds like an issue with your video card driver or the graphic acceleration on the video card. Is an alternate driver available for that card, maybe?

One way to test if it is a driver issue would be to boot a Linux LiveCD and see if the Linux games / graphics apps have any color distortion (a LiveCD does not install or alter your PC at all).
posted by idiopath at 11:04 PM on December 4, 2009


I think this is a problem which has shown up for me several times. If you search for "starcraft colors windows 7" you should get a few threads about various solutions. The only one that's worked for me is to go to Task Manager, kill all explorer.exe instances, then launch the game.
posted by Jacen Solo at 3:08 AM on December 5, 2009


This may or may not apply, but I had somewhat similar issues with both of my monitors enabled in win7.. I had to disable one to get certain fullscreen games to run without crashing.
posted by zennoshinjou at 3:55 AM on December 5, 2009


Have you tried disabling the Aero visual effects? The fastest way is to go into "Personalization" in the control panel and choose Windows 7 Basic (or something like that, there's a theme at the bottom of the window that doesn't have transparent effects). This usually works. You might also need to lower the amount of colors from your video card for some games.

This is meant for laptops, but it lets you turn the Glass effect on and off from the taskbar.
posted by mccarty.tim at 7:59 AM on December 5, 2009


I had a similar problem with Media Center when it was full screen. I downloaded and re-installed the latest drivers for my video card from NVidia and it went away. I would try re-installing your video drivers first.

And you don't have to kill explorer via TaskManager. You can shut it down cleanly by opening the Start menu then CTRL+SHIFT+RIGHTCLICK on the background of the start menu (off to the right by the Shutdown icon is the easiest place) and select Exit Explorer.
posted by jeffamaphone at 9:39 AM on December 5, 2009


« Older That guitar bend technique whe...   |  Can anyone recommend a DURABLE... Newer »
This thread is closed to new comments.


Post