Join 3,520 readers in helping fund MetaFilter (Hide)


1 SSD & 2 HDD (One of the HDD isnt showing any more). Need help!
November 17, 2012 7:39 AM   Subscribe

I've just upgraded my rig with a 256gb SSD card for the main C:. This is primary used for the OS, apps and my work files. I previously had 2 HDD's one for OS and the other for backups.

However I've got the SSD working with a new copy of Windows 8 Pro. Only one of my HDD drives is showing. I've copied over the work files but cannot access my other drive. I swapped the sata cable to the other drive and violla, it shows. But the other drive doesnt show.

I've checked the leads and swapped them around, so no fault with the lead itself. Even swapping the DVD writer Sata lead works.

I remember in the good ole' days you had to put a bracket to show if its a master or slave. Is this the case? or could it be a bios setting?

So just to clarify:

· Both HDD's do work
· All the Sata leads work
· Checked Admin tools (drives only showing is the DVD, SSD and one of the HDD)

Its baffled me so far why it isnt showing both HDD's.
posted by spinko to Computers & Internet (10 answers total)
 
Do they all show up in the BIOS settings? (I'm not sure if that's what you mean by admin tools.) I don't believe you need to set any jumper pins on the drives since SATA drives don't share a cable. That being said, I think SATA was designed to be roughly equivalent to IDE and so there may be some master/slave issues depending on how your BIOS sees the drives. I think the order of the drives may be set by where the cables plug in to your motherboard: primary master and slave, then secondary master and slave, though I think with SATA you can change the designations or even disable drives in the BIOS.

Do the drives even have jumpers on them? If so, there should be a little diagram next to the jumper pins that shows how they work. Maybe put all of the jumpers on "cable select" mode instead of master or slave?
posted by stopgap at 8:41 AM on November 17, 2012


You mentioned using 'Admin Tools' above; this sounds suspiciously like WIndows 8's version of control panel. What you need to check requires rebooting into your BIOS and checking both of the below:

1) If your onboard Sata controller is set in compatibility mode, (which would, most likely, cause the system to use the old Master/Slave mode to access the drives)

and 2) If any of the Sata channels themself are 'disabled'. (this would be my guess for causing drives not to even show up)

changing either of those should fix your problem; the former may require a reinstall of Windows 8 due to driver mismatch.
posted by schade at 11:52 AM on November 17, 2012


I've shared my bios settings. I can see the 3 hard drives on Raid settings but obviously I dont wanna do raid.

https://www.dropbox.com/s/irgwsvzruooghc2/2012-11-17%2021.33.00.jpg
https://www.dropbox.com/s/mh0ujo6yk29ge83/2012-11-17%2021.33.20.jpg
https://www.dropbox.com/s/a4u0klf68o7779d/2012-11-17%2021.33.33.jpg
https://www.dropbox.com/s/0jkecdzvakmmg2t/2012-11-17%2021.33.42.jpg
https://www.dropbox.com/s/ic8gf0emv1hmr4g/2012-11-17%2021.34.19.jpg
https://www.dropbox.com/s/q0bkmouxp5rt3ac/2012-11-17%2021.34.23.jpg
https://www.dropbox.com/s/vwphttj1suxlma3/2012-11-17%2021.34.28.jpg
https://www.dropbox.com/s/o850x6db0cor1w2/2012-11-17%2021.34.37.jpg
https://www.dropbox.com/s/hmbs2crei8imm9e/2012-11-17%2021.34.40.jpg
https://www.dropbox.com/s/k2p4lbi07xyrl8q/2012-11-17%2021.34.44.jpg
https://www.dropbox.com/s/x6wj3z9osz25dk0/2012-11-17%2021.35.05.jpg

This last screen you can see the 3rd HDD (Samsung)
posted by spinko at 12:55 PM on November 17, 2012


Hmm. Are all three drives showing up in the Windows Device Manager? Maybe there is a conflict that will show up there.
posted by stopgap at 2:20 PM on November 17, 2012


I believe "Admin Tools" and "Windows Device Manager" are the same thing, so the disk isn't showing up there.
posted by alexei at 4:19 PM on November 17, 2012


Do you have a free SATA port on your motherboard? Try moving SATA cables around to any free slots--it looks like the SSD is replacing one of the HDDs in BIOS.
Note: this is a pure guess; I have never seen this happen.
posted by hexatron at 7:19 PM on November 17, 2012 [1 favorite]


3 are not showing on the device manager, only 2.
posted by spinko at 12:38 PM on November 18, 2012


Yup, I tried all 4 sata ports, no luck.
posted by spinko at 12:39 PM on November 18, 2012


Sorry, I should have been more specific. Is anything showing up as an "Unknown Device" in the Device Manager (under "Other Devices" I think)? Obviously they are not all being recognized properly as drives.
posted by stopgap at 12:51 PM on November 18, 2012


I don't know that this will work, given that the drive is not showing up in Device Manager, but sometimes you can find drives using the Disk Manager. Right click on My Computer and select "Manage..." or search on the Start Menu for "Computer Management." Choose "Storage" in the left pane, then "Disk Management." The lower center pane should have a list of all the drives and their partitions where you can assign drive letters.

Finally, searching for some of the text from your BIOS screenshots led me to this:
I have installed four SATA HDDs on GSATA ports, but only two of them are detected under OS. How do I operate these HDDs seprately?
GSATA ports provides Smart Backup feature, HDDs can work separately or work in RAID modes. Please refer to below information of setup process.
  • If you need to operate HDDs separately, please refer to user's manual, to enter "BIOS\ Integrated Peripherals", to make sure [Smart Backup Config] stay at default value [Normal (Port Multiplier)], and then to install GIGABYTE SATA2 RAID Driver under OS.
  • So my best suggestion would be to go to the Gigabyte download page for your motherboard and try installing their RAID driver (even though you're not setting up the drives as a RAID array).
    posted by stopgap at 1:21 PM on November 18, 2012


    « Older What are my options for doing ...   |  Can you identify the signature... Newer »
    This thread is closed to new comments.