Skip

Too much white noise from speakers!
October 10, 2012 9:50 AM   Subscribe

How can I reduce the noise my speakers are spewing out from the various electronic things on my desk? Even with nothing playing, there's so much noise.

I have a set of logitech desktop speakers, connected to my laptop.

Even when nothing is playing, there is so much noise spewing out of them. Heck, if I move a browser window around on my monitor, I can HEAR the window being moved!! There's a plethora of electronic devices going on on my desk.

Complication 1: The noise disappears if I unplug the speakers from the laptop.

Complication 2: The noise is NOT there if I plug earphones directly into my laptop.

From pop culture, I feel like saying "more shielding would help" - but I have no idea what to do other than to say that.

Any ideas on what's going on, and how I can mitigate this noise?
posted by StrictlyVague to Technology (11 answers total) 1 user marked this as a favorite
 
Note: This is not gsm/cell phone interference.
posted by StrictlyVague at 9:51 AM on October 10, 2012


Questions: Do the speakers connect via USB or headphone jack? What kind of laptop is it?
posted by tinamonster at 10:02 AM on October 10, 2012


You have shitty speakers, and nothing's gonna change that.

Get new speakers.
posted by DemographicLanguage at 10:03 AM on October 10, 2012


And: Did you just get the speakers and/or they have always done this or is it a problem that recently developed?
posted by tinamonster at 10:04 AM on October 10, 2012


Make sure that the cable connecting the speakers to the computer isn't crossing any power cables. If that doesn't help, indeed, you want better speakers.
posted by dbiedny at 10:23 AM on October 10, 2012


Does your laptop have a Wifi adapter? That's what you're hearing.

My laptop spits and pops at my speakers all day, I have to hard-wire it to the network and turn off the adapter. Even then, wifi signals from the other devices in the house (there are many) tend to send a lot of hissing and popping my direction.

DIY Shielding is the answer: Wrap anything you think might be vulnerable (the wires, the speakers themselves) in aluminum foil.
posted by thanotopsis at 10:23 AM on October 10, 2012


Sometimes ferrite chokes can help.
posted by empath at 10:33 AM on October 10, 2012


Also, make sure that no cables that run power or audio are running in physical parallel to one another.
posted by digitalprimate at 10:53 AM on October 10, 2012


Seconding ferrite chokes.
posted by Sunburnt at 10:58 AM on October 10, 2012


I use a USB audio device. Originally I was using the USB ports in the back of my monitor, but the monitor itself seemed to be the noisy culprit for me.

I fixed this by using a USB cable with ferrite chokes, plugged into the tower. Now it's dead-silent.

So:
  1. Ferrite chokes.
  2. External USB audio device.
Silence.
posted by sportbucket at 11:13 AM on October 10, 2012


I don't think your problem is your speakers. Plug them into your phone or iPod or something (in the exact same location) to check. Your problem is probably a crappy on-board sound card. Almost all built-in sound cards are terrible. The earphones just work differently; I'd be willing to bet that the sound is still there, but it's quiet. The speakers amplify it.

Do you know anyone with a USB headphone amp or audio interface? I'd almost to be willing to bet that something like this would take care of your problem.

Unless it's something simple: how high is your volume turned up on your OS? You want it as high as possible without distortion. My USB headphone amp tells me to turn it up all the way.
posted by supercres at 1:22 PM on October 10, 2012


« Older Two days in San Diego ... how ...   |  Can you help me figure out wha... Newer »
This thread is closed to new comments.


Post