Skip

Why is my computer refusing to connect to the internet?
March 23, 2012 1:40 PM   Subscribe

AskMefi, my computer is suddenly refusing to connect to the internet. I'm starting to go a little bit nuts.

So my new-as-of-last-year computer can't connect to the internet. I'm running Windows 7 64 bit with a Linksys Wireless-G PCI Adapter (all drivers up to date), connecting to a wireless Linksys WAG160N router. I share the network my 4 housemates, who aren't (as far as I know) reporting any problems.

Over the last few weeks my connection has been dropping randomly every couple of days for a few minutes at a time - completely losing contact with the wireless network. Turning the router off and on usually solved this problem. Lately it has started to drop just the internet connection. I can find and connect to the router, but it either says it has no internet access or refuses to load any browser pages/chat clients. If I run a troubleshooter, it tells me: "Your computer appears to be correctly configured, but the device or resource (DNS server) is not responding."

I have tried:

- flushing the DNS server
- releasing/renewing the IP address
- resetting the router
- disabling/enabling the wireless adapter

I can connect to the internet just fine with my PS3 and if I use my iPhone as a hotspot connected to the wireless network, so I think the problem is (unfortunately) with my machine.

Here is my ipconfig when I'm trying to connect to the wireless network:

Windows IP Configuration

Host Name . . . . . . . . . . . . : MOYA
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Linksys Wireless-G PCI Adapter
Physical Address. . . . . . . . . : 00-1E-E5-A5-A2-6B
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::d41e:47a2:46e2:e029%18(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.7(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 23 March 2012 19:58:35
Lease Expires . . . . . . . . . . : 23 March 2012 20:58:35
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 469769957
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-60-8C-4D-BC-AE-C5-DE-7E-EC
DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : BC-AE-C5-DE-7E-EC
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Hamachi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Hamachi Network Interface
Physical Address. . . . . . . . . : 7A-79-05-F7-49-FB
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2620:9b::5f7:49fb(Preferred)
Link-local IPv6 Address . . . . . : fe80::298c:4dba:2554:1bec%12(Preferred)
IPv4 Address. . . . . . . . . . . : 5.247.73.251(Preferred)
Subnet Mask . . . . . . . . . . . : 255.0.0.0
Lease Obtained. . . . . . . . . . : 23 March 2012 19:30:35
Lease Expires . . . . . . . . . . : 23 March 2012 20:02:42
Default Gateway . . . . . . . . . : 5.0.0.1
DHCP Server . . . . . . . . . . . : 5.0.0.1
DHCPv6 IAID . . . . . . . . . . . : 427456862
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-60-8C-4D-BC-AE-C5-DE-7E-EC
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{5967EEC2-571F-451D-822B-1E8B83CCE26C}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{20B7AC2E-17E2-4177-9842-9C6F0567C5AD}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:1cda:2ab2:a9e1:cada(Preferred)
Link-local IPv6 Address . . . . . : fe80::1cda:2ab2:a9e1:cada%11(Preferred)
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

This is really, really frustrating. Is this a hardware issue? Some weird bug in the gears? Please, AskMe, you're my only hope!
posted by fight or flight to Computers & Internet (13 answers total) 1 user marked this as a favorite
 
Try disabling the Hamachi Network Interface VPN and if that doesn't work disable wireless and try connecting directly to the router via an ethernet cable. My guess is your traffic is being routed through the non-functioning VPN.
posted by ChrisHartley at 1:45 PM on March 23, 2012


Your DNS server is set to 192.168.1.1, while your computer is on a network that has 192.168.0.1 as the gateway. Perhaps Windows is manually set to the wrong DNS server (it generally should be getting that setting via DHCP). Make sure it's set to Obtain DNS server address automatically.
posted by zsazsa at 1:50 PM on March 23, 2012 [1 favorite]


ChrisHartley -- I've uninstalled Hamachi (should have done that a while ago) and rebooted the machine - no change; it still says it's connected to the internet, but won't load anything/disconnects every couple of seconds.

zsazsa -- I just checked the DNS server address and everything is set to obtain automatically. Is there a way I can force it to use the correct one?
posted by fight or flight at 1:57 PM on March 23, 2012


try going to http://173.194.73.147 (what google.com resolves to for me) that should bypass DNS. Does that connect. If so, there is a problem with DNS.
As zsazsa stated, your DNS server doesn't match your gateway. This is a something goofy. If windows is configured correctly, log in to your router, and make sure the DHCP isn't serving an incorrect DNS - which it looks like it may be doing
posted by defcom1 at 2:04 PM on March 23, 2012 [1 favorite]


you can memail you your router brand / model (if you don't want to post it), we can check the manual online and see where the DHCP DNS configuration is.
posted by defcom1 at 2:06 PM on March 23, 2012


defcom1 -- I can connect to google.com. I can also load it (briefly) without bypassing DNS. When it's working, it seems like it's loading things "halfway". If I try to access Facebook, for instance, it only loads the top bar of the webpage and none of the content. If I try to go to the Guardian homepage, it loads some of the pictures and the hyperlinks and text, but very little of the page structure. It's like I'm trying to run it on a modem from 1991.

My hosuemate down the hall is also now reporting problems -- he says the internet is disconnecting every two or three minutes.

The router is a Linksys WAG160n. My housemate just told me that our landlord has actually connected our router to another router in the next door flat (which they also own), I suppose in order to save money having to connect up two separate systems. Which might explain a few things.
posted by fight or flight at 2:17 PM on March 23, 2012


Which is to say (sorry to threadsit) our router is literally wired up to the router next door, which I believe is a Virgin Media Hub of some kind (. This explains why I haven't been able to log in to "our" router.
posted by fight or flight at 2:19 PM on March 23, 2012


hmmm...is your router connected via the "wan" port? if so, then you're double NATing. Which breaks things.
To test, grab the wire from next door, disconnect from your router and plug it in to your computer. Do you now get an ip address in the 192.168.1.x range? If yes, what you need to do is disable DHCP on your router, and plug the wire from next door into your LAN port on the router. It will then act as a wifi bridge, but will not act as a router, the duties will fall onto the real internet gateway, next door. The drawback is now you're on the same LAN as your neighbors, and shared drives will be accessible etc.
posted by defcom1 at 2:29 PM on March 23, 2012


Not positive but I think it should be possible to "double-NAT" without breaking things. Have you tried setting your own PC's DNS manually, either to your own gateway address or to a known external DNS server such as google (8.8.8.8) or openDNS (208.67.222.222)?
posted by jacobsee at 3:14 PM on March 23, 2012


Ok, I spoke to defcom1 a bit over Mefimail to avoid this becoming a chat thread. He suggested I change my DNS server address to 8.8.8.8 and 8.8.4.4, which I have now done.

I also managed to log in to next door's router and fiddle with the settings a bit. I changed the wireless channel from "auto" to "1", which seems to have fixed things (for now)! I'll wait and see if it keeps working. I guess it was a problem with the router after all.
posted by fight or flight at 3:19 PM on March 23, 2012


This is a bit late but the problem is 100% with your DNS. How it is being served up (via DHCP or manual) is of no consequence. You are on the 192.168.0.0 net and your DNS in on the 192.168.1.0 net. This will never work! 8.8.8.8 and 8.8.4.4 are Google DNS servers which are fine, but another DNS which I always use is OpenDNS (208.67.222.222 and 208.67.220.220). DNS is the *reason* these guys are in business so these servers never go down and are always up to date. There is nothing stopping you from using these servers at all, you don't have to pay for the service.

I have a little private saying, whenever I try and troubleshoot a networking problem. It's "How is DNS configuration causing this problem?"!! DNS misconfiguration is a major cause of problems, especially in the Windows "Active Directory" world.
posted by humpy at 8:33 PM on March 23, 2012


Be aware that if you do use the OpenDNS servers, then attempts to resolve non-existent domain names will not result in the expected "no such name" errors, but in your computer being handed the address of some other host (possibly with advertising content).

If you get sick of this and switch back to a clean public DNS server like Google's, you will want to clear your own computer's DNS cache (use net stop dnscache then net start dnscache from a cmd window) as well as your browser's web cache.

Incidentally, if that's not what you already did when you mentioned "flushing the DNS server" I strongly recommend you give it a go. Windows 7 doesn't react well to connectivity issues affecting DNS, and sometimes its DNS cache will seize on the idea of certain names being unresolvable well after DNS service has been restored. Windows XP used to have a "repair this connection" option available in the GUI that would actually clear its DNS cache along the way; for reasons I don't understand, the only way to make this actually happen with Windows 7 is to do it via cmd.

As for which DNS server you should be using: the usual way of these things is for your local wireless router's DHCP server to hand out its own IP address to be used as a DNS server, then act as a caching DNS forwarder for whatever DNS server it has been told to use by whatever set up its WAN-side connection. Some of them, though, simply pass through the address of the DNS server they were handed themselves, and rely on your computers connecting directly to that. So the fact that your local gateway is handing you 192.168.1.1 as a DNS server address even though your local gateway address is 192.168.0.1 doesn't necessarily mean that anything is squirrely, just that your DNS is set to come from the next router upstream from yours (i.e. the Virgin thing next door).

If the router next door has upstream connectivity issues, then I would expect you to see exactly what you are currently seeing - reliable connection to your own LAN, and spotty connection to the outside world.

If it's also a wireless-capable router, and its wireless was turned on just a few weeks ago, and both it and your own wireless router are set to assign channels automatically, then they could well be stomping on each other's wireless signal and causing local connectivity issues. Since you've found your way into its control panel, try setting it to channel 1 and your own to channel 11.

Double-NAT usually works all right provided you're not trying to run Internet-facing servers behind it; doing that requires setting up fixed inbound NAT rules in both the NAT routers between you and your public IP address. Having one layer of NAT between your computer and its DNS server should certainly cause no issues: if DNS didn't work via NAT, you wouldn't be able to use 8.8.8.8 either. So if you'd rather not give your neighbors unfettered access to your LAN, connecting to their router via the WAN port on yours should still work OK.

One final thought: I have seen a Windows 7 laptop that absolutely refused to detect any wireless network, even though other devices around it had no problem doing so, come good after uninstalling the wireless LAN interface driver, power-cycling, and letting Windows re-detect the interface and auto-reinstall the driver. That's a pretty easy thing to try if you have wireless network problems affecting only your own PC.
posted by flabdablet at 10:39 PM on March 23, 2012 [1 favorite]


Also, find out where the router next door is getting its power supply from. You'll get no Internet service from a router that's accidentally been switched off.
posted by flabdablet at 10:43 PM on March 23, 2012


« Older Does synthetic polyisoprene (i...   |  What are the books and films t... Newer »
This thread is closed to new comments.


Post