How to get my iBook to see the internet?
August 30, 2006 9:31 AM   Subscribe

My wireless router and my iBook G4 aren't playing nice. Our iBook G3 connects wirelessly without fail.

This started not very long after we moved to the new apartment: my airport icon shows a full signal connection, or sometimes minus one bar, but when I try to load a page the result is a page that says I am not connected to the internet. When I turn off the airport and then turn it back on, sometimes it will be able to load the page. Lately that doesn't work, so I move onto the step of restarting the router and the modem. This isn't working lately either. So, sometimes it lets me on and bumps me off randomly whlie other times it won't let me online at all.

The router is a NetGear MR814v2, which the Apple store Genius Bar people say isn't the best model. They suggest I turn to a Linksys.

We have an iBook G3 that never has any problem getting online or staying online wirelessly. The fun part is that we have an ancient (five years old) Gateway that we plug into the router for downloading. At first, it seemed that the iBook G4 would get bumped when the Gateway went online, pointing maybe to an IP conflict. All three machines have their own IPs assigned, however. Now the Gateway is not necessarily downloading, or even on/connected to the router when we have this difficulty getting or staying online with the G4.

Do I really need to trash this router, or is there something else that can be done so I can go back to reclining on the sofa with my computer? (I'm tethered to a table that is just the wrong height for computer work and a new table is out of the question for quite some time.)
posted by bilabial to Computers & Internet (6 answers total)
 
Did the Geniuses check the antenna on your iBook G4 or try swapping out the AirPort card for another one?

Does the G4 stay online consistently if you use it with someone else's base station?

If swapping the card/reseating the antenna results in improved performance, then it's not your router. If you can stay online consistently at a coffee shop/place-o-business/friend's house, then it's your router.

I guess basically the idea is just to methodically check each piece of the puzzle before buying new hardware. (And BTW, there's nothing inherently wrong with a NetGear router; I have one and it functions flawlessly with our iBook, PowerBook, TiVo, Dell & various visitors.)
posted by bcwinters at 9:37 AM on August 30, 2006


I recall reading something awhile back about AirPort cards becoming slightly unseated during shipment. I used to have a G4 tower that was having the same problems as you, and re-seating the AirPort card and reconnecting the antenna seemed to help. YMMV, of course.
posted by Shecky at 10:36 AM on August 30, 2006


Hmm. I had similar problems connecting to my wireless router (also a Netgear) via the Airport card in my desktop G4. The problems cleared up when I set the router to broadcast in both b and g modes, rather than just in the faster g mode. I'm guessing a certain generation of Airport cards (read: those that originally shipped with G4s) don't support the g mode very well, if at all.

So perhaps go into your router settings and change it to broadcast in both b and g—that may be the solution.

(And in my experience, the "minus one bar" status usually means Airport isn't even getting a real connection—I only get that status when I'm connecting oh-so-slowly to a very, very distant router, or when Airport wants me to think I have a connection, but I actually don't.)
posted by limeonaire at 12:19 PM on August 30, 2006


How do we set if for both b and g? My boyfriend checked the settings and didn't see an obvious way to do that.

The geniuses just logged on with my computer to their wireless at the store and said "looks good, it's not the wireless card because it works here." Which I thought sucked because, sometimes I can get that same reaction at home - yay, it logs me on, maybe I'll never have a problem again. But, right now I'm plugged into the ethernet cord. I guess I'll try it at the internet cafe around the corner and see how it does there.
posted by bilabial at 2:44 PM on August 30, 2006


Okay. In my Netgear router setup, you go to Wireless Settings under Setup in the left sidebar. Then in the Wireless Network part of the settings panel in the middle, and there should be a setting called "Mode:" followed by a drop-down menu. The options on that menu are "b only," "g only," and "g and b."

The options in your router's setup menu may not be in the same order, but they should still be under general headings similar to those.
posted by limeonaire at 7:38 PM on August 31, 2006


What version of OS X are you running on your G4?

IIRC when tiger came out, it was breaking a lot of wireless connections because the computer name was too long.

If you go to prefpane->sharing. You will see that the name listed is

"Your name's iBook G5." (or something like that)

Change it to something shorter. I used to have the same issue every time i reinstalled OS X 10.4. I believe they fixed it in an update, but my MacbookPro seems to be exhibiting the same problem in 10.4.7 with my Linksys wrt54g
posted by mphuie at 1:57 PM on September 1, 2006


« Older What level of involvement is a...   |  Has there been a 'director's c... Newer »
This thread is closed to new comments.