Join 3,512 readers in helping fund MetaFilter (Hide)


Make Excel stop babysitting me.
December 5, 2011 9:11 PM   Subscribe

Excel is treating me like a child because it thinks I can't tell the difference between .csv and .xlsx. It's wasting my time. Help?

Whenever I save an Excel (2011 for Mac, Leopard) spreadsheet in a format other than .xlsx, such as .csv or .txt, it gives me the following warning:

"This workbook contains features that will not work or may be removed if you save it in the selected file format. Do you want to continue?... plus more fine print"

This happens every time I reflexively hit command-s as I work, and it happens when I close the file even if I've *just* saved it. Worse, the response button that's highlighted is "Cancel" so I can't just hit return to get through the warning -- I have to pick my mouse up to deal with it.

This has been irritating me for a while, but I don't use Excel that often so I was never driven to try to fix it. Right now I'm using it a lot more and I'm up against a big deadline, and this is getting in the way of being able to work efficiently. How do I convince Excel that I'm already very well aware of the nature of .csv and .txt files (that's why I'm saving files in those formats!), I'm keeping track of which files are in which format, and I do not need or want to be warned every single time? Please help me!
posted by ootandaboot to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
I don't think that there is a preference option to turn this off, but you could probably script the export (OK, the save) and thus avoid the dialog.

Something simple like:

Sub SaveWithoutGrief()
Application.DisplayAlerts = False
ActiveWorkbook.Save
Application.DisplayAlerts = True
End Sub


Seems to work (testing on Office 2010/Win7) - though you'd have to use something a bit trickier for a 'Save As'.
posted by pompomtom at 9:24 PM on December 5, 2011 [1 favorite]


Turn on Full Keyboard Access. That way you can press Tab to activate the Ok button and then press return, keeping your hand off the mouse.
posted by zsazsa at 11:19 PM on December 5, 2011 [1 favorite]


Just installed the Office trial on the Mac. Looks like you have to press Tab twice, then the space bar to press OK.
posted by zsazsa at 11:46 PM on December 5, 2011


Another workaround is to save it as the native format as you are working, and then just save it as the csv when you are done.
posted by gjc at 7:09 AM on December 6, 2011


Annoying, isn't it? I don't think it's so much Excel treating you as a child as it's the not-so-invisible hand of marketing whispering "don't save your information in that boring as stale bread open format of CSV where you'll lose all your nifty formulas, formatting and OLE objects! Instead save it in the nice, shiny, proprietary .xls format, where it's then guaranteed that anyone who wants to look at it will need a copy of Excel (available from your local authorized Microsoft products retailer)."
posted by de void at 7:54 AM on December 6, 2011 [1 favorite]


Arrrghhhh I hate this "feature" -- gjc has it right but I'll try that script also.
posted by omnidrew at 8:00 AM on December 6, 2011


If it makes you feel any better, the phrase Excel is treating me like a child will help me through all of my issues today. (Why am I fooling around online? Excel is "not responding" so I have to please wait.)

You've managed to anthropomorophasize Excel. I now hate it a teeny bit less so thanks!
posted by Lesser Shrew at 8:39 AM on December 6, 2011 [1 favorite]


Record a macro that saves the current file as a .csv. Add a shortcut key to the macro. Get used to using the shortcut combo instead of command-s.

Let me know if you need more details on macros.
posted by SuperSquirrel at 9:59 AM on December 6, 2011


There's a good range of workaround options here. Thanks guys :)
posted by ootandaboot at 5:10 PM on December 7, 2011


« Older Help me gamble and eat during ...   |  Is this cat puke reason for co... Newer »
This thread is closed to new comments.