Skip

Improving Pages '09 PDF Export Quality
January 25, 2011 12:34 PM   Subscribe

iWork question: When exporting my document to PDF in Pages '09, the resulting text quality is really poor for the regions that are set in 8pt Helvetica Neue. If I do a Print->Save as Postscript, then open that in Finder and save as PDF, the quality is fine. Is there any way to get Pages to just do this properly?

It seems to be a font size issue. The regions that are set in a larger size look fine. It isn't a system font smoothing issue since using Postscript fixes the problem.
posted by krunk to Computers & Internet (11 answers total) 1 user marked this as a favorite
 
It it changing the font to something else? Is the default zoom level different or something?
posted by The Lamplighter at 1:10 PM on January 25, 2011


I tested this on my end with the defaults and everything looks fine. Though, I'm not quite sure what the problems is. Does zooming in when Preview opens help?
posted by jmd82 at 1:45 PM on January 25, 2011


Are you setting Image Quality to Best in the PDF export window?
posted by odinsdream at 2:02 PM on January 25, 2011


It would help if you could upload a test document somewhere, so we could look at it. "The text quality is really poor" could mean a lot of different things.

There might be several reasons why the text might have to get converted to an image.
- Is there a shadow on the text?
- Is the text set to be an odd color (like a CYMK fill or a pattern or something)?
- How about any background behind the text?
- Is the text in the body of the document, or inside of another textbox or shape?

Try turning off shadows, setting the text color to plain black, etc. and see if that helps at all.
posted by xil at 2:09 PM on January 25, 2011


It does seem to render 8pt like a shitting Windows 3.1 screen font. I noticed the minimum font size on the drop down is 9pt. And if I change a paragraph to be in 9pt is it what you'd expect in terms of resolution (no jaggies).

Does zooming in when Preview opens help?
In my test, zooming only makes the 8pt type look shittier.

I'm not an expert at any means in this. But it looks like the PDF export is using a bitmap for 8pt and the 9pt+ is done correctly.

I don't know if this is a fault in the font, in Pages, or Mac OS X's PDF engine. When I replicate the same text from Pages 09 in Word 11 and save the Word file as a PDF, it gives me the desired fidelity.

I tried again in TextEdit and saving that blurb of text as a PDF comes out as desired. I presume iWork and TextEdit use the same PDF engine in Mac OS (who knows what MS does). So I'm lead to believe it might be a problem in Pages09. If bumping the 8pt to 9pt isn't possible, perhaps you'd need to look at other typefaces. Or if you're stuck with Helveltica Neue 8pt you'll have to do that clunky Save as Postscript and then save the postscript into a PDF. If there's a silver lining I'd think it would be easy to set up an Automator Action to do that for you.
posted by birdherder at 2:16 PM on January 25, 2011


Aha, never mind my earlier questions -- this is indeed quite easy to reproduce.

As birdherder said, this looks like a Pages bug. Other apps work fine. I can't think of any workarounds you haven't already found.

The problem is that a poorer style of antialiasing is used -- if you zoom in on the PDF, you'll see that the text never gets really blocky, it just has sharp edges (pixels are all black) rather than your typical grayed-out antialiased edges.
posted by xil at 2:26 PM on January 25, 2011


On OS-X, there should be a Print>PDF>Save as PDF option in every single print dialog that will convert to PDF through the printer software rather than using Pages' Export option. This should save you the step of having to go through postscript while still giving you the better PDF encoding. The (PDF) button is in the lower left corner of the print dialog.
posted by yeolcoatl at 5:21 PM on January 25, 2011


On OS-X, there should be a Print>PDF>Save as PDF option

Yeah, this results in the same problem.

But, bizarrely, this problem has suddenly stopped occurring! I will investigate and report my findings shortly.
posted by krunk at 5:40 PM on January 25, 2011


I've uploaded the old (crappy) version here and the good one here. It's my CV, so just ignore all my personal details :^)

Strangely, they both render the same in Safari, but in Preview they look very different. Perhaps this is just a bug with Preview? They both look decent in Adobe Reader 10, but not perfect. Pages no longer creates the bad files for some reason.
posted by krunk at 5:51 PM on January 25, 2011


I found a workaround: In System Preferences, Appearance, change "Turn off text smoothing for font sizes" from 8 to something smaller (like 6).

In general this setting should affect only on-screen display, not printing. Pages is probably getting it wrong and using this setting when it prints, which is incorrect.
posted by xil at 6:11 PM on January 25, 2011


I think xil has got it, thanks!
This would explain why Pages is no longer reproducing the bug, yet Preview is still rendering the old files crappily. I tried this fix yesterday but assumed it hadn't worked.
posted by krunk at 6:22 PM on January 25, 2011


« Older What places are available to d...   |  Do you know this wordpress the... Newer »
This thread is closed to new comments.


Post