Join 3,372 readers in helping fund MetaFilter (Hide)


Getting XP to play nice on a Mac network
December 11, 2010 2:38 AM   Subscribe

I'd like both computers in the house (one Mac, one XP) to share my WiFi network. This works great as long as the network is open, but I'd like it to be closed.

I'm a Mac guy, not very good with Windows. My router is an Apple Airport Express.
If I go into Airport Utility and set a password for the network, the PC won't connect. It doesn't even ask for a password, it simply says something to the effect of "A connection couldn't be established".
So for now, I went back to an open network, which works OK, but I have hop-ons sucking up my bandwidth.
Any way to keep it closed would be great, either password or MAC address.
Thanks in advance...
posted by Silky Slim to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
The Mac + PC stuff should not present the actual problem. What type of security/encryption is the network using? If its some flavour of WPA if I remember correctly XP needs to install a Microsoft update to be able to handle that.
posted by oxit at 4:17 AM on December 11, 2010


IIRC, the airport uses WPA/WPA2 to secure the wireless, that XP doesn't support without SP2 or higher.

You can try this patch to see if it gets windows to prompt you for the password.

Assuming that does work, you should apply the latest service pack, SP3, to your windows PC, as lower service packs are no longer getting security updates. Simplest is to use Windows Update to install SP3, or use the fix it button to turn on automatic updates.

If that's not the problem, you may need to update the drivers for your wireless network card in XP. If you can find your wireless card in 'device manager', we can advise you on what drivers might work.
posted by ArkhanJG at 4:20 AM on December 11, 2010


I've had success with non-mac devices connecting by using the hex password NOT the alphanumeric password.

This success I've had with the Wii and PCs.
posted by CarlRossi at 6:09 AM on December 11, 2010


Seconding CarlRossi, I've experienced that as well.
posted by 8dot3 at 8:53 AM on December 11, 2010


Try getting both machines connected first, then stealth the router.
posted by PickeringPete at 12:24 PM on December 11, 2010


I have had problems such as you describe above. I got my children's XP machines to connect to the non-stealthed router, using static IP numbers (outside the DHCP pool) and specified OpenDNS servers. Once they connected properly, I turned on the cloaking. The Windows machines each required some fiddling to re-establish the connection but that worked for me.

You might try installing the Airport Utility for Windows and try manipulating your Airport Express with it. In other words, use the Windows machine to set up the password and encryption. See if that helps. And I would make sure that your router is happy to deal with various wireless flavors. Should be an option when you use the Airport Utility. Some people have found that helps.

From what I understand, stealthing the router doesn't give you as much protection as you might think. I would rely on a good password, and MAC filtering.
posted by PickeringPete at 1:53 PM on December 11, 2010


« Older I upload photos - they print a...   |  According to Posterous, I have... Newer »
This thread is closed to new comments.