Join 3,513 readers in helping fund MetaFilter (Hide)


I'm a Mac, and I can't get on the internets.
December 8, 2010 6:29 PM   Subscribe

Wireless internet conundrums. After internet signal problems being repaired by the internet provider and plugging into the modem directly showing that the connection itself is fine, the wireless goes out every few minutes for the Macs in the house, but works fine for the PC.

My roommate and I have cable internet that we run through a Belkin N wireless router (WPA2 Personal encryption or whatever it's called). The router is a couple of years old and has worked fine during all that time. Last week, we started having issues where the internet would work occasionally, but as soon as we tried doing anything bandwidth-heavy, like streaming video or uploading files, the internet would stop working entirely. Resetting the router didn't help. It would start working again randomly minutes or hours later. ISP sent out techs to fix the lines going to the house, said there had been an upstream signal problem, but it was fixed. However, we were still having problems. They came back out and found that there was damage to the lines at the pole itself, but that it was now fixed. It still wasn't working on my laptop, so they had me plug directly into the modem and run a speed test and try to max out the connection by opening tons of YT videos and running several speed tests at once, but everything still worked fine.

However, my roommate and I are still having problems with the wireless. We thought it was the router, but out of curiosity, I tried using the wireless on my old PC laptop and it works perfectly fine. It just doesn't work on our Macs (both MBPs, mine is a couple months old, hers a couple years). I'm able to use wireless anywhere else with no problem, so this is specific to our house.
Our connections go out every five to ten minutes. Turning Airport off and on again gets it working again, but only for a few minutes. Our outages are not always at the same time, like I'll be online and she won't then mine will go out and hers is fine. Another problem is that while it used to be that as soon as I opened my laptop from being asleep/opened a browser window, I was immediately online. Now, however, it takes longer to connect.

I went ahead and opened Network Preferences and timed what was going on when I connect and have a timeline: Turned airport on, it does the flash-type thing on the icon in the toolbar and says in Network Preferences "Not Connected: AirPort does not have an IP address and cannot connect to the Internet." It still says this after the icon is solid. Then, 30 seconds after turning Airport on, it says, "AirPort has the self-assigned IP address XXX.XXX.XXX.XXX [except with the actual numbers] and will not be able to connect to the Internet." About 1 minute later, it says "AirPort is connected to The Internet and has the IP address XXX.XXX.X.X [except with the actual numbers]." Then the internet works.

Then, when it stops working, usually after 3-10 minutes, it still shows the message that it's connected.

We can't figure out the mystery as to why our Macs won't connect properly to the internet while the PC is just fine. Everything worked fine before our internet outage last week. Does anyone have any suggestions as to what might be going on or what we can do to fix it?
Things I've tried: restarting the computer, deleting the network and re-adding it, renewing the DHCP lease. I'm not a total techie, but I'm pretty good at following directions and figuring out computer stuff when necessary. This is my first Mac, so I don't know if there is some special Mac thing I'm not realizing I need to do (my roommate can't think of anything, either).
posted by elpea to Computers & Internet (20 answers total) 3 users marked this as a favorite
 
Just as an experiment, I would force assign an ip on the mac to something at the upper end of the allowable range. For a dlink that may be 192.168.0.255, although probably even .150 would work, just something out of the range of numbers that may be normally assigned by dhcp.

Sounds to me like an ip issue, likely duplicates. Force reset ip's on all systems should fix.
posted by TomMelee at 6:38 PM on December 8, 2010


Just for reference (not much there though), klangklangston was having this same issue yesterday. Were you subject to the massive Time Warner outages of late?
posted by carsonb at 6:44 PM on December 8, 2010


...finishes reading the question completely... oh. So yeah, maybe call your ISP again?
posted by carsonb at 6:46 PM on December 8, 2010


We don't have TWC, but a small provider (Grande, they're only in Austin and San Marcos). I bet they probably use TWC lines to some extent, though. They tested our line and said it was running fine and it all works when we plug directly into the modem or when I use the PC. I'm going to try TomMelee's suggestion and see if that helps. Thanks!
posted by elpea at 8:30 PM on December 8, 2010


Oh, and the ISP won't/can't help me as to router issues. If it works when you plug the computer into the modem, they consider their job done (probably rightfully so).
posted by elpea at 9:36 PM on December 8, 2010


I have a Mac and I have the same problem! My band-aid totally-random fix is to leave my Bittorrent client (Transmission) seeding something all the time (and limiting the upload rate to 1-5 k). This doesn't fix the problem but it somehow keeps my computer connected to the wireless network in my house most of the time. Sometimes it craps out anyway. A real solution would be MUCH appreciated!
posted by monkeymike at 9:57 PM on December 8, 2010


Data point: While trying to persuade my neighbor's Mac Mini to connect via a (non-Airport) wireless link to my house, I found that the connection was utterly flaky if set up via DHCP, but rock-solid with a fixed IP address. I don't think the Mac DHCP client copes well with lost packets.
posted by flabdablet at 11:36 PM on December 8, 2010


Although you have a wireless N router, have you tried switching it over to 802.11g and seeing if it works better? 802.11n is faster than 802.11g but, since it's a newer standard, Belkin's implementation of it may be at odd's with Mac's implementation. You should also go ahead and try a different wireless channel; this is a standard technique in debugging wireless connections as particular channels in your vicinity may be particularly unreliable.

I've also had luck with decreasing the "beacon interval" of my wireless router in order to increase the reliability of connections. Basically wireless routers send out packets every so often in order to synchronise clients and by decreasing it you increase the number of synchronisation packets sent out.

Also, you should log onto your router while your Internet is not working and figure out what it thinks the state of your MBP is. On my D-Link wireless router I can get a list of connected wireless clients, and I'm sure you can get the same sort of information on the Belkin. If there are DHCP issues then you won't see your MBP in this list after the Internet stops working.

Finally, a useful datapoint is to be more precise about what you mean by the Internet "not working". When you're in this state you should: Interpreting the results:
posted by asymptotic at 5:16 AM on December 9, 2010 [1 favorite]


Note: it used to work perfectly fine, so I don't think it's an inherent problem with my router type and Macs playing nice. Im wondering if some setting got changed that needs to go back. I tried all the suggestions so far, and even re-set up the router. No dice. :( Maybe I'll call Belkin.
posted by elpea at 8:23 AM on December 9, 2010


Just for grins, make sure that the mac isn't trying to grab the same IP as the router. For example, linksys use 192.168.1.1, Dlink's use 192.168.0.1, etc. That or it could be on the wrong subnet even. It definitely sounds like an IP conflict to me.

The macs work fine plugged directly into the modem, not just the pc's?
posted by TomMelee at 10:18 AM on December 9, 2010


Yup, the Macs work fine plugged in. I'm guessing it is an IP thing, too, but nothing helps. The router IP is 192.168.2.1, my computer is 192.168.2.6, roommate's is 192.168.2.3. We also both have wireless printers, but I can't print wirelessly anymore since this problem started. My computer says the printer is "offline" even though the printer itself says that it's connected to the internet.
posted by elpea at 3:18 PM on December 10, 2010


So when you log onto your router, and check the list of connected clients, can you see MAC addresses that match both your Macs and both your wireless printers? Can you then check the router's DHCP table, and find out what IP addresses have been handed out to all four client machines?

If the router is too shitty to expose those details: power everything down, then power up the modem, wait for a couple minutes to let it get itself sorted, then power up the router, wait for a couple minutes, then power up one Mac and see if the connection holds up for longer than usual. If it does, power up its wireless printer and test again. Keep powering up devices one at a time, waiting long enough between each to assure yourself that the connection isn't flaky.

When you finally find the connection flaking out, power everything down again. Then bring up the modem, then the router, then the last box you powered up (the one that made things flake out). Make sure that the connection stays solid. Then, power up your other boxes one at a time and test again, but this time power down the last one you brought up before powering up the next one - the idea is to have only two boxes connecting wirelessly at any time, the one that brought on the fault first time around and one other.

Once you have identified which pair of boxes are fighting, check their IP settings carefully and look for conflicts.
posted by flabdablet at 1:24 AM on December 11, 2010


Some updates in the past for Macs have caused problems like this when you encrypt the wireless signal. My only suggestion is to try it without the security and see if you have issue. If you have no problems than it is probably related to this previous issue. The blog post I linked to has some possible workarounds. I also recommend that you make sure you have all the latest updates for your Macs and the router.
posted by roguewraith at 5:56 AM on December 11, 2010 [1 favorite]


The D-link is defaulting to 192.168.2.1? That's uhm...weird.

Can you change it to .0.1? If I were you, I'd delete the stored connections in the computers (all), and then change the default IP to .0.1, which is Dlink normal default. Then I'd reboot all computers and re-add the connection.

I'd bet you a bowl of cheerios that that funky range is the issue for the printers too.
posted by TomMelee at 7:25 AM on December 11, 2010


Some D-Link wireless routers do default to using the 192.168.2.0/24 address range, presumably to avoid conflict with their upstream modems (which usually pick 192.168.0.0/24 or 192.168.1.0/24). As long as all the hosts connected to that router are configured for DHCP, and DHCP is turned on in the router itself, there should be no problem with 192.168.2.0/24.

BUT

if the D-Link router is connected to the WAN modem via one of its LAN ports rather than by its WAN port, then Bad Things will happen. Instead of the router's WAN interface being the only one to be issued a 192.168.0.0/24 address from the modem's DHCP server, both the modem and the router would have DHCP servers visible to the LAN, and those servers would be handing out addresses in two different IP subnets. That would be bad.

BUT

it would not explain the observed behavior, which is a network connection that works for a few minutes and then flakes out.
posted by flabdablet at 4:32 PM on December 11, 2010


I'm going to try your suggestions, but wanted to clarify that it's a Belkin router. Thanks for all the help!
posted by elpea at 5:16 PM on December 12, 2010


Didn't intend to imply otherwise - only that I've seen consumer-grade routers default to using the 192.168.2.x address range before, for perfectly legitimate reasons, and that this is not in and of itself likely to be the cause of any trouble.
posted by flabdablet at 6:22 AM on December 13, 2010


I haven't seen one default there before, but I have seen ones set there before, and differing-brand-adapters weren't looking there for the address, regardless of what DHCP was telling them.
posted by TomMelee at 8:10 AM on December 13, 2010


As long as the DHCP server hands out IP addresses with the same subnet part as the gateway has, and as long as it's also configured to hand clients the proper gateway address, the actual subnet numbers shouldn't matter at all provided they're in one of the private address ranges - as all 192.168.x.y addresses are.

Something else that can make it all not work is using one of a router's LAN ports instead of its WAN port to connect it to the modem. Many modems also function as routers, and I've seen this connection method recommended to avoid client machines needing to go through two lots of NAT routing to get out to the Internet.

But if you do this without disabling the router's DHCP server first, you end up with two active DHCP servers visible to client machines - one in the modem, and one in the router - and if the modem and the router are set to use different IP subnets as they often are by default, exactly which subnet a client ends up in will be a matter of chance.

In that scenario, you could actually make things kind of work by configuring the router to occupy the same IP subnet as the modem. In theory, the two DHCP servers should then negotiate to avoid handing out duplicate addresses. In practice they often don't, and you end up with client address conflicts.

If you've got a modem with an inbuilt NAT router and you want to add more Ethernet ports and wireless by connecting a wireless router to its LAN side, the right thing to do is turn off the wireless router's routing brains (the setting that does this will be called something like "Disable NAT" or "Use as WAP"), then wire the router's WAN port to the modem's LAN port. The router should then turn its own DHCP server off and pick up an address for itself from the modem's DHCP server, which will also become accessible to clients via the router's LAN ports and wifi. This puts the modem in sole charge of all IP addressing, and makes the router's default settings irrelevant.

Having done this, it's also a good idea to tell the modem's DHCP server to reserve a fixed IP address for the router's MAC address, just to make it less tedious to gain access to the router's inbuilt control server from computers on the LAN. Most modems make this fairly straightforward.
posted by flabdablet at 2:25 AM on December 14, 2010


Turns out my roommate had an extra router from her old place and we just switched them out. This solved the problem. Still never figured out what was going on with the other router, but I got tired of messing with it. Thanks for all the suggestions!
posted by elpea at 1:20 PM on January 9, 2011


« Older I'll be turning 21 in a couple...   |  Wardrobe oxymoron? Seeking ac... Newer »
This thread is closed to new comments.