Join 3,433 readers in helping fund MetaFilter (Hide)


Old hack, new trick?
October 20, 2010 8:52 AM   Subscribe

Netbook/Windows Starter 7 question: What is the filename (and path) for the default, non-changeable background (wallpaper) image? Can I just save what I want as that file and have it use that instead?

I remember thinking we were cool 3000 years ago doing this for the startup image in Windows. Will this trick work here?

(I had no idea what the "Starter" thing was about, and now that I've got it I realize how annoying it is (no DVD playback, really??). I think I'll probably end up installing Ubuntu instead, but in the meantime, this will soothe my annoyance if it works.)
posted by fiercecupcake to Computers & Internet (6 answers total) 3 users marked this as a favorite
 
Can I just save what I want as that file and have it use that instead?

I remember reading something somewhere recently that said this doesn't work.

However a Google search reveals this guide. Not tried it myself though.
posted by EndsOfInvention at 9:02 AM on October 20, 2010


Wow. In changing the wallpaper, you are breaking the EULA. Seriously: "You may not • work around any technical limitations in the software; • customize the desktop background..." Here is how to change the XP Welcome screen, but from this discussion (source of the EULA quote), there is another good comment:
Resetting permissions on the file and overwriting will not work, as shell32.dll has code which compares the image with a SHA-256 hash. The only option other than tampering with the files yourself in a hex editor is using Stardock MyColors, though you must use an entire theme.
Without getting Stardock My Colors, you can try these How To Geek tips to customize Win7 Starter, though their wallpaper changer suggestion will result in a 320×240 image or slideshow. Another blog had this comment:
hi all. i just bought a dell mini 10 with windows 7 starter. im able to change my wallpaper by using stardock mycolors, it really works. You can download it for free. I downloaded the diamond theme, then from there the wallpaper can be changed. i hope this helps.
Good luck!
posted by filthy light thief at 10:33 AM on October 20, 2010


The "How To Geek" link filthy light thief posted has this in the comments, from "b0rek":
1. Open regedit (aka registry editor; you can access it from the star menu by typing “regedit” in the search box…)
2. Go to “HKEY_CURRENT_USER\Control Panel\Desktop\” folder and click on it
3. On the right hand side find there are a bunch of entries. Find the key named “Wallpaper” and double click on it and put the path of the picture you want as your new wallpaper (example path is “C:\Users\Bob\Pictures\new_wallpaper.jpg”)
4. Right-click on the “Desktop” folder in regedit that you found in step 2 and click Permissions.
5. Click “Advanced”
6. Go to “Owner” tab, highlight your name in the box that says ʽChange owner toʼ ( There are only two choices the other is Administrator )… once your user name is highlighted click “OK”
7. Click on “Advanced” again
8. Uncheck the button that reads “Include inheritable permissions from the objectʼs parent”… click “Remove” when prompted
9. Click “Add”
10. Type “Everyone” and click “OK”
11. Check Allow “Read Control” and click “OK”
12. Click “OK” again
13. Highlight “Everyone” and check to Allow “Read” and click “OK”
14. Restart Computer and enjoy new Wallpaper
which seems to me to be basically the same thing another commenter ("Bubbles the Monkey") said on the "Another blog..." link:
In a nutshell, “\\HKEY_CURRENT_USER\Control Panel\Desktop\Wallpaper” is the registry location where Windows stores the file name to use as the wallpaper image (for those of you who don’t know, the Registry is simply a place where Windows stores all of the configuration details for every single aspect of Windows, and can be viewed with the program RegEdit.exe). The default value for the wallpaper is “%windir%\web\wallpaper\windows\img0.jpg” (where %windir% is shorthand for your Windows directory, usually c:\windows\). Also by default, this image file is protected and this registry entry is protected. However, you can override these protections by changing the owner of the file and the owner of the “Desktop” branch of the registry.

The reason why people get a black screen after they change either the image, or the image file name in the registry, is because the windows DLL responsible for displaying the wallpaper checks if its the original image file or not. If its not, it clears the wallpaper entry in the registry (resulting in no image being displayed on the desktop, leaving it black). The solution then, is to make the registry entry read only, so that windows cant change the registry entry to an empty value again if the image file is different from the original.

Make sense so far?

So, the easiest solution is this:

Go to the “c:\windows\web\wallpaper\windows\” folder, and rename the img0.jpg file to something else (a backup), and then copy your desired wallpaper image file to this folder, and rename it to img0.jpg. Then open regedit.exe and go to the “\\HKEY_CURRENT_USER\Control Panel\Desktop\” branch. Right click on “Desktop” in this branch and select Permissions from the pop-up menu. Click on the Advanced button, go to the Owner tab, and select your login user name from the list of possible owners. Click OK, and then OK again to close the Permissions dialog. Now go back into the Permissions dialog (with yourself now as the owner of this registry branch). Click on the Advanced button again, and now click on the Add… button. Enter “Everyone” and press OK, you’ll get a list of permissions to choose from next, select the last one Read Control, and press OK. Finally select your user name from the same list of “Permission Entries” / “user names”, and press the Edit button. This is the most important step … from the list of permissions, make sure that Full Control, Set Value, Delete, Write DAC, and Write Owner are NOT selected. Clear them if they are, and press OK. Before you close the Advanced dialog, make sure the “Include inheritable permissions from this objects parent” is NOT checked, and press OK to close the Advanced dialog, and then OK again to close the Permissions dialog.

You are done. Now close regedit, and restart Windows, you should now have your own desktop wallpaper :)
Any thoughts?
posted by fiercecupcake at 11:22 AM on October 20, 2010


Well, did it work?
posted by defcom1 at 4:16 PM on October 20, 2010


I don't have Win7, but since there are two write-ups that appear to say the same thing (or close to the same thing), I think it should work.

If you have never mucked around in regedit before and are at all hesitant about this, back up your registry. That way, if you do mess something up, you can undo it with ease.
posted by filthy light thief at 4:17 PM on October 20, 2010


I chickened out and installed that Stardock MyColors thing; it's been too long since I've played around in regedit. Note to anyone else doing this: pick a theme you like the colors of, because you can change the wallpaper (!) but not the colors or the associated icons.

I didn't really feel like the Stomachache-of-Computer-Problems visiting me last night. I may eventually put my big-girl panties on and try the regedit trick.

So: success, with the Stardock MyColors free download, then adding pictures to the Windows default wallpaper directory (Pictures?), and selecting those.
posted by fiercecupcake at 7:18 AM on October 21, 2010


« Older Help me find a good eye doctor...   |  How can I seek treatment for p... Newer »
This thread is closed to new comments.