Join 3,564 readers in helping fund MetaFilter (Hide)


I suppose that I could just use Safari, or something...
May 18, 2010 4:07 PM   Subscribe

On Firefox, youtube only gives me the message "An error has occurred, please try again later".

This started a while ago, but curiously enough embedded youtube videos would play fine, they would only not work if I was actually trying to view them on youtube proper. Lately, that too gives the same error.

However, the videos play fine on Safari, nary an error to be seen. The only suggestions that I've found online are to delete my youtube cookies, which has done not a whit of good.

I've updated to the latest flash player to try fix it that way, and that also hasn't helped. I am running Mac OS X 10.5.8.

Any ideas how to fix this?
posted by vernondalhart to Computers & Internet (13 answers total)
 
Totally random guesses, but based on experience of things like this:

1) Do you have the very latest Firefox? If not, install it.
2) Clear cache.
3) Restart the computer, if you haven't since this started.
4) Actually remove (get to the point where you see a "You need flash" message) and reinstall the Flash player. On Mac in particular, it can often get confused about knowing what version you have.
posted by drjimmy11 at 4:43 PM on May 18, 2010


Did you opt in YouTube's HTML5 version? I did and I get the same behaviour.
posted by clearlydemon at 5:07 PM on May 18, 2010


As near as I can tell, I have the latest firefox (3.6.3), I've restarted both computer and browser (which clears the cache), and I've just reinstalled Flash player after having uninstalled it as completely as I can.

Still no go.

Also, neither with, nor without the HTML5 works.
posted by vernondalhart at 6:00 PM on May 18, 2010


It probably wouldn't be helpful for me to say that you bought a mac, so you should just stick to the software they supplied you with. At some point Google, Firefox, and Apple will get past their codec wars and things will start to work again.

This thread indicates Chrome may work. Have you tried that?
posted by Mr. Gunn at 6:49 PM on May 18, 2010


It's not that helpful, not, but it's not necessarily wrong. However, this is a recent thing (or relatively so): as stated in the question, it used to be fine, then it used to only work for embedded youtube videos (????) and now, nothing.

Perhaps I should give Chrome a try. I'm not really a huge fan of safari, and it is annoying to switch browsers just to watch the occasional linked video.
posted by vernondalhart at 7:19 PM on May 18, 2010


That should read: "It's not that helpful, no..."

I'm not a seventh grader, I swear.
posted by vernondalhart at 7:20 PM on May 18, 2010


This just happened to me as well. I am interested in a solution as well. Already tried the suggestions posted above but no result.
posted by Danniman at 7:30 PM on May 18, 2010


This has also been happening to me today...
posted by avidreader at 9:13 PM on May 18, 2010


You may have already tried this, but it's probably worth disabling any extensions you have installed and trying it. If that works, you can re-enable the extensions one by one until you find the one that's choking it.

Another possibility is to delete any cookie from Youtube.

If those fail, try to locate all of the Firefox pref files, delete them and Firefox itself (you may want to use a program like "app zapper" that roots out all of the related files scattered in various libraries), and re-install it cold.
posted by nonliteral at 9:17 PM on May 18, 2010


Well, as said in the question, I already tried deleting all youtube cookies to no avail.

Having now tried disabling every extension I have in firefox, still no luck.
posted by vernondalhart at 9:38 PM on May 18, 2010


I had this problem with Firefox for the last few weeks, and suddenly today Youtube started working again. I did change some settings last night, and I suspect that's what did it:

- Cookies: next to "Keep until," switched from "ask me every time" to "they expire"
- Deleted all cookie exceptions

Maybe I was inadvertently blocking something necessary from youtube? Well, maybe it'll work for you too.
posted by cirripede at 9:59 PM on May 18, 2010


Weird. This is all over mozilla forums, Yahoo! Answers, Google support, and whatnot -- and nothing seems to have nailed down the real problem. I went through several iterations of settings, including uninstalling and reinstalling Flash, but what worked for me was:
* Logging out of YouTube
* Remove YouTube.com cookies (in Options|Privacy|Show Cookies)
[actually it started working here]
* Log back into YouTube using my Google Account settings
[still works]

It may have been one specific cookie of the half dozen YT uses, but I didn't test it out that finely.
posted by dhartung at 10:10 PM on May 18, 2010


Faugh, there had been a long-standing block to youtube cookies, I guess that I'd not noticed when I switched my cookie settings ages ago. Having removed that block, videos seem to work now.
posted by vernondalhart at 10:11 PM on May 18, 2010


« Older I was just given a pay-cut as ...   |  What songs could me and my fri... Newer »
This thread is closed to new comments.