Skip

Blu-Ray Makes My Mac Mini Turn Green With Envy
December 18, 2009 2:05 PM   Subscribe

How can I get my Mac Mini and my new Blu-Ray player to play nice while they both share my big screen HDTV?

I've been using my Visio VW46L as a monitor for my Mac Mini. I plug the DVI to HDMI cord into HDMI port #1 and everything has been well. The whole internet just looks better when it's 46" big.
Until now.

I purchased a Phillips BDP-5010 Blu-Ray Player.
Plugged it into a second HDMI port on my TV.
Looks fabulous!
Until I hit the input button and go back to the HDMI input that I use for my Mac Mini.
Everything that should be blue is GREEN.
Now nothing looks fabulous.

If I unplug the Blu-Ray player HDMI, unplug the TV and then plug it in and turn it back on (what I figure is the equivalent of rebooting a television), the Mac Mini's colors are back to normal and spiffy.

Do I have what I might loosely term a HDMI conflict?
Is the TV incapable of multiple 'profiles"?
Are the settings or whatever for my Blu-Ray 'leaking' over to my Mac Mini?

Needless to say, it's going to be a big PITA to have to go through all this plugging and unplugging and turning off nonsense when I want to check email without everything looking a sickening shade of green.

Any ideas on what's causing this color shift and how I can get my toys to play well with each other?

As always, thanks for all your help, I truly appreciate it.
posted by willmize to Technology (5 answers total) 2 users marked this as a favorite
 
Might be your cable. I have that issue occasionally with a monoprice purchased mini-displayport -> DVI dongle.

Also, is your Mini asleep before you switch the inputs over? You might want to try waking it up before you switch (if you haven't tried that already).
posted by wongcorgi at 2:11 PM on December 18, 2009


@wongcorgi (and maybe others): Just a quick clarification. I'm using two separate cables.
For the Blu-Ray, it's an HDMI to HDMI living in my TV's 2nd (of three) HDMI ports.
For the Mac Mini, I'm using a DVI to HDMI cable in a separate HDMI port on my TV.
I've been leaving them both in when switching back and forth between them via the TV's remote control.
And no, the Mac Mini is awake and functional when I'm switching over to the Blu-Ray player.
Hopefully this helps a bit.
posted by willmize at 2:18 PM on December 18, 2009


Are there any firmware updates available on Philips' web site for your Blu-Ray player?

You might also contact Vizio's tech support.
posted by Blazecock Pileon at 3:29 PM on December 18, 2009


A couple things to try:

1) Do you get the same effect when you switch the ports on your TV (Mini to port #2, Blu-Ray to port #1)?

2) When you have a good picture from the Mini, look in the Displays settings panel to see how the Mini is identifying your TV. Now do the switch so it messes up the color and see if the ID has changed. If it has, that might give you an avenue of exploration. There's such a thing as losing EDID info, but that usually screws up the resolution rather than the color. However, EDID can carry color depth, so there might be something there. If you decide it is an EDID problem, take a look at the DVI Doctor.

In some displays, there is a separate EDID chip for each port, so I guess it could be possible to have different "profiles".
posted by joaquim at 3:38 PM on December 18, 2009


Well, after another hour of trying to figure this problem out, I admitted defeat and returned the Blu-Ray player. I guess it just wasn't my time to upgrade to 1080. I shall have to live with my 480 and be happy with it for now :)
Much thanks to everyone who answered, I appreciate it and took them all into consideration when trying to figure out this issue.
Either I will find a player that will play nice, or I will have to move the computer back into the spare bedroom with the little 19" screen, which I am sure it will not be happy about :)
Thanks again!
posted by willmize at 5:48 PM on December 20, 2009


« Older How do I find someone to buy/l...   |  Is this street art in Brooklyn... Newer »
This thread is closed to new comments.


Post