Join 3,494 readers in helping fund MetaFilter (Hide)


Help me connect!
August 31, 2009 4:02 PM   Subscribe

Help me connect to my girlfriend's wireless network!

My lovely girlfriend has a closed wireless network set up at her house (it requires a WPA2 Personal password to access and it's hidden from Airport's network scan). I have the network name and the password, and I've joined through Airport. I get full bars, but no actual internet connectivity whatsoever.

Neither my girlfriend nor I are particularly computer-savvy. We're not sure if maybe she needs to give my computer special permission from hers, or what. I don't know if this matters, but we both use Macbook Pros--she's running Leopard and I'm running Tiger.

Thanks so much.
posted by scarylarry to Computers & Internet (12 answers total) 2 users marked this as a favorite
 
MAC filtering?

Do you can get IP address?
posted by wongcorgi at 4:09 PM on August 31, 2009


The symptoms sound similar to issues I have had with wireless drivers that do not handle WPA. I fixed the issue by switching to a different wireless card.

Some diagnostics to see what your situation is more specifically:

If you are connected to the AP, it gave you an IP address, try pinging that IP address from another computer on the network (for example if your computer says it has "192.168.1.102" as an IP address, have your girlfriend run the following command in Terminal "ping 192.168.1.102". Control-C or closing the terminal will make the ping stop.)

If she can ping your computer, but you still are not finding anything on the internet, copy the file "/etc/resolv.conf" from her computer onto yours, and then see if you can find web pages after that.
posted by idiopath at 4:26 PM on August 31, 2009


Grab both computers and sit them next to each other. Solemnly swear not to change any settings on GF's computer but simply look and see what those settings are.

Go to System Preferences, Network setting. Network name: should be your GF's network. Now click "Advanced" (you may need to "unlock" (click on the padlock if it's closed) to do this.)

Go to the TCP/IP Tab.
If "Configure IPv4" says "manually" on GF's computer, yours should too.
In this case: copy the info in the fields from her computer to yours, except for the "IPv4 address" field. You need your own address, so copy it over identically, but change the last number. (so if her # is something like 192.168.0.2, you should put in 192.168.0.3)

Make sure "Router" is filled in and matches her settings

HOWEVER
If her "Configure IPv4" says "Using DHCP" (or something else) then you should mirror her settings and click "renew DHCP lease" to get an IP address.

NOW:
Go to the DNS tab. Make sure you input the numbers that she has.

(Check under the proxies tab too, but she probably doesn't have any set. This is fine.)

Done? hit "OK" to go back to the non-advanced pane, and then "apply".

Test the internet. Win? you're done. Fail? continue reading.

Now open up whatever browser your GF uses for the internet, and go to the preferences for this. (Again, change stuff on YOUR computer, not HERS) and make sure that your internet connectivity preferences match.

Try restarting your browser and trying the internet again. If these steps don't work, let us know.

------

What kind of wireless router are you using?
posted by titanium_geek at 4:41 PM on August 31, 2009 [3 favorites]


It could be a wireless driver issue as well, but the first step is to make sure the settings match up.
posted by titanium_geek at 4:42 PM on August 31, 2009


Don't hide SSIDs. Just don't.
posted by flabdablet at 5:00 PM on August 31, 2009


Your question just prompted me to FINALLY call D-Link to try to figure out my wireless connectivity issue, which sounds like it may be the same thing. (Macbook Pro, Tiger, network shows up but won't connect, etc.)

Here's what I did:

Change the SSID by adding a 1 at the end. (Why? I do not know.)
Change the encryption to WEP 64-bit.
Use a 10-digit all passkey of all numbers.
To connect on a Mac, use a dollar sign at the beginning of the password when signing in via Airport.

I am posting this comment on my wireless connection. Aw yeah. Good luck!
posted by nosila at 7:02 PM on August 31, 2009


titanium_geek, thanks for your extremely easy-to-follow walkthrough. We tried everything you suggested, and I'm still not able to connect to her network.

I was able to connect to an unsecured wireless network, however, so I know it's not my wireless card.

The router she's using is an Airport Extreme router. Any further suggestions?

Thank you all so much.
posted by scarylarry at 7:53 PM on August 31, 2009


nosila, you really, really really don't want to be using WEP. If you want to run an open network, turn the security off altogether. If you don't, use WPA2 or WPA. WEP is trivially crackable and not worth your trouble.
posted by flabdablet at 8:39 PM on August 31, 2009


Also, I have a vague recollection of having trouble connecting a friend's MacBook to my own WPA-secured network (I'm a Linux boy, not a Mac boy) and I remember being really surprised to find that you had to actually tell the Mac to use WPA instead of WEP (isn't this the Just Works computer?) and that finding where to tell it was fiddly and annoying.
posted by flabdablet at 8:42 PM on August 31, 2009


Alright, need more info.

So, Airport Extreme. I'm afraid I don't have one, but how do you configure this? Can you have a look at the settings? Can you log in to the router via a browser (point it at http://192.168.0.1 or whatever the router's IP address is)

Under System Preferences - Network - Airport Tab, click on the name of your girlfriend's network. Click on the pencil (the / one next to + and -) to edit. Make sure you type in the password extra carefully and make sure you have the same WPA2 setting as your girlfriend, there may be WPA2 personal and WPA2 business... ?

this apple discussion might be of use.

What are the symptoms of "no internet" ? What does firefox/safari/etc say when they can't load pages? Can you ping?

To ping: open up terminal and type: ping -c5 192.168.0.1 (assuming 192.168.0.1 is something on the network) (find out your gf's IP from her settings)
then try: ping -c5 www.google.com (what does it say?)
posted by titanium_geek at 9:02 PM on August 31, 2009 [1 favorite]


I think that the AirPort base stations are configured using an application on a connected computer; they may have a built-in web server but that is not really how they are meant to be used.

The AirPort Extreme Setup Guide is here.

If you want to look at that, and then (from your GF's computer) browse the configuration and let us know how it's set up, we might be able to give you more help. My guess is MAC locking, if someone else set this up at some point in the past and was really paranoid. (I think MAC locking is stupid, and in the same vein as SSID hiding or using WEP; MAC addresses can be trivially spoofed. If it's on, I'd just turn it off and use WPA-PSK by itself.)
posted by Kadin2048 at 10:46 PM on August 31, 2009


Success! We reconfigured the network with Airport Utility. (And the network is no longer hidden.)

Thanks, everyone, for all the advice!
posted by scarylarry at 9:44 AM on September 1, 2009


« Older How can I break contract with ...   |  What are some good protein-ric... Newer »
This thread is closed to new comments.